locked
File in uso da un altro utente RRS feed

  • Domanda

  • Buongiorno,

    Ho un problema con l'accesso a dei file di Excel in rete. Vi spiego. Ho un rete di dominio formata da una 15 di PC con Windows 7 Pro 64 bit, installato ovunque Office 2010 Home & Business e un Server sbs 2008 che tra le altre cose fa da File server.

    Capita che su 2 utenti quando accedono a dei file di Excel, non specifici, condivisi in rete sul server, ogni tanto, e sottolineo ongi tanto, gli appare il messaggio "File in uso da un altro utente...aprire in sola lettura" senza specificare che utente e soprattutto nessun altro utente accede al file in quel momento.

    Sapete se c'è una soluzione per risolvere il problema?

    Grazie mille

    venerdì 30 marzo 2012 08:17

Tutte le risposte

  • Ciao, potrebbe essere il classico problema dovuto ai thumb DB che ti blocca i files.

    Prova a vedere qui. Poi facci sapere!

    A.

    How to Turn off Caching of Thumbnails in Thumbs.db Files

    People sometimes report that they cannot manipulate their folders as they want to because Explorer has a Thumbs.db file open.  Windows 7 apparently generates these files for compatibility with older software that may expect such files to exist in folders with, for example, photos in them.

    Unless you're running such old software, you can just turn this off without consequences (except that your system won't be fooling with your photo files to make Thumbs.db files in the background).  Thumbnail views will STILL WORK, as Windows 7 Explorer now actually stores its thumbnails in a central database for its own use.

    With Windows 7 Professional and above you can disable this through the Group Policy Editor:

    • Click the Start orb
    • Enter gpedit.msc in the search box and hit Enter.
    • Expand User Configuration - Administrative Templates - Windows Components.
    • Click on Windows Explorer.
    • Right-click the entry "Turn off the caching of thumbnails in hidden thumbs.db files" and choose Edit.
    • Enable the setting.

    Note: If you have a version of Windows that does not provide the Group Policy Editor, the above change can be done through a registry modification. NOTE: BE VERY CAREFUL WHEN MODIFYING THE REGISTRY.

           [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\ Explorer]

           DisableThumbsDBOnNetworkFolders   REG_DWORD    0x00000001

    You will want to log off and back on again (or reboot) after making these changes.

    venerdì 30 marzo 2012 08:48
  • Grazie mille!

    Alla prima occasione proverò e vi farò sapere.

    Grazie

    venerdì 30 marzo 2012 09:08
  • Ma i tumb.db  bloccano le operazion sulle directory  (essendo loro stessi "locked")? o mi sbaglio? http://support.microsoft.com/kb/2025703

    Questo particolare problema si manifesta quando tenta  di accedere ad un file excel presente in una condivisione di rete. All'apertura del file, viene visualizzato un errore "File in uso da un altro utente...aprire in sola lettura". Excel visualizza "un altro utente", invece del nome di un utente reale, quando non riesce ad individuare chi ha bloccato il workbook. Il problema accade tipicamente su sistemi vista/window7 che accedono ai file in una risorsa di rete condivisa da un windows 7 o windows 2008...

    http://blogs.technet.com/b/the_microsoft_excel_support_team_blog/archive/2011/05/02/file-is-locked-for-editing-by-another-user.aspx

    Ciao


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!

    venerdì 30 marzo 2012 10:02
  • Grazie...la prima volta che sarò dal cliente vi farò sapere se ha funzionato.

    Grazie ancora

    Ciao

    mercoledì 4 aprile 2012 10:39
  • ok aspettiamo

    Ciao


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!

    mercoledì 4 aprile 2012 20:15