Update-SPSolution Error on second WFE


  • I've just tried to update a core solution to our SP2010 farm (same one used previously) and it worked on our first web front end but failed on the second one. Central Admin shows:

    'Some of the files failed to copy during deployment of the solution.'

    followed by

    Access to the path 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Template\Features\<resourcename>\MasterPages\Home.aspx' is denied.

    This is the first time we have updated any solution with this new front end server (though the previous version deployed to it when we first built the WFE and everything else is working fine.

    Now the WFE is out of service - when browsing to it you get 'could not load file or assembly '<this solution>, the system cannot find the file specified.

    Could anyone advise what might have happened and how I can redeploy just to this server to avoid breaking the other working one?

    giovedì 29 marzo 2012 16:40


Tutte le risposte