none
Problemi Sql Server 2012 Best Practices Analyzer RRS feed

  • Domanda

  • Salve, sto approntando upgrade del mio server cluster active/passive da
    sql2008 enteprise ad sql2012 enterprise. Leggendo il white paper Upgrade
    Techinical Reference, ho scaricato il SQL Server 2012 Best Practices
    Analyzer, in combinata con la Baseline 2.0, quando lancio il programma dopo
    avere inserito i settaggi ricevo questi errori:
    User is not a member of Administrators group on remote machine, OR _x000A_2.
    Powershell Remoting is not Enabled on Remote Server;
    <S N="Resolution">_x000A_1. Add user as a member of Administrators group, OR
    _x000A_2. Run Commands &lt;b&gt; Enable-PSRemoting -f&lt;/b&gt; through
    PowerShell command prompt using elevated privileges, AND _x000A_3. Run
    Command &lt;b&gt; winrm set winrm/config/winrs
    `@`{MaxShellsPerUser=`"10`"`}&lt;/b&gt; through PowerShell command prompt
    using elevated privileges</S>
     
    Premetto l'utente loggato sul server attivo del cluster è l'amministratore
    di dominio.
     
    Grazie
     
     
    lunedì 27 agosto 2012 12:28

Risposte

  • Ho risolto, in quanto commettevo l�??errore che quanto sceglievo il computer da connettere mettevo il nome dell�??instanza di sql cluster, invece ha funzionato appena ho messo come nome server quello del nodo attivo.
     
    Grazie
    martedì 28 agosto 2012 15:40

Tutte le risposte

  • Non è un problema di permessi. Devi abilitare l'esecuzione remota di comandi Powershell sul server che stai scansionando con BPA. Te lo dice chiaramente l'errore: "Powershell Remoting is not Enabled on Remote Server".

    Lancia sul server "target" da powershell: Enable-PSRemoting -f e riprova...

    Ciao!


    Danilo Dominici MCP MCDBA MCITP MCSE MCAD Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    lunedì 27 agosto 2012 15:35
  • Quando lancio il comando Enable �??PSRemoting �??f, mi dice gestione remota windows già impostato per la ricezione di richieste in questo computer, gestione remota windows già impostato per la gestione remota  in questo computer.
     
    martedì 28 agosto 2012 06:52
  • Hai provato ad eseguire BPA come amministratore (intendo l'opzione "Esegui come amministratore", non l'utente di dominio...) ?

    Da dove stai eseguendo l'installazione ?


    Danilo Dominici MCP MCDBA MCITP MCSE MCAD Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    martedì 28 agosto 2012 10:28
  • Ho risolto, in quanto commettevo l�??errore che quanto sceglievo il computer da connettere mettevo il nome dell�??instanza di sql cluster, invece ha funzionato appena ho messo come nome server quello del nodo attivo.
     
    Grazie
    martedì 28 agosto 2012 15:40