none
companyweb - impossibile accedere alla pagina RRS feed

  • Domanda

  • Ho dovuto reinstallare nuovamente SBS 2003.

    purtroppo però adesso non funziona più il sito intranet.

    se faccio http:\\companyweb ricevo errore "impossibile trovare la pagina"
    e lo stesso errore lo ricevo dalla maggior parte dei link della finestra
    principale "gestione server" ....in particolare da tutti quei link che
    necessitano di iis e share point.

    ho controllato gli eventi: tutto ok

    ho controllato il DNS che ci sia companyweb: ok

    scheda di rete: ok

    non so più cosa fare, ho già tentato di ripristinare la connessione ad internet dal pannello "gestione server" ma niente.

    mi potete aiutare?

     

    grazie

    Riccardo

     

    mercoledì 23 marzo 2011 11:31

Risposte

Tutte le risposte

  • ci proviamo :)

    prima domanda: iis si è reinstallato ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    mercoledì 23 marzo 2011 12:12
    Moderatore
  • ciao Edoardo,

    sì, sono partito da una installazione pulita.

    mercoledì 23 marzo 2011 15:32
  • non ho chiesto se sei partito da un'"installazione pulita". ho chiesto se in questo momento IIS risulta installato e gestibile da IIS Manager.
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    giovedì 24 marzo 2011 08:34
    Moderatore
  • sì,

    IIS risulta installato e gestibile da IIS Manager

    giovedì 24 marzo 2011 15:26
  • ciao Edoardo,

    ho ricontrollato tutto. ma apparentemente è tutto ok. non capisco dove sto sbagliando.

    hai qualche suggerimento da darmi'

    ciao e grazie

    Riccardo

    venerdì 25 marzo 2011 11:43
  • bene, se apri iis manager e fai click col destro sul sito del companyweb, scegli proprietà trovi definito il default document per la root del sito ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    domenica 27 marzo 2011 17:32
    Moderatore
  • ciao Edoardo,

    sì, trovo definito e abilitato in Documenti il Default.aspx; Default.htm; Default.asp e index.htm.

    però credo che il mio problema sia dovuto alla versione di ASP installata.

    dico una fesseria, credo che durante l'esecuzione dalla Console di Gestione Server > Internet e Posta Elettronica, la prima volta l'SBS vuole la v 1.1.4322.

    invece io credo di aver aggiornato il server alla v. 2.0 prima di eseguire il comando > Internet e Posta Elettronica.

    lunedì 28 marzo 2011 08:07
  • non credo che sia un problema della versione del framework, che comunque puoi provare a cambiare andando sempre in proprietà del sito in questione e poi sulla tab "ASP.NET" dove, nel menu a tendina, puoi scegliere la vrsione del framework.

    ti consiglio anche di leggere qui http://www.winvistatips.com/companyweb-problem-t639737.html

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 28 marzo 2011 08:32
    Moderatore
  • ho trovato "Non Consentire" sull'Estensione servizio Web in ASP.NET v2.0.50727.

    gli ho dato "consentire" e adesso, quando digito http://companyweb mi resituisce questo errore nella pagina:

    Errore Server nell'applicazione '/'.

    Errore di runtime.

    lunedì 28 marzo 2011 10:38
  • hai provato a mettere il framework 1.1 al posto del 2.0 ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 28 marzo 2011 11:33
    Moderatore
  • sì, avevo già provato. ma mi dà lo stesso errore
    lunedì 28 marzo 2011 11:58
  • riporta l'errore per esteso con tutti i dettagli.
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    lunedì 28 marzo 2011 12:15
    Moderatore
  • Errore server nell'applicazione '/'.

    Errore di runtime
    Descrizione: Errore di un'applicazione sul server. Le attuali impostazioni personalizzate relative agli errori dell'applicazione impediscono di visualizzare ulteriori dettagli sull'errore riscontrato.

    Dettagli: Per attivare la visualizzazione dei dettagli di questo messaggio di errore specifico sul server locale, creare un tag <customErrors> in un file di configurazione "web.config" memorizzato nella directory principale dell'applicazione Web corrente. L'attributo "mode" del tag <customErrors> deve essere impostato su "RemoteOnly". Per attivare la visualizzazione dei dettagli sui computer remoti, impostare "mode" su "Off".


    <!-- File di configurazione Web.Config -->

    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly"/>
        </system.web>
    </configuration>
     

    Note: È possibile personalizzare la pagina di errore corrente modificando l'attributo "defaultRedirect" del tag di configurazione <customErrors> dell'applicazione in modo che punti all'URL di una pagina di errore personalizzata.


    <!-- File di configurazione Web.Config  -->

    <configuration>
        <system.web>
            <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    lunedì 28 marzo 2011 12:26
  • cosa ottieni nel browser se punti alla stessa pagina agendo dal server stesso ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    martedì 29 marzo 2011 09:02
    Moderatore
  • Ciao Edoardo,

    l'errore che ho riportato Lunedì è quello che ottengo nel browser dal Server.

    quello che inserisco sotto è quello dal client.

    Errore server nell'applicazione '/'.
    --------------------------------------------------------------------------------

    Errore di runtime
    Descrizione: Errore di un'applicazione sul server. Per motivi di sicurezza, le attuali impostazioni personalizzate relative agli errori dell'applicazione impediscono di visualizzare in modalità remota ulteriori dettagli sull'errore riscontrato. Tali dettagli possono essere tuttavia visualizzati nei browser eseguiti localmente sul server.

    Dettagli: Per attivare la visualizzazione dei dettagli di questo messaggio di errore specifico sul server remoto, creare un tag <customErrors> in un file di configurazione "web.config" memorizzato nella directory principale dell'applicazione Web corrente. L'attributo "mode" del tag <customErrors> deve essere impostato su "Off".


    <!-- File di configurazione Web.Config -->

    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>
     

    Note: È possibile personalizzare la pagina di errore corrente modificando l'attributo "defaultRedirect" del tag di configurazione <customErrors> dell'applicazione in modo che punti all'URL di una pagina di errore personalizzata.


    <!-- File di configurazione Web.Config  -->

    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>
     

     

    scusami, non lo avevo specificato prima.

    ciao

    martedì 29 marzo 2011 13:23
  • Ciao Edoardo,

    l'errore che ho riportato Lunedì è quello che ottengo nel browser dal Server.

     

    sul server nella barra degli indirizzi del browser puoi provare a mettere al posto di

    http://companyweb

    questo

    http://localhost

    e dirmi cosa ti viene scritto ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    martedì 29 marzo 2011 15:02
    Moderatore
  • entro nella pagina "Windows Small Business Server 2003"

    e più sotto posso scegliere tra 4 possibilità:

    1) Sito Web dell'azienda (se clicco sul link mi riporta alla pagina con l'errore)

    2) Configurazione guidata rete (questa mi porta alla pagina dove posso installare da client)

    3) Area di lavoro sul Web (Qusta mi dice "Applicazione server non disponibile" L'applicazione Web a cui si sta tentando di accedere sul server Web non è correttamente disponibile. Per ripetere la richiesta, fare clic sul pulsante Aggiorna del browser. Nota per l'amministratore: Per informazioni dettagliate sulla causa dell'errore specifico del fallimento della richiesta, vedere il log eventi dell'applicazione del server Web. Per scoprire la causa dell'errore, vedere la voce corrispondente al log.

    Nell'event viewer Applicazione mi ha inserito l'rrore ID Evento: 1062 "It is not possible to run two different version of ASP.NET in the same IIS process. Please use the IIS Administration Tool to reconfigure your server to run the application in a separate process.

    (è la prima volta che mi compare)

    4) Informazioni e risposte (funziona il link)

    ciao

    martedì 29 marzo 2011 15:37
  • Ciao Edoardo,

    Ho replicato in ambiente virtuale la mia situazione e ho rilevato che, come sospettavo, se installo l'SBS completamente senza eseguire gli aggiornamenti, non ho nessun problema. Poi eseguo gli aggiornamenti e tutto fila liscio. nessun errore.

    Se però installo l'SBS e, prima del completamento, eseguo l'aggiornamento di Windows, mi installa anche il framwork 2.0. Al completamento dell'installazione mi dà di gli errori che ti ho riportato. 

    A questo punto mi consigli (casomai provo in ambiente virtuale) di provare a disinstallare il framwork 2.0 ?

    ciao  e grazie ancora

    Riccardo

    mercoledì 30 marzo 2011 10:49
  • mi hai scritto che hai provato a sostituire il framework 2.0 con il framework 1.1, come ti ho consigliato.

    ma sei sicuro di farlo per l'intero sito e non solo per una singola virtual dir ?

    ho l'impressione che tu lo faccia in una posizione tale per cui cambia il framework solo in quella virtual dir e non in tutto il web site.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    mercoledì 30 marzo 2011 11:46
    Moderatore
  • ho verificato di nuovo, hai ragione, però non riesco a cambiarlo. Nella dir principale "Siti Web" nel tab ASP.NET la selezione è bloccata sul 2.0 e non mi permette di cambiare.

    Riesco a cambiarlo nelle virtual dir "Sito Web predefinito" che in tutte le altre virtual dir. Non riesco a cambiarlo invece in "Amministrazione Microsoft SharePoint" anche lì la selezione è bloccata su 2.0

    mercoledì 30 marzo 2011 12:05
  • di quali gruppi è membro l'account con il quale sei loggato sul server ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    mercoledì 30 marzo 2011 12:29
    Moderatore
  • sono loggato come Administrator di cui fa parte:

    Administrators; Domain Admins; Domain Users; Enterprise Admins; Mobile Users; OWS_1457702179_admin (Ruolo 'admin' di Microsoft SharePoint per il web "http://<nome_server>:8081); Proprietari autori criteri di gruppo; Schema Admins; Utenti desktop remoto

    mercoledì 30 marzo 2011 12:50
  • Ho risolto!!

    in tutte le virtual dir sono tornato ad impostare ASP con la versione 2.0. poi ho seguito questo http://support.microsoft.com/kb/823379/it.

    Ho riavviato IIS, poi nella console Gestione del server ho ri-eseguito "Ripristina le impostazioni di Internet e di posta elettronica".

    Grazie ancora Edoardo per il tuo prezioso aiuto e il tempo che mi hai dedicato.

    ciao

    Riccardo 

    mercoledì 30 marzo 2011 13:15
  • grazie a te del feedback e per aver postato la soluzione a beneficio della community.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    giovedì 31 marzo 2011 06:56
    Moderatore