none
Dopo l'aggiornamento a Microsoft 10 Fall Creators Update la connessione di rete di una macchina virtuale Hyper-V non funziona più RRS feed

  • Domanda

  • Dopo aver aggiornato Windows 10 a Fall Creators Update la connessione di rete di una macchina virtuale Hyper-V basata su Windows XP SP3 non funziona più. Come posso ripristinare la connessione di rete?
    lunedì 27 novembre 2017 07:48

Risposte

Tutte le risposte

  • Verifica la correttezza della configurazione dei commutatori virtuali e riassociali alla macchina virtuale.
    Trovi tutte le indicazioni qui:
    <link obsoleto rimosso>


    lunedì 27 novembre 2017 08:52
    Moderatore
  • I commutatori virtuali sono configurati e associati come prima dell'aggiornamento ma ho notato che, solo dopo l'aggiornamento, ora in Hyper-V viene automaticamente creato un commutatore virtuale denominato "Opzione predefinita" ma viene anche indicato in una nota informativa: "Utilizzare una scheda di rete legacy anziché questa scheda di rete  per eseguire un'installazione di rete del sistema operativo guest quando i servizi di integrazione non sono installati nel sistema operativo guest."

    Come si possono installare ora i servizi di integrazione nel sistema operativo guest?

    mercoledì 29 novembre 2017 08:53
  • Non puoi installare i servizi di integrazione perché il sistema operativo non è ufficialmente supportato da Hyper-V in Windows 10:
    https://docs.microsoft.com/it-it/virtualization/hyper-v-on-windows/about/supported-guest-os

    L'unico modo è passare ad una scheda legacy (basta aggiungere la scheda di rete nella configurazione della VM, che deve essere stata precedentemente creata come generazione 1).


    mercoledì 29 novembre 2017 15:55
    Moderatore
  • Non mi è chiaro cosa intendi con "... che deve essere stata precedentemente creata come generazione 1".
    mercoledì 29 novembre 2017 16:25
  • In Hyper-V, in fase di creazione di una VM, ti fa scegliere se deve essere di generazione 1 o 2. Nel caso di Windows XP sicuramente sarà già di generazione 1, ma meglio comunque specificarlo (in caso contrario la scheda legacy non sarà disponibile).
    mercoledì 29 novembre 2017 19:58
    Moderatore
  • Come consigliato, sono passato ad una scheda legacy aggiungendola nella configurazione della VM e subito è stato possibile vedere di nuovo gli altri computer in rete.

    Però la connessione ad internet continua a non funzionare ed ottengo dalla diagnostica di rete il messaggio qui allegato.

    venerdì 1 dicembre 2017 08:48
  • Verifica:
    - Che la scheda di rete legacy sia connessa al commutatore virtuale corretto nelle impostazioni della VM
    - Che la nuova scheda di rete sia configurata correttamente nel sistema operativo guest (Windows XP). Ad esempio potrebbe essere necessario reinserire la configurazione di rete TCP/IP statica se nella tua rete non hai un server DHCP.

    venerdì 1 dicembre 2017 09:30
    Moderatore
  • La scheda di rete legacy è connessa al commutatore virtuale corretto e nella rete è presente un server DHCP che assegna l'IP al computer.

    La connessione risulta attiva e si riesce a connettersi ad alcuni siti http ma non agli https.

    Il log di diagnostica che si ottiene è questo

    sabato 2 dicembre 2017 07:08
  • Ciao, prova ed eseguire netcfg -d da un Prompt DOS con credenziali elevate e dopo il riavvio verifica se funziona. In ogni caso il "default switch" non deve essere eliminato o modificato in quanto parte integrante della release 1709.

    Saluti
    Nino


    www.testerlab.it

    sabato 2 dicembre 2017 09:15
    Moderatore
  • Ma eseguendo netcf -d sul computer host, sarà poi necessario configurare nuovamente qualsiasi connessione di rete, non solo quelle usate da Hyper-v?
    domenica 3 dicembre 2017 05:10
  • Le connessioni si dovrebbero riconfigurare automaticamente all'avvio.


    www.testerlab.it

    domenica 3 dicembre 2017 07:46
    Moderatore