locked
Windows 7 64 bit le stampanti .... non stampano RRS feed

  • Domanda

  • Ciao a tutti,

    ho conseganto un pc nuovo con Win 7 64 bit ed ho installato le stampanti del cliente dopo aver scaricato i driver certificati Windows 7 64 bit dal produttore;

    1 HP Photosmart B110a

    1 Samsung SCX-4521f

    Il problema è che la stampante viene installata regolarmente ed anche le funzioni di scanner ecc.. funzionano ma non stampano!

    Le stampanti sono online, ma quando si lancia una stampa appare subito il segno di attenzione sulla stampante che avverte che c'è un errore di stampa.

    Ho provato a disinstallare tutto il software di ciascuna stampante ed reinstallarne una alla volta anche su porte usb diverse ma il problema permane.

    Le stampanti funzionano regolarmente ( provate sul vecchio pc...)

    Che fare?

     

    Grazie

    lunedì 16 maggio 2011 16:02

Risposte

  • èMolto semplice account utente - modifica impostazioni di controllo e metti tutto a zero( non notificare mai)  riavvia ed è ok.Non è il massimo per la sicurezza ma va

     

    Ciao

    • Contrassegnato come risposta csr-rimini martedì 24 maggio 2011 14:56
    martedì 24 maggio 2011 12:22

Tutte le risposte

  • ciao crs-rimini,

     

    prova ad applicare il fix 

     

    http://go.microsoft.com/?linkid=9740813

     

    al termine riavvia e riprova

    fai sapere

    Elvis


    Alvise Cervellati - MVP Windows Expert-Consumer
    lunedì 16 maggio 2011 16:49
  • Intanto grazie per la risposta,

     

    ho scaricato il fix e conto di eseguirlo nel pc incriminato per domani.

    Ovviamento spero che vada ma comunque vi faccio sapere.

     

    Intanto grazie e ..... a domani!

     

    Ciao

    martedì 17 maggio 2011 10:15
  • Ciao,
    ho fatto la prova con il fix che mi hai linkato ma purtroppo non è cambiato nulla...
    Allora ho fatto altre prove.
    Per prima cosa ho rimosso tutte le stampanti ( in realtà erano solo 2 + primoPDF ( tolto) e la stampante di office...)
    e poi ho installato solamente la stampante HP Photosmart B110a con i suoi driver certificati per Windows 7 64 bit...., ma ancora non ne
    vuole sapere...
    Però ho scoperto che andando nei servizi->Spooler di stampa e facendo click su "riavvia servizio" la stampa che era in coda parte e viene
    stampata regolarmente.Alla prossima stampa,però, ritorna l'errore e cosi via...Quindi per ogni stampa bisogna riavviare il servizio.
    Cosa non molto comoda.
    C'è qualche soluzione?
    Grazie
    Ciao
    giovedì 19 maggio 2011 06:50
  • Salve, provi a disinstallare tutte le stampanti e rimuovere eventuali softwares di gestione delle stampanti. Installi manualmente le stampati: dispostitivi e stampanti --> aggiungi stampante --> aggiungi stampante locale --> seleziona che tipo di collegamento (tcp port,lpt,usb...) --> clicca su windows update ed attendi che termini l'operazione di aggiornamento dei pacchetti driver disponibili. Una volta ultimata l'operazione, seleziona il driver della stampante (sperando che sia disponibile) e lo installi.

    Mi faccia sapere.

    Saluti

    giovedì 19 maggio 2011 07:30
  • procedi così: 

    Start > pannello di controllo > premi il tasto ALT + E > scegli opzioni cartella > Visualizzazione.

    Metti la spunta per visualizzare cartelle , file e unità nascoste.

    Dai ok.

    Poi , da start digita "services.msc" e dai invio >apri il  servizio Spooler di stampa ed arrestalo , lascia la finestra dei servzi aperta.

    Vai in c:\windows\system32\spool\printers ed elimina tutto il contenuto lasciando la cartella vuota.

    Dai ok , ritorna nella schermata di prima dei servizi , avvia il servizio Spooler di stampa , verifica che sia impostato su Automatico , chiudi i servizi e riavvia.

     

    ora da start > digita "cmd" > esegui come amministratore il prompt dei comandi > digita "SFC /SCANNOW", attendine il completamento, riavvia, reinstalla la stampante e riprova

     

    fai sapere


    Alvise Cervellati - MVP Windows Expert-Consumer
    giovedì 19 maggio 2011 09:37
  • Intanto grazie per le risposte!

    @Luigi Del Giudice
    Ho provato con la tua procedura ( che tra l'altro i driver su WU non ci sono ...) ma il
    problema permane...

    @Alvise2009

    Il cliente ora non è disponibile, ma appena posso provo la tua procedura.

    Devo prima disinstallare tutte le stampanti prima di procedure?

    Credi possa essere un problema dei 64 bit ( magari passare al 32 ) ?

    Il cliente ( posso capirlo ) inizia ad essere impaziente poichè deve lavorarci...
    Spero di risolvere presto...

    Appena ho notizie vi faccio sapere.

    Grazie
    Ciao
    giovedì 19 maggio 2011 09:48
  • la procedura resetta lo spooler di stampa, quindi la stampante dovrai reinstallarla (installala con il minimo indispensabile, se possibile solo driver)

     

    prova e fai sapere :-) 

    intanto buon pranzo, Elvis


    Alvise Cervellati - MVP Windows Expert-Consumer
    giovedì 19 maggio 2011 10:22
  • Ciao,

    allora ho provato ad andare in c:\windows\system32\spool\printers  ma nonostante la spunta su visualizzare cartelle , file e unità nascoste la cartella mi

    risulta vuota......

    Ho eseguito anche "SFC /SCANNOW" ma, dopo la scansione, dove non trova nessun errore, riavvio e ... continua a non stampare, bisogna sempre cliccare su riavvia servizio "spooler di stampa" per fare "ogni" stampa...

    Non sò più che pesci prendere ( e anche il cliente ).

    Altre idee?

    Grazie

    Ciao

    lunedì 23 maggio 2011 16:25
  • èMolto semplice account utente - modifica impostazioni di controllo e metti tutto a zero( non notificare mai)  riavvia ed è ok.Non è il massimo per la sicurezza ma va

     

    Ciao

    • Contrassegnato come risposta csr-rimini martedì 24 maggio 2011 14:56
    martedì 24 maggio 2011 12:22
  • Cavolo! Funziona!

    Mi chiedo cosa c'entrano le impostazini di controllo con lo spooler!!

    In effetti funziona ma, come tu stesso dici, non è il massimo per la sicurezza.

    Per ora va più che bene ma se qualche esperto, sapendo anche come è stato "risolto" (aggirato) il problema, sa dirmi (dirci) come risolvere in maniera totale (ripristinando le impostazioni di controllo...) sarebbe utile per me e penso per altri.

    Intato grazie a tutti ( evvai muraweb! ) e spero in altre risposte per risolvere al 100%.

     

    Grazie

    martedì 24 maggio 2011 15:01
  • Il servizio "Print Spooler" di Windows è vulnerabile ad un buffer overflow che potrebbe permettere ad un aggressore di eseguire codice nocivo sul sistema ed installare malware.Per eseguire la vulnerabilità, un aggressore dovrebbe convincere l'utente aggredito a collegarsi ad un sistema di stampa remoto che provvederà a inviare il codice nocivo. La vulnerabilità può essere anche eseguita da un utente locale.

    Ecco perchè l'UAC gestisce anche lo spooler ed ecco perchè su seven genera quel problema (che credevo fosse stato risolto in progettazione ).Ricordo che accadeva anche con vista mentre per xp era stata rilasciata una patch.

    Ultimamente con seven 64 bit questo problema lo riscontrato in almeno una 10 di modelli differenti anche se non capisco perché su alcune macchine identiche non succede ( va bè non ci ho sbattuto molto la testa probabilmente puo' essere un problema di windows pre installato )

     

    Ciao

    mercoledì 25 maggio 2011 17:19
  • Il servizio "Print Spooler" di Windows è vulnerabile ad un buffer overflow che potrebbe permettere ad un aggressore di eseguire codice nocivo sul sistema ed installare malware.Per eseguire la vulnerabilità, un aggressore dovrebbe convincere l'utente aggredito a collegarsi ad un sistema di stampa remoto che provvederà a inviare il codice nocivo. La vulnerabilità può essere anche eseguita da un utente locale.

    Ecco perchè l'UAC gestisce anche lo spooler ed ecco perchè su seven genera quel problema (che credevo fosse stato risolto in progettazione ).Ricordo che accadeva anche con vista mentre per xp era stata rilasciata una patch.

    Ultimamente con seven 64 bit questo problema lo riscontrato in almeno una 10 di modelli differenti anche se non capisco perché su alcune macchine identiche non succede ( va bè non ci ho sbattuto molto la testa probabilmente puo' essere un problema di windows pre installato )

     

    Ciao

    Ciao stesso problema ma non si risolve in alcun modo
    martedì 31 maggio 2011 16:54