locked
Windows 7 Ultimate su Sony Vaio VGN-SZ3HP/B RRS feed

  • Domanda

  • Possiedo un notebook Sony Vaio VGN-SZ3HP/B. Ho eseguito l'upgrade Advisor per Windows 7 senza riscontrare alcun problema. Ho installato oggi Windows 7 Ultimate; l'installazione ha avuto successo, ha installato il driver video corretto (Intel Chipset GM945). Poi inspiegabilmente al primo riavvio ha sostituito il dirver video con un generico VGA 800x600. Non c'è verso di cambiarlo e riportarlo al driver precedente. Mi sa tanto che il mio party del 22 ottobre non andrà a buon fine.
    p.s. ho rifatto l'installazione di Win7 poco fa.... ha installato il driver video generico VGA ! Che ciofeca sto Win7 !
    venerdì 9 ottobre 2009 16:03

Risposte

  • Ciao,
    non è tanto assurda perché spesso i driver forniti dai produttori a Microsoft da inserire all'interno del DVD del sistema operativo oppure presenti su Windows Update sono datati e quindi più suscettibili a problemi. Hai provato anche a scaricare tutti gli aggiornamenti di Seven? Alcuni di questi (che sono stati rilasciati dopo l'uscita dell'RTM) migliorano la compatibilità di molti componenti hardware e software.

    Purtroppo non puoi installare i driver prelevandoli dal sito della nVidia perché è scritto esplicitamente qui: "I notebook Sony VAIO (contattare l'OEM del notebook per avere notizie e assistenza relativi ai driver per questi notebook)."

    Devi provare ad installare (utilizzando la modalità compatibilità Vista) i driver nVidia per Vista presenti sul sito della Sony (anche se purtroppo sono aggiornati al 31/05/2007):
    http://support.vaio.sony.eu/computing/vaio/downloads/info/info.aspx?l=en_GB&url=Downloads/NV/D/VID/NVDVID-01422002-UN.exe&m=VGN-SZ3HP_B&ip=NVDVID-01422002-UN.htm

    Ciao


    Leonardo Bai - Microsoft MVP Windows Live Messenger - Since 2007. My MVP Profile: https://mvp.support.microsoft.com/profile/Bai
    • Contrassegnato come risposta Adriano Arrigo domenica 11 ottobre 2009 17:13
    sabato 10 ottobre 2009 05:58

Tutte le risposte

  • Ciao,
    il driver del tuo chipset da dove l'hai prelevato? E' per Vista o Windows 7? Probabilmente è Windows Update che ti propone il download del driver bacato... in quel caso durante l'installazione personalizzata degli aggiornamenti digli di non installarlo e di non chiederlo più. Per il momento se torni ad un punto di ripristino precedente all'installazione del driver riesci a risolvere senza reinstallare nuovamente?

    Ciao


    Leonardo Bai - Microsoft MVP Windows Live Messenger - Since 2007. My MVP Profile: https://mvp.support.microsoft.com/profile/Bai
    venerdì 9 ottobre 2009 16:07
  • Prova questi : http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2301&DwnldID=17803&lang=eng

    P.S.: io ho un Lenovo e i driver della scheda video li ha visti al primo colpo, chipset Intel965, ma non mi sento di dare della ciofeca a Sony per questo :-)

    Anche perché : "... I just did a clean windows 7 installation on my sony vaio sz and got all the drivers and hotkeys to work. You just have to find and install the driver in the correct order." Quindi, magari non è Windows 7 ad essere così una ciofeca.

    http://www.sevenforums.com/drivers/8640-sony-vaio-ns-drivers.html


    Adriano Arrigo
    Microsoft MVP Windows Desktop Experience
    ITALY
    venerdì 9 ottobre 2009 17:02
  • Ciao, il driver non l'ho prelevato da nessuna parte. E' stato installato tramite il dvd di installazione Windows 7 Ultimate.  Ripeto, la cosa assurda è che con la prima installazione (da dvd appunto) la scheda video era stata riconosciuta perfettamente da Win7. Poi inspiegabilmente al primo riavvio il driver (la scheda video sul mio sony è una GF Go 7400) è stato sostituito dal generico VGA Generic Video Graphic, che permette soltanto di sfruttare fino a 1024x768 (invece del 1200x800) e non abilita l'Aero. Ho provato a cercare punti di ripristino precedenti, ma non c'è stato nulla da fare. Cosi ho eseguito una nuova installazione di Win7 (formattando prima il disco fisso) e facendo quindi un'installazione pulita: putroppo in questo secondo caso è stato installato direttamente il driver generico VGA. E' assurda questa cosa, non trovi ?
    sabato 10 ottobre 2009 00:11
  • Ciao, pure io avevo effettuato un'installazione pulita di Win7 sul mio vaio sz e tutti i driver funzionavano perfettamente, addirittura mi aveva riconosciuto il bluetooth e la webcam che il programma advisor mi aveva segnalato con incompatibili. Ma poi al primo riavvio di win7 il driver ottimizzato per la scheda video è stato sostituito dal driver generico VGA e non c'è verso di fargli riprendere il driver precedente. Ho provato a disabilitare il driver da Gestione Dispositivi e forzare manualmente l'installazione del driver Intel 845GM ma nulla... ho provato anche ad andare sul sito di nvidia per scaricare il driver della GF Go 7400 ma pare il tool di diagnostica sul sito Nvidia dice che il driver VGA generico è corretto e cosi non installa alcun driver aggiornato.
    Come faccio ora ad organizzare il party del 21/10 se Windows 7 fa cilecca con i driver video ? Gli amici che ho invitato al party non sarebbero contenti di sperimentare Windows 7 con problemi invece di opportunità :-(

    sabato 10 ottobre 2009 00:20
  • Ciao,
    non è tanto assurda perché spesso i driver forniti dai produttori a Microsoft da inserire all'interno del DVD del sistema operativo oppure presenti su Windows Update sono datati e quindi più suscettibili a problemi. Hai provato anche a scaricare tutti gli aggiornamenti di Seven? Alcuni di questi (che sono stati rilasciati dopo l'uscita dell'RTM) migliorano la compatibilità di molti componenti hardware e software.

    Purtroppo non puoi installare i driver prelevandoli dal sito della nVidia perché è scritto esplicitamente qui: "I notebook Sony VAIO (contattare l'OEM del notebook per avere notizie e assistenza relativi ai driver per questi notebook)."

    Devi provare ad installare (utilizzando la modalità compatibilità Vista) i driver nVidia per Vista presenti sul sito della Sony (anche se purtroppo sono aggiornati al 31/05/2007):
    http://support.vaio.sony.eu/computing/vaio/downloads/info/info.aspx?l=en_GB&url=Downloads/NV/D/VID/NVDVID-01422002-UN.exe&m=VGN-SZ3HP_B&ip=NVDVID-01422002-UN.htm

    Ciao


    Leonardo Bai - Microsoft MVP Windows Live Messenger - Since 2007. My MVP Profile: https://mvp.support.microsoft.com/profile/Bai
    • Contrassegnato come risposta Adriano Arrigo domenica 11 ottobre 2009 17:13
    sabato 10 ottobre 2009 05:58
  • l'installazione ha avuto successo, ha installato il driver video corretto (Intel Chipset GM945).
    ho provato anche ad andare sul sito di nvidia per scaricare il driver della GF Go 7400
    Cos'è che mi sfugge ?  ;-)
    Adriano Arrigo
    Microsoft MVP Windows Desktop Experience
    ITALY
    sabato 10 ottobre 2009 09:36
  • Cos'è che mi sfugge ?  ;-)
    LOL! Abbi pietà ma gli antibiotici mi stanno uccidendo :-P

    A questo punto sarebbe utile capire quale chipset video effettivamente monta il notebook (visto che poteva montarli entrambi)... ma come hai detto giustamente tu penso proprio che si tratti di quello Intel visto che lo aveva riconosciuto la prima volta.

    Grazie mille Adriano per la precisazione! :-)

    Ciao
    Leonardo Bai - Microsoft MVP Windows Live Messenger - Since 2007. My MVP Profile: https://mvp.support.microsoft.com/profile/Bai
    sabato 10 ottobre 2009 10:04
  • Grazie per il chiarimento, domani pomeriggio proverò ad installare nuovamente Win7 (stavolta lo installero come aggiornamento invece di radere al suolo Xp come ho fatto le altre volte) sperando che in questo caso la scheda video venga riconosciuta correttamente. Se cosi non fosse dovrò dire addio al mio Party per Windows 7. In questo caso cosa ne faccio del materiale che zio Bill mi ha inviato dagli USA ? Non potendo sfruttare correttamente il mio notebook Sony dovrò continuare ad utilizzare WinXP.
    Domani vi farò sapere com'è andata a finire.
    'Notte.
    Paolo
    domenica 11 ottobre 2009 01:17
  • Ciao Paolo,
    purtroppo se hai XP non è possibile installare Seven come aggiornamento :(
    Invece di formattarlo nuovamente prova ad installare i driver che ti ha consigliato Adriano:
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2301&DwnldID=17803&lang=eng
    Se non dovesse andare prova anche ad installare i driver della Sony:
    http://support.vaio.sony.eu/computing/vaio/downloads/info/info.aspx?l=it_IT&url=Downloads/IN/D/VID/INDVID-01346821-UN.exe&m=VGN-SZ3HP_B&ip=INDVID-01346821-UN.htm
    Tutto questo ovviamente se il tuo Chipset video è il GM945 ;-)
    Se invece hai la scheda video GeForce allora vale il link che ti avevo passato nel post precedente.

    HTH
    Leonardo Bai - Microsoft MVP Windows Live Messenger - Since 2007. My MVP Profile: https://mvp.support.microsoft.com/profile/Bai
    domenica 11 ottobre 2009 06:17
  • Il Design di Sony sarà anche "fashion"  ma non comprendo con quale modalità vende i notebook alla propria utenza.
    Hanno deliberatamente bloccato la virtualizzazione da CPu (virtual XP su Vaio non può essere eseguito)
    Non consentono update dei driver Gpu rilasciati da Nvidia per notebook.

    Non consiglierò mai a nessuno un Sony

    domenica 11 ottobre 2009 13:02
  • Ciao Leonardo,
    sono riuscito ad installare il driver di nVidia al link che mi avevi postato. Ora tutto sembra funzionare alla perfezione. A questo punto provo ad installare anche i driver della webcam in modalità vista compatibile.
    Grazie per il tuo supporto.
    Finalmente sarò in grado di organizzare il party di Seven come si deve :-)
    Ciao
    Paolo

    domenica 11 ottobre 2009 15:22
  • Anche se ci resterà per sempre il dubbio, meglio così... :-)
    Adriano Arrigo
    Microsoft MVP Windows Desktop Experience
    ITALY
    domenica 11 ottobre 2009 17:12
  • Ciao Paolo,
    sono contento che sei riuscito a risolvere i problemi con la scheda video :-)

    A questo punto non mi resta che augurare un Buon Party anche a te! :-)

    A presto
    Leonardo Bai - Microsoft MVP Windows Live Messenger - Since 2007. My MVP Profile: https://mvp.support.microsoft.com/profile/Bai
    lunedì 12 ottobre 2009 13:59