none
Impostare gli account per un dominio RRS feed

  • Domanda

  • Ecco un'altra domanda.

    Grazie all'aiuto di ObiWan sono riuscito a configurare con estrema facilità il mio mail server

    Avrei la necessità di impostare un account di posta su Exchange 2010 affinchè le email che arrivano indirizzate a pippo@pippo.it vengano distribuite su un utente del dominio interno che si chiama pippo@pippo.local ed ovviamente stessa cosa per la posta in uscita. C'è qualche thread già discusso per questo?

    Grazie,


    Alberto De Luca [MVP - Visual Basic .NET]
    mercoledì 13 aprile 2011 17:28

Risposte

  • Per vederlo ti basta andare nelle proprietà di quella mailbox e vedere i vari smtp address impostati. Soprattutto però devi vedere a livello di accept domain se l'exchange è configurato per ricevere la posta per quei domini. Lo vedi dalla console di exchange-->organizzazione-->hub transport
    Peppacci - MVP - Microsoft Exchange Server Microsoft MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    • Contrassegnato come risposta Alberto De Luca giovedì 14 aprile 2011 08:53
    giovedì 14 aprile 2011 08:28
    Moderatore
  • Si credo che fosse sullo stesso server, sono 2 domini in hosting su
    aruba... In passato questa era la cfg:

    Ed ecco il perchè il forward non funziona :) vedi, molto probabilmente
    il secondo dominio (quello verso il quale punta il forward) è ancora
    configurato sul mailserver che esegue il forward; a questo punto
    succede quanto segue

    il mailserver impostato per il forwarding riceve una email indirizzata
    ad una mailbox del dominio che ora è "esterno"

    il mailserver controlla la propria configurazione e... scopre che quel
    dominio è "locale" (dato che non è stato eliminato)

    il mailserver tenta quindi di recapitare la mail (forward) alla mailbox
    che risiede presso ... se stesso ma, dato che tale mailbox è stata
    disattivata (o non esiste più) emette un messaggio di errore

    la soluzione è quella di contattare Aruba e fare ELIMINARE il
    dominio che ora è presso il tuo exchange dal loro mailserver

    Per farla breve e, seguendo quanto hai scritto, dovrai richiedere
    ad Aruba di eliminare dal loro mailserver il dominio doctorbit.com
    in modo che il forwarding (ove impostato) possa funzionare :)

    ciao

    • Contrassegnato come risposta Alberto De Luca venerdì 15 aprile 2011 07:25
    venerdì 15 aprile 2011 07:16

Tutte le risposte

  • pippo@pippo.it e pippo@pippo.local sono già associate alla stessa mailbox :)

     

    Quindi a quanto credo di aver capito, se pippo@pippo.it, pippo@pippo.com , pippo@pippo.eu hanno il record MX che punta allo stesso mailserver vengono tutte associate internamente alla stessa mailbox pippo@pippo.local?

     


    Alberto De Luca [MVP - Visual Basic .NET]
    mercoledì 13 aprile 2011 20:40
  • Per vederlo ti basta andare nelle proprietà di quella mailbox e vedere i vari smtp address impostati. Soprattutto però devi vedere a livello di accept domain se l'exchange è configurato per ricevere la posta per quei domini. Lo vedi dalla console di exchange-->organizzazione-->hub transport
    Peppacci - MVP - Microsoft Exchange Server Microsoft MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    • Contrassegnato come risposta Alberto De Luca giovedì 14 aprile 2011 08:53
    giovedì 14 aprile 2011 08:28
    Moderatore
  • Perfetto, grazie!
    Alberto De Luca [MVP - Visual Basic .NET]
    giovedì 14 aprile 2011 08:53
  • Come da consiglio di Peppacci continuo qua il mio topic...

    P.S.: Mi chiamo Alberto e non Luca... :)

    Mi manca un'ultima tessera per finire il lavoro di configurazione di Exchange. Dovrei reindirizzare tutte le email provenienti da un mio indirizzo pippo@pippo.it che è su un server esterno al mio exchange su un indirizzo pippo@pippo.com che è sul mio Exchange. Sono andato sulla consolle di amministrazione del mio provider ed ho abilitato il forwarding della casella pippo@pippo.it --> pippo@pippo.com. Fin qui nessun problema. Se provo ad inviare una mail a pippo@pippo.it da un indirizzo tipo pluto@pluto.com mi ritorna un messaggio di errore: account is locked email bounced.

    Cosa debbo fare per abilitare le bounced email sull'indirizzo pippo@pippo.com?

    Grazie ancora.


    Alberto De Luca [MVP - Visual Basic .NET]
    giovedì 14 aprile 2011 12:24
  • Mi manca un'ultima tessera per finire il lavoro di configurazione di
    Exchange. Dovrei reindirizzare tutte le email provenienti da un mio
    indirizzopippo@pippo.it che è su un server esterno al mio exchange
    su un indirizzopippo@pippo.com che è sul mio Exchange.

    Ok; hai due possibilità; se la casella su pippo.it permette di attivare
    il forwarding, puoi attivarlo ed inoltrare tutte le emails verso la tua
    casella su pippo.com gestita dal tuo exchange, se invece questo
    non fosse possibile, puoi usare un pop3 retriever (ossia per usare
    la terminologia di exchange un "connector") che scarichi le emails
    dalla casella esterna ad intervalli regolari; in quest'ultimo caso
    potresti usare il tool che ti ho indicato nell'altro thread creandoti
    un semplice "batch" da schedulare agli intervalli desiderati.. anche
    se sinceramente, preferirei l'uso del "forwarding" :)

    Sono andato sulla consolle di amministrazione del mio provider ed
    ho abilitato il forwarding della casella

    pippo@pippo.it -->pippo@pippo.com

    Fin qui nessun problema. Se provo ad inviare una mail a
    pippo@pippo.it da un indirizzo tipo pluto@pluto.com mi
    ritorna un messaggio di errore: account is locked email
    bounced.
    Cosa debbo fare per abilitare le bounced email sull'indirizzo
    pippo@pippo.com ?

    prima di tutto, verifica che la casella su pippo.com riceva le emails
    in arrivo; a tale scopo, prova ad inviare una email da "pluto.com"
    verso la casella "pippo.com" verificando che questa raggiunga
    la destinazione, poi potremo procedere con gli altri controlli

    giovedì 14 aprile 2011 14:05
  • La prima cosa è quella che ho fatto, ovvero attivare il forwarding. Il problema è che sulla casella da cui invio la mail all'indirizzo forwardato mi ritorna una email che dice: "account is locked email bounced"

    Grazie,


    Alberto De Luca [MVP - Visual Basic .NET]
    giovedì 14 aprile 2011 14:14
  • La prima cosa è quella che ho fatto, ovvero attivare il forwarding. Il
    problema è che sulla casella da cui invio la mail all'indirizzo
    forwardato mi ritorna una email che dice: "account is locked email
    bounced"

    Si ok... ma se, da un account esterno invii direttamente una email
    alla TUA casella ossia all'indirizzo impostato come DESTINAZIONE
    del forward (e non alla casella che fa poi forwarding); tale email
    arriva a destinazione ?

    giovedì 14 aprile 2011 14:24
  • Si, si.. certo che arriva
    Alberto De Luca [MVP - Visual Basic .NET]
    giovedì 14 aprile 2011 14:29
  • > Si, si.. certo che arriva

    Ok, quindi la mailbox destinazione funziona, a questo punto
    il problema è evidentemente relativo al forward; cerchiamo
    quindi di capire il motivo del "reject"; a tale scopo potresti
    attivare il logging SMTP in exchange nonchè il message
    tracking e, verificando i logs, cercare di capire quale sia
    "l'errore" che causa il rifiuto del messaggio

    Personalmente sospetto che il problema possa essere
    dovuto al check SenderID/SPF; per cercare di chiarire...

    tu invii una email da pippo@pippo.net all'indirizzo email
    pippo@pippo.com la mailbox in questione riceve tale
    email ed essendo stata configurata per inoltrare tutti i
    messaggi, diligentemente procede all'inoltro della mail
    verso la mailbox pippo@pippo.it che risiede sul tuo
    server; il tuo server vede una sessione SMTP di questo
    tipo:

    HELO mail.pippo.com
    MAIL FROM: pippo@pippo.net
    RCPT TO: pippo@pippo.it

    ora... supponiamo che il dominio ORIGINE, ossia il
    dominio pippo.net pubblichi un record SPF (o SenderID)
    che autorizza SOLO ed esclusivamente i servers relativi
    a tale dominio all'invio di emails dallo stesso; il tuo server
    vedrà una connessione da un IP diverso da quelli
    autorizzati (ossia da uno degli SMTP di pippo.com)
    ma che "pretende" di provenire da pippo.net ed a questo
    punto, rifiuterà tale messaggio come "falso"

    Questo è un problema classico dei domini che pubblicando
    SPF non implementano SRS; per risolverlo, a parte convincere
    chi gestisce pippo.net ad implementare SRS potresti aggiungere
    al tuo filtro un'eccezione che faccia in modo che i controlli SPF
    vengano omessi per i messaggi in arrivo da pippo.net oppure
    dagli IP emittenti per il dominio pippo.com

    In qualsiasi caso, quella sopra è solo un'ipotesi e l'unico modo
    di verificarla o smentirla, come ho già scritto, è quello di attivare
    il logging e verificare il contenuto dei vari logs

    giovedì 14 aprile 2011 14:58
  •  

    >In qualsiasi caso, quella sopra è solo un'ipotesi e l'unico modo
    >di verificarla o smentirla, come ho già scritto, è quello di attivare
    >il logging e verificare il contenuto dei vari logs

     

    Ho attivato i Logs ed il problema si verifica proprio a livello di server di forwarding poichè il log SMTP del mio server di Exchange non riceve nessun messaggio di HELO quando vengono inviate email attraverso il forwarding.


    Alberto De Luca [MVP - Visual Basic .NET]
    giovedì 14 aprile 2011 16:38
  • In qualsiasi caso, quella sopra è solo un'ipotesi e l'unico modo
    di verificarla o smentirla, come ho già scritto, è quello di attivare
    il logging e verificare il contenuto dei vari logs

    Ho attivato i Logs ed il problema si verifica proprio a livello di
    server di forwarding poichè il log SMTP del mio server di Exchange
    non riceve nessun messaggio di HELO quando vengono inviate email
    attraverso il forwarding.

    Uh... mi stai dicendo che il "forward" NON arriva affatto al tuo server
    ?

    Se è così... mi viene un dubbio; non è che per caso il dominio verso
    il quale hai impostato il forward fosse, in passato, attestato sugli
    stessi
    server del dominio DAL quale fai il forward (ok, forse non è molto
    chiaro, prova a rileggerlo :D)

    giovedì 14 aprile 2011 16:45
  • Uh... mi stai dicendo che il "forward" NON arriva affatto al tuo server
    ?

    Se è così... mi viene un dubbio; non è che per caso il dominio verso
    il quale hai impostato il forward fosse, in passato, attestato sugli
    stessi
    server del dominio DAL quale fai il forward (ok, forse non è molto
    chiaro, prova a rileggerlo :D)

    Si credo che fosse sullo stesso server, sono 2 domini in hosting su aruba... In passato questa era la cfg:

    Dominio doctorbit.it Hosting su Aruba DNS+MailServer su Aruba

    Dominio doctorbit.com Hosting su Aruba Redirect su doctorbit.it +MailServer su Aruba

    doctorbit.com faceva in passato il forwarding su doctorbit.it

    adesso ho modificato doctorbit.com in:

    Gestione DNS senza Mail server

    il MailServer di doctorbit.com è diventato il mio Exchange

    vorrei aquesto punto fare il redirect SOLO di alcuni indirizzi di doctorbit.it sulla casella principale di doctorbit.com, facendo questo mi da errore.

    Grazie per la tua pazienza...


    Alberto De Luca [MVP - Visual Basic .NET]
    giovedì 14 aprile 2011 16:54
  • Si credo che fosse sullo stesso server, sono 2 domini in hosting su
    aruba... In passato questa era la cfg:

    Ed ecco il perchè il forward non funziona :) vedi, molto probabilmente
    il secondo dominio (quello verso il quale punta il forward) è ancora
    configurato sul mailserver che esegue il forward; a questo punto
    succede quanto segue

    il mailserver impostato per il forwarding riceve una email indirizzata
    ad una mailbox del dominio che ora è "esterno"

    il mailserver controlla la propria configurazione e... scopre che quel
    dominio è "locale" (dato che non è stato eliminato)

    il mailserver tenta quindi di recapitare la mail (forward) alla mailbox
    che risiede presso ... se stesso ma, dato che tale mailbox è stata
    disattivata (o non esiste più) emette un messaggio di errore

    la soluzione è quella di contattare Aruba e fare ELIMINARE il
    dominio che ora è presso il tuo exchange dal loro mailserver

    Per farla breve e, seguendo quanto hai scritto, dovrai richiedere
    ad Aruba di eliminare dal loro mailserver il dominio doctorbit.com
    in modo che il forwarding (ove impostato) possa funzionare :)

    ciao

    • Contrassegnato come risposta Alberto De Luca venerdì 15 aprile 2011 07:25
    venerdì 15 aprile 2011 07:16
  • Ma quante ne sai... :D:D:D:D
    Alberto De Luca [MVP - Visual Basic .NET]
    venerdì 15 aprile 2011 07:25
  • > Ma quante ne sai... :D:D:D:D

    Beh.... come dicono gli anglofoni

    "Been there, done that, got the T-Shirt" :D
    (o, in acronimo BTDTGTTS :D) seriamente,
    non è la prima nè l'unica volta che una cosa
    del genere accade; nel tuo caso, anzi, il tutto
    è meno "infernale" del solito visto che hai
    ancora rapporti con chi gestiva il precedente
    servizio di posta; in altri casi... beh, ho visto
    cose che voi umani ... :)

    venerdì 15 aprile 2011 08:36
  • Direi che per la competenza, completezza e l'esposizione impeccabile, in questo 3D OBI si merita un bel pò di utili.... e anche una Toccatina :-) 

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    venerdì 15 aprile 2011 09:19
  • Direi che per la competenza, completezza e l'esposizione
    impeccabile, in questo 3D OBI si merita un bel pò di utili....

    Grazie Andre... ma lo sai (te l'ho già detto) che non lo faccio
    per le "medaglie" ma soltanto perchè ... beh, mi piace farlo :)

    D'altro canto per quanto riguarda "exchange" sono solo un
    "hobbyista", lo seguo marginalmente perchè rientra nei miei
    interessi ma sono più orientato a tematiche relative alla
    sicurezza (e la trasmissione di "robaccia" tramite email
    rientra nel novero)

    e anche una Toccatina :-)

    Uh ... e adesso questo che è, un tentativo di molestia sessuale :D ?

    Ciao Andre e... grazie !

    P.S.: Alberto... fammi/facci sapere come va a finire, a questo
    punto sono veramente curioso e... come vedi, non avevo
    sottovalutato i tuoi skills :D

    venerdì 15 aprile 2011 09:28
  • > ma lo sai (te l'ho già detto) che non lo faccio
    > per le "medaglie" ma soltanto perchè ... beh, mi piace farlo :)

    Lo so, lo so ... solo che sul forum non c'è altro metodo per far capire a colpo d'okkio che quanto scritto è interessante, oltre la toccatina ovviamente ;)


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    venerdì 15 aprile 2011 09:34
  • Dopo lunga e perigliosa navigazione nei fiordi vulcanici ancora attivi di Aruba sono finalmente riuscito a sistemare il tutto. A futura memoria lascio un estratto del diario di bordo:

    1) Ho aperto un ticket su Aruba per chiedergli se mi eliminavano il mio dominio dal loro mail server.

    2) Mi hanno comunicato che la richiesta era stata evasa.

    3) Ho aspettato 24/48 H come da loro indicazione

    4) Non funzionava niente comunque, anzi addirittura in questo caso le email non si sapeva che fine facessero, niente sui log di Exchange, niente sulla casella di posta.

    5) Ho cambiato l'indirizzo ip del mio mail server sul record MX e sul mio firewall..

    6) Adesso arriva tutto...

    Grazie a tutti per il supporto che mi avete fornito, adesso vedo se mi riesce anche sistemare la connessione per WP7 sullo stesso account...


    Alberto De Luca [MVP - Visual Basic .NET]
    lunedì 18 aprile 2011 09:33
  • Dopo lunga e perigliosa navigazione nei fiordi vulcanici ancora
    attivi di Aruba sono finalmente riuscito a sistemare il tutto. A
    futura memoria lascio un estratto del diario di bordo:

    Alberto

    Innanzi tutto ti RINGRAZIO di cuore per il feedback che ritengo
    possa essere di interesse a quanti abbiano dei sistemi ospitati
    presso "aruba" (lascio da parte le mie considerazioni personali
    su tale hoster, sui servizi offerti e sulla reputazione dello stesso
    dato che sarebbero OT, ma credo e spero siano chiare :D)

    Detto ciò, sono felice di sapere che sei riuscito a risolvere il tuo
    problema e che tutto funziona come dovrebbe, torno a dirti che
    in caso di necessità... siamo qui e... beh, spero che la cosa ti sia
    servita a non sottovalutarti; come ho già scritto, non credo di aver
    sottovalutato i tuoi skills e la cosa credo sia stata dimostrata in
    maniera inoppugnabile dall'evoluzione di questo thread

    Per il resto, di nuovo, non ti fare problemi nel postare richieste,
    alla fine della fiera i forums sono qui per questo e non credo ci
    sia nulla di cui vergognarsi nel postare una richiesta di aiuto, anzi,
    sono proprio coloro che pensano di "saperle tutte" quelli che alla
    fine dei conti combinano i peggiori "macelli" :)

    Ancora grazie del feedback e... Buona Pasqua :) !

    lunedì 18 aprile 2011 13:12