none
configurare hyper-v con 3 nic RRS feed

  • Domanda

  • Buongiorno a tutti, premetto di non avere grande esperienza di virtualizzazione, quindi chiedo scusa per eventuali inesattezze o castronerie che penso siano verità...
    Abbiamo installato un server host (HP ML350G5) con win server 2008 R2 STD e il solo ruolo hyper-v. l'host ha 2 schede di rete fisiche, di cui una doppia (con 2 nic), quindi in totale 3 schede di rete.
    Poichè una delle VM ha ISA 2006, abbiamo necessità di virtualizzare 2 nic e tenere la terza per uso host. Abbiamo provato a creare due virtual network esterne; per la prima nessun problema; quando cerchiamo di creare la seconda esterna scegliendo un'altra scheda di rete, dice che non può crearla e imposta una rete interna. Per scrupolo abbiamo anche evitato di usare le 2 sulla scheda doppia, ma niente.
    Vorrei sapere se ci sono limiti nella creazione di reti esterne e, se sì, come potrei risolvere il problema avendo ISA come VM assieme ad altri server virtuali sull'host.
    Grazie anticipatamente per un qualsiasi aiuto!!!!
    Stefania


    Stefania Cresta - DUE Servizi Informatici Srl - Genova
    martedì 12 aprile 2011 14:26

Risposte

Tutte le risposte

  • ti cnsiglio di leggerti attentamente questo tutorial

    http://www.petri.co.il/configuring-virtual-networks-with-hyper-v.htm

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    martedì 12 aprile 2011 15:22
    Moderatore
  • Grazie Edoardo, avevo già letto quell'articolo identico pubblicato su un altro sito. In effetti mi pare di capire che dovrei riuscire a fare cio' che mi serve e cioè 2 reti virtuali esterne. Abbiamo anche installato tutti gli aggiornamenti possibili.
    Quando cerco di installare la seconda virtuale esterna dice che la scheda è già in uso da altro commutatore; riprovando esce un altro errore diverso che non ricordo, ma il risultato è che ho come unica possibilità di impostare rete interna/privata  oppure uscire senza crearla.
    Abbiamo anche eliminato dall'host tutte le schede di rete in modo che le ricreasse, ma stesso risultato.
    Non capiamo dov'è il problema.
    Mi rendo conto che non riesco a darvi grandi informazioni per potermi aiutare, in teoria sarebbe tutto semplice .. speravo che qualcuno avesse già avuto lo stesso problema e si fosse capito il motivo.
    In questo momento abbiamo riavviato l'host e riprovato: ora ha accettato le due esterne!. Lo avevamo già fatto più volte senza alcun risultato. E nel frattempo non abbiamo variato nulla, solo riavviato! E in ogni caso dentro le VM, dopo aver configurato le schede di rete con le stesse subnet, non si riesce neppure a pingare gli IP attribuiti alle schede virtuali sull'host! Insomma c'è evidentemente un 'casino' da qualche parte.
    Grazie comunque per l'aiuto
    Stefania


    Stefania Cresta - DUE Servizi Informatici Srl - Genova
    martedì 12 aprile 2011 16:32
  • In questo momento abbiamo riavviato l'host e riprovato: ora ha accettato le due esterne!. Lo avevamo già fatto più volte senza alcun risultato. E nel frattempo non abbiamo variato nulla, solo riavviato! E in ogni caso dentro le VM, dopo aver configurato le schede di rete con le stesse subnet, non si riesce neppure a pingare gli IP attribuiti alle schede virtuali sull'host! Insomma c'è evidentemente un 'casino' da qualche parte.

    come vedi però l'operazione è fattibile, è la vostra macchina ad essere "incriccata" (termine tecnico) :-)

    per riassumere e capire il tema che hai scritto: il problema ora è che hai 2 virtual switch configurati ma le vm non pingano gli ip assegnati a quelle schede ? ma avete assegnato correttamente le virtual networks alle vm ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    mercoledì 13 aprile 2011 08:43
    Moderatore