none
WCF Windows 7 Fault event problem (Windows XP works as expected) RRS feed

  • Discussione generale

  • I have a strange issue in a wcf service. The service is hosted in a Windows Form with netTcpBinding. It is called by some clients with windows xp or windows 7,  works in each client but when i do some test like unplug network cable, clients with xp receive fault event but clients with Windows 7 don't receive nothing so they don't reopen connection. When i stop server or disable network adapter, Fault event is raised in both system.

    I think that this strange issue is due to something in Windows 7 anyone have any idea?

    Thanks very much

    • Tipo modificato Anca Popa martedì 11 settembre 2012 14:54 thread in inglese
    • Spostato Anca Popa martedì 11 settembre 2012 14:54 (Da:Windows 8 e Windows 7)
    venerdì 7 settembre 2012 12:11

Tutte le risposte

  • Hi,

    Please be aware that this Community is able to provide support in Italian only. Since we received your request in English, I will move your thread to the appropriate forum.

    The following URL will help make sure you receive the appropriate support information for your location.

    Select your region from the drop down list and then click the arrow button:
    http://support.microsoft.com/common/international.aspx

    Thank you for your understanding,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    martedì 11 settembre 2012 14:54