none
disco databse secondo server guasto

    Domanda

  • salve, purtroppo ho perso il disco (in RAID-5) dei DB sul secondo server del nodo DAG.

    il sistema cluster dei nodi è funzionante e i due server si vedono. al momento ho scollegato il server dalla rete , in modo che il primo nodo del DAG non cerchi la syncronizzazione dei DB.

    Ora , volevo sapere , una volta ripristinato il RAID e montato volume D: , quando riconnetto il server la syncronizzazione parte in automatico ricreando tutta la struttura D:\Program Files\Microsoft\Exchange Server\V14......  ??

    o devo agire sui db togliendo e ricreando la mappaturra ??

    grazie

    lunedì 2 luglio 2018 13:13

Tutte le risposte

  • Ciao, siamo italiani, quindi solo post iniziali in italiano :-). Non è chiara una cosa, se hai perso una disco di un raid 5 il raid5 avrebbe dovuto continuare e girare finchè non inserivi il nuovo disco e gli avrebbe ricostruito sotto il volume...almeno così funziona il raid5. 

    Quindi in caso il nodo sia veramente crashato in maniera irrecuperabile di solito si toglie e si rimette il dag, altrimenti si prova a fare un reseed, qui sotto trovi le procedure...

    https://practical365.com/exchange-server/how-to-reseed-a-failed-database-copy-in-exchange-server-2013/

    http://www.techieshelp.com/exchange-dag-node-failure-force-switchover-queus/

    non hai scritto che versione di server è..ad ogni modo il V14 che metti mi fa pensare ad una 2010...

    ciao

    A.

    martedì 3 luglio 2018 12:47
    Moderatore
  • esatto, si è perso un disco, nel frattempo (purtroppo non abbiamo disco di scorta in casa) dopo circa 1 ora si è guastato anche un secondo disco. quindi penso che se anche avessi sotituito il 1 disco guasto , durante la ricostruzione si sarebbe morto lo stesso. tieni presente che tutto il sistema operativo è su un altro raid 0/1, qundi, i due server nel DAG continuano a mantenere il dialogo l'uno con l'altro. Manca il disco D: dove c'era posizionato i vari database. Si , la versione èexchange 2010. 

    Quindi devo sospendere (o rimuovere ??) la copydatabase dal server che funziona e poi ricrearle , qunado riporto on-line il disco D: sul secondo server DAG ?

    grazie

    mercoledì 4 luglio 2018 06:03
  • In questo caso puoi partire provando con la sospensione. In caso non funzioni ti tocca fare remove e resync.

    Ciao.

    A.

    mercoledì 4 luglio 2018 08:50
    Moderatore
  • ciao, oggi finalmente ho ricevuto i due dischi da sostituire. ricreato il RAID5 e montato come disco D:

    ho riavviato il server (con la rete collegata) e in D: ha ricostruito il pathname D:\Program Files\Microsoft\Exchange Server\V14...... con un primo database.

    ora dalla EMC del primo server (quello che ha sempre funzionato) pero vedo :  MOUNT il db in gestione su questo server,  e in FAILED and SUSPENDED la copy database sul server ripristinato.

    devo attendere che facciano tutto loro la ri-sincronizzazione ?  o devo forzare il resync ?

    grazie

    venerdì 6 luglio 2018 14:04
  • forza pure e vedi che succede.
    domenica 8 luglio 2018 11:29
    Moderatore