none
Impossibile eliminare Server Exchange 2010 guasto RRS feed

  • Domanda

  • Buongiorno a Tutti

    Ho un sistema composto da due server Exchange 2010 sp2 installati su Windows server 2008 R2 Standard, tutti e due i server sono configurati con i tre ruoli: Hub, CAS, DB

    MI trovo a dover eliminare dalla lista dei server Exchange un server che si è guastato in maniera irreparabile , esso appare ancora in EMC Server Configuration e EMC Mailbox.

    Il server in questione era configurato con i ruoli: Hub CAS e DB.

    Se tento dii eliminarlo mi da il seguente errore:

    The mailbox database 'Mailbox Database' cannot be deleted.

    This mailbox database contains one or more mailboxes, mailbox plans, archive mailboxes, or arbitration mailboxes…..

    Ora avendo installato un nuovo server Exchange sostitutivo  e volendo creare un DAG con un secondo server Exchange non mi da la possibilità di crearlo con il seguente errore:

    An Active Manager operation failed with a transient error. Please retry the operation. Error: The fully qualified domain name for node 'SERVERGUASTO' could not be found.

    Ho verificato con ADSI l’oggetto non esiste più

    Come posso fare per eliminare  definitivamente il Server il quale ormai non esiste più

    Grazie

    giovedì 18 ottobre 2012 10:21

Risposte

  • Ciao Peppacci

    Esatto Gli attributi delle Move request li avevo azzerati ed esse erano sparite ma il problema database persisteva.

    ora forte della tua affermazione dell'utilizzo di ADSIedit ho ricreato un anuova Connessione al Dominio con ADSI

    ed è andata !!!!!

    sono riuscito finalmente a cancellare sia i database che il server, sembra che le credenziali memorizzate nell'editor avessero qualche problema.

    Ti ringrazio e anche tuuti gli intervenuti nel Thread

    Il problema è Risolto !

    Saluti

    mercoledì 24 ottobre 2012 09:33

Tutte le risposte

  • Hai già configurato un mailbox database e delle mailbox sul nuovo server?

    Se non l'hai fatto, valuta invece la rimozione del nuovo server per poi seguire la procedura di recover:

    http://technet.microsoft.com/en-us/library/dd876880.aspx

    In pratica vai a sosituire al server guasto quello nuovo mantenendo lo stesso nome. Ovviamente il server guasto non deve più essere connesso alla rete e quello nuovo lo devi prima togliere dal dominio, cambiarci il nome (deve essere uguale a quello del server guasto) e quindi seguire la procedura linkata.

    Ciao,


    Dario Palermo

    giovedì 18 ottobre 2012 10:32
  • Purtroppo il nuovo server è già operativo e contiene metà delle caselle degli utenti.

    Ciao

    Roberto

    giovedì 18 ottobre 2012 11:41
  • Non lo trovi sotto il relativo administrative group\server? Hai verificato che non ci siano ancora vecchi database di questo server defunto?

    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    giovedì 18 ottobre 2012 12:44
    Moderatore
  • No  in Active directory non ci sono .

    i vecchi DB appaiono nella EMC\Organization Configuration\Mailbox

    ma se tento di rimuoverli mi da l 'errore segnalato.

    giovedì 18 ottobre 2012 13:32
  • Che verifiche hai fatto in questo senso?

    Ciao,


    Dario Palermo

    giovedì 18 ottobre 2012 15:52
  • Ogni ricerca in active directory e ogni ricerca manuale con  ADSI

    mi ha dato esito negativo !

    Mentre con i comandi Get-MailboxDatabase e Get-ExchangeServer mi vengono mostrati sia i Database che i Server

    Ciao

    venerdì 19 ottobre 2012 09:46
  • I vecchi db, visto che non esistono più se non nella foresta, puoi cancellarli sempre con adsedit.

    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    venerdì 19 ottobre 2012 12:18
    Moderatore
  • Ciao RMilano,

    Mi inserisco nella discussione, oltre a quanto ti hanno gia' consigliato vedi tu se uno spostamento puo' tornare utile anche per il tuo scenario, di seguito la pagina Wiki creata da Andrea Gallazzi:

    Exchange 2010: How to Delete the First Database and Move the System Mailboxes

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    lunedì 22 ottobre 2012 12:38
  • Ciao A Tutti

    La situazione si è evoluta  ma non ancora risolta.

    grazie ai Vostri suggerimenti Ho scoperto che c'era un arbitration mail box ed altre due mail box non visibili IN EMC le ho eliminate con ADSI

    Poi si è posto nuovo problema con una Move-Request impossibile da cancellare ho risolto con ADSI seguendo questo link ho modificato le proprietà dell’oggetto

     http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/eeaeae5d-d42b-403b-92cd-7676e1ab3204/

    E ora ho ancora un messaggio di errore che mi impedisce di cancellare il Database che appare in EMC

    dicendo che c'è ancora una Export-request Attiva

    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    The mailbox database 'Mailbox Database' cannot be deleted.

    Mailbox Database
    Failed
    Error:
    This mailbox database is associated with one or more active MailboxExport requests. To get a list of all MailboxExport requests associated with this database, run Get-MailboxExportRequest | ?{ $_.RequestQueue -eq "<Database ID>" }. To remove a MailboxExport request, run Remove-MailboxExportRequest <Recipient ID\Request Name>.

    La Quale naturalmente non si elimina con il comando remove .

    Con ADSI continuano ad esistere sia il server che  i Database ma non posso cancellarli.

    mercoledì 24 ottobre 2012 08:06
  • Con ADSI continuano ad esistere sia il server che  i Database ma non posso cancellarli.

    Con adsiedit puoi cancellarli. 

    Cmq verifica che non ci sia questo attributo popolato su qualche utente.

    msExchMailboxMoveFlags 10


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    mercoledì 24 ottobre 2012 08:36
    Moderatore
  • Ciao Peppacci

    Esatto Gli attributi delle Move request li avevo azzerati ed esse erano sparite ma il problema database persisteva.

    ora forte della tua affermazione dell'utilizzo di ADSIedit ho ricreato un anuova Connessione al Dominio con ADSI

    ed è andata !!!!!

    sono riuscito finalmente a cancellare sia i database che il server, sembra che le credenziali memorizzate nell'editor avessero qualche problema.

    Ti ringrazio e anche tuuti gli intervenuti nel Thread

    Il problema è Risolto !

    Saluti

    mercoledì 24 ottobre 2012 09:33
  • Grazie a te per il feedback

    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    mercoledì 24 ottobre 2012 10:54
    Moderatore