locked
IE8 dopo installazione SP1 W7 32 bit RRS feed

  • Discussione generale

  • Dopo aver installato SP1 di Windows 7 32 bit tramite Windows Update, quando chiudo IE8 appare un errore "Internet Explorer ha smesso di funzionare".

    "Risolvi problemi" mi rimanda al sito Microsoft che indica:
    Messaggio di errore nel file Mshtml.dll che si verifica quando si utilizza Windows Internet Explorer 8 in un computer che esegue Windows 7: "ID evento: 1000" Ma non trovo aggiornamenti possibili italiani.

    Oltretutto ho aggiornato il sistema con Windows Update ! Potrebbe essere un Adds-On ?
    Come faccio ad individuare quale crea il problema ? Non vorrei disinstallarli tutti....

    Grazie Roby
    venerdì 25 febbraio 2011 11:31

Tutte le risposte

  • Reimpostazione di Internet Explorer
    Prova a reimpostare Internet Explorer
    Esegui il "Fix it" indicato nell'articolo della Microsoft Knowledge Base.



    Se hai problemi con l'esecuzione del "Fix it" reimposta Internet Explorer manualmente:
    1 - Opzioni Internet.
    2 - Fare clic sulla scheda Avanzate.
    3 - Nella finestra di dialogo Reimposta Internet Explorer, fare clic su Reimposta, quindi di nuovo su Reimposta.
    4 - Una volta completato il ripristino delle impostazioni predefinite di Internet Explorer, fare clic su Chiudi nella finestra di dialogo Reimposta Internet Explorer.
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    venerdì 25 febbraio 2011 12:32
    Moderatore
  • Grazie Vincenzo.

    Ho eseguito "Fix it" (opzioni internet ecc.). Dopo il "Reimposta" quasi tutti gli Adds-on sono stati disabilitati, ma non è cambiato nulla e l'errore permane....  ora provo a fare il boot del PC

    venerdì 25 febbraio 2011 13:54
  • Grazie Vincenzo.
    Prego.
    Ho eseguito "Fix it" (opzioni internet ecc.). Dopo il "Reimposta" quasi tutti gli Adds-on sono stati disabilitati, ma non è cambiato nulla e l'errore permane....  ora provo a fare il boot del PC
    Se non risolvi è necessario rimuovere e reinstallare Windows 7 Service Pack 1 (SP1).

    Vedi e segui:
    Informazioni su come installare Windows 7 Service Pack 1 (SP1)
    Risoluzione dei problemi di installazione di un Service Pack per Windows 7”.

    Saluti,


    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    venerdì 25 febbraio 2011 14:09
    Moderatore
  • Message Deleted by OP.
    venerdì 25 febbraio 2011 16:42
  • Ho disinstallato l'SP1 e tutto è tornato come prima..... sinceramente sono indeciso se riprovare l'installazione, visto quello che era successo....

    Cosa mi consigli ?

    Grazie

    Roby

     

    venerdì 25 febbraio 2011 17:29
  • Si: "Windows 7 e Windows Server 2008 R2 Service Pack 1 (KB976932)"

    Quindi? Se non hai risolto rimuovi e reinstalla il SP1 seguendo attentamente le istruzioni di cui ai link della mia precedente risposta.
    Vedi: "Come disinstallare Windows 7 Service Pack 1 (SP1)".

    Ciao,
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    venerdì 25 febbraio 2011 17:33
    Moderatore
  • Ho disinstallato l'SP1 e tutto è tornato come prima..... sinceramente sono indeciso se riprovare l'installazione, visto quello che era successo....
    Vedi e segui:
    Informazioni su come installare Windows 7 Service Pack 1 (SP1)
    Risoluzione dei problemi di installazione di un Service Pack per Windows 7”.

    Riprova.

    Grazie per il feedback, Roby.

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    venerdì 25 febbraio 2011 18:35
    Moderatore
  • Tutto ok.... reinstallato SP1 e tutto sembra andare bene.

    Grazie per la collaborazione

    Buona giornata

    Roby

     

    Nooooo !!!  Sono stato troppo precipitoso !  Proprio chiudendo IE di questo sito social.microsoft.com si è ripresentato il problema !!!!!

    Sembra accadere meno frequentemente, ma accade.

    Forse è in relazione ad un accesso con account.... devo verificare....

    No, la cosa sembra casuale e confermo che accade molto meno frequentemente di prima !

    NB: installato SP1 da file (non con Windows Update) dopo aver installato KB947821 e dopo aver bloccato Security Essentials e Firewall !!!

    Per facilitare una eventuale analisi del problema: uso Notebook HP 8730W T9600 con 4 Gb RAM IE v.8.0.7601.17514
    Conviene installare IE 9 ? Grazie Roby
    venerdì 25 febbraio 2011 19:47
  • Tip  Ti consiglio di stampare le istruzioni che seguono per una migliore esecuzione delle operazioni di troubleshooting.

    Reimposta di nuovo Internet Explorer:
    - Opzioni internet -> Avanzate -> Reimposta... -> OK -> OK.

    1. Esegui un'accurata verifica antimalware
    1
    - Software da scaricare ed eseguire, in successione, riavviando ogni volta il computer...
    1a - Scarica ed esegui lo Strumento di rimozione malware Microsoft
    Versione per Windows 64-Bit: Strumento di rimozione malware per Microsoft® Windows® (KB890830) x64
    2a - Scarica, aggiorna ed esegui Malwarebytes' Anti-Malware   
    3a - Scarica, aggiorna ed esegui anche SUPERAntiSpyware.
    4a - Fai una scansione on-line (in "Modalità provvisoria con rete", se possibile):
    http://onecare.live.com/site/it-it/center/whatsnew.htm 
    "Analisi di protezione per Windows Vista e Windows 7".
    Alert: la scansione può durare ore, attendi pazientemente che lo scanner termini il proprio lavoro.

    2. Disattiva e riattiva Windows Internet Explorer 8
    Vedi: "Attivare o disattivare le funzionalità di Windows".
    Seleziona Windows Internet Explorer in "Attivazione o disattivazione delle funzionalità Windows" per disattivarlo, riavvia il computer e quindi esegui l'operazione inversa per riattivarlo.

    3. Avvio selettivo di Windows
    Nell'ipotesi che qualche programma/servizio di terze parti causi l'inconveniente, prova ad investigare utilizzando l'Avvio selettivo di Windows 7:
    "Eseguire l'avvio selettivo utilizzando Configurazione di sistema".

    4. Avvio pulito di Windows
    Ti indico anche una procedura efficace per la risoluzione di gran parte dei problemi di conflittualità.
    Prepara e mantieni un avvio pulito.
    Digita: msconfig e dai invio nel box di ricerca del menù Start.
    Vai alla sezione Avvio.
    Togli tutte le spunte meno quelle relative all'antivirus e Windows Defender.
    Dai OK.
    Non riavviare.
    Vai alla sezione Servizi.
    Metti la spunta per nascondere tutti i servizi Microsoft (Attenzione, nascondere i servizi Microsoft per non modificarli).
    Disabilita tutti gli altri meno quelli relativi all'antivirus ed a Windows Defender.
    Dai OK.
    Non riavviare.
    Vai in C:\windows\prefetch
    Cancella tutti i file (compresa la cartella ReadyBoot che verrà ricreata) meno il file layout.ini.
    Vai in C:\windows\temp
    Cancella tutti i file cancellabili.
    Pannello di controllo > Opzioni internet -> clicca su Elimina per ripulire i File Temporanei Internet e la Cronologia.
    Dai OK.
    Vuota il cestino.
    Riavvia.
    Al riavvio scarica Wise Registry Cleaner Free Portable (non usare la versione che hai eventualmente già installato nel sistema ma scarica sempre l'ultima)
    Estrai il file e lo lanci (oppure lo installi se hai scelto la versione con l'installer).
    Metti tutte le spunte nella finestra di sinistra.
    Avvia la scansione.
    Ripara, per il momento, tutte le voci verdi.
    Riavvia.
         - Courtesy of MVP Franco Leuzzi -

    5. Rimozione e reinstallazione del software di sicurezza
    - Se non hai ancora risolto, prova a rimuovere ed a reinstallare il software antivirus o la suite di sicurezza, per test.
    - Se utilizzi un firewall di terze parti rimuovilo, attiva Windows Firewall e fai un test.

    6. Reinstallazione "in place" di Windows
    Un'altra possibilità consiste nella reinstallazione "in place", su se stesso, di Windows.
    - Avvia Windows normalmente.
    - Inserisci il DVD di Windows 7 nell'unità ottica e lancia il setup.
    - Scegli di installare come "aggiornamento".
      Non verranno toccati programmi e dati.
      Tutti i file di sistema verranno sovrascritti.
    - Dopo l'ultimo riavvio vai in Microsoft Windows Update ed installa tutti gli aggiornamenti importanti e critici.
         - Courtesy of MVP Franco Leuzzi -

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    sabato 26 febbraio 2011 05:38
    Moderatore
  • Eseguito 1a tutto ok;
    Eseguito 2a trovato PUP.WirelessKeyView $RTMSXC7exe (... ma secondo me non è uno spyware...);
    Eseguito 3a (SUPERAntispyware ha trovato 19 cookye .txt, messi in quarantena  (.....ma se questi 19 file erano degli Spyware,
    allora Microsoft Security Essentials non è affidabile !!!????!!!);
    Eseguito 4a tutto ok, salvo aggiustamenti su registro (fatto);
    Eseguito 2 (disattivato e riattivato IE8).
    Ora mi sono fermato qui ed il problema è RIMASTO !!!
    Fino a quando non ho installato l'SP1, con W7 32 bit tutto andava abbastanza bene.... ero contento di aver abbandonato XP (non ne potevo più !), di non aver installato Vista e speravo che con Windows 7 le cose fossero finalmente cambiate......

    Da un anno stavo provando Ubuntu ed ero quasi deciso ad abbandonare Microsoft.... ora se anche Windows 7 incomincia ad avere delle
    instabilità, faccio veramente il salto.....
    Scusa lo sfogo, ma non si può continuamente perdere tempo e denaro dietro ai problemi Microsoft !  Tutti i passaggi alle varie release fatti con Ubuntu non mi hanno mai creato problemi !
    Grazie in ogni caso per la costesia e la collaborazione (grazie anche a Leuzzi... anche Franco è sempre disponibile e veloce con le risposte).... non ce l'ho con Voi, naturalmente !!!!

    Roby

    sabato 26 febbraio 2011 21:47
  • Provato ad eseguire IE8 senza componenti aggiuntivi?

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Expert-IT Pro \System Administration
    sabato 26 febbraio 2011 23:25
    Moderatore
  • Supporto Microsoft per Windows 7 Service Pack 1 (SP1)
    - Supporto Microsoft gratuito per utenti privati via chat, via email o per telefono.

    Rimuovi Windows 7 Service Pack 1 (SP1) e chiedi supporto a Microsoft.

    Ciao,


    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    domenica 27 febbraio 2011 08:56
    Moderatore
  • Vincenzo, la cosa non vuole proprio andare a buon fine.....!!!!!

    Come mi hai suggerito ho cliccato "Supporto Microsoft" ed ho iserito il PID a mano (inizialmente pensavo volesse il Product Key) perchè da solo non riusciva a rilevarlo...... a questo punto mi dice che "Questo prodotto indica che il supporto sarà a pagamento" !!!!  Il notebook HP8730W quando lo acquistai montava XP e Vista (da installare...l'HD era vergine)... e non avendo alcuna intenzione di usarli, insieme all'HP8730W acquistai anche il DVD Windows 7 Professional OEM...... questo forse è il motivo della questione ?  Certamente il rivenditore non è competente per fornire supporto per l'SP1 (non lo contatto nemmeno!), ma trovo alquanto singolare che in questo caso io debba pagare Microsoft per un aggiornamento Service Pack che crea problemi !!!!  In questa situazione sono considerato da Microsoft un cliente di serie B ????  Microsoft secondo il mio punto di vista dovrebbe ringraziarmi per avergli dato l'ennesima fiducia acquistando anche Windows 7 !

    Ciao, Roby

    Scegliendo W7 SP1 sembra ok ..... vediamo.... proverò anche a telefonare.

    Grazie nuovamente per la pazienza e per l'ottimo supporto.

    NB: segnalo che modificando il post per la seconda volta, appare il messaggio in formato html.... forse c'è qualche problema anche sul sito.... (mi riferisco a questo sito del forum).
    • Modificato RobyBob domenica 27 febbraio 2011 13:01
    domenica 27 febbraio 2011 10:12
  • Contatta Microsoft Italia per telefono.
    Orario di servizio: Lun-Ven 9.00/19.00. 
    Tel.: +39 02 70398398

    Ciao,
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    domenica 27 febbraio 2011 10:37
    Moderatore
  • Ciao Vincenzo,

    sono in contatto col Supporto Microsoft via mail, ma ancora non sono riuscito a risolvere....
    Oggi spero di ricevere una nuova proposta x il superamento del problema
    Ciao........

    Roby

    " La terza volta è un disastro....

    lunedì 7 marzo 2011 09:05
  • Vincenzo, puoi cortesemente avvisare il web master di questo sito che modificando un post per la seconda volta il testo si presenta in html..... se lo modifichi per la terza volta succede il disastro che vedi sopra..... Per il mio problema sono in contatto col Supporto Microsoft via mail ma ancora non ho risolto.... spero in una nuova proposta oggi.... della serie sempre problemi.... Ciao, grazie Roby

    • Modificato RobyBob lunedì 7 marzo 2011 09:19
    lunedì 7 marzo 2011 09:13
  • Il Team STO della piattaforma TechNet/MSDN è al corrente da tempo del problema relativo alla modifica dei post.

    Per quanto riguarda il contatto con il Supporto Microsoft fai sapere com'è andata.

    Grazie,
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    lunedì 7 marzo 2011 09:16
    Moderatore
  • Il Supporto Microsoft mi ha consigliato altre procedure per superare il problema..... la prima non è andata a buon fine e per attuare la seconda (tramite l'uso di DVD W7) il sistema mi chiede di disinstallare alcuni software HP come ad esempio "BIOS Configuration for HP Protect Tool, Device Access Manager for HP Protect Tool, HP Embedded Security Protect Tolls e HP-Protect Tools Security Manager Suite" !!      Considerando che in fase di installazione di W7 un anno e mezzo fa sono stato al telefono col Supporto HP per due o tre giorni per superare criticità riguardanti il mancato riconoscimento di dispositivi hardware (modem interno, lettore impronte digitali, ecc.) e che questi software HP da disinstallare sono legati alla sicurezza (accesso con impronte digitali ecc.), preferisco lasciare perdere !!!!  Ho sentito anche il Supporto HP ma le cose rimangono queste. Ho deciso quindi di NON installare SP1 !!!!!!  Gira gira con Microsoft siamo sempre ai soliti problemi..... nulla da dire in merito alla professionalità e cortesia del personale del Supporto Microsoft a Milano (bravi e disponibili!), ma la mia esperienza con i S.O. Microsoft è sempre stata difficile..... devi mettere in conto ore di lavoro per superare le inevitabili criticità che prima o poi si presentano.... ed a quanto sembra anche con Windows 7 le cose sono rimaste le stesse....

    Ringrazio anche Voi MVP per la pazienza e la disponibilità.  Buona giornata

    Roby

    martedì 8 marzo 2011 11:07
  • Si, sono al corrente, e posso confermare, che in gran parte dei casi la reinstallazione di Windows risolve il problema consentendo con successo l'applicazione del Service pack 1 per Windows 7, infatti nei Forum Microsoft Answers abbiamo trattato molti casi del genere, risolti appunto con la reinstallazione "in place" di Windows.

    E' l'unica via da percorrere per installare il SP1 in sistemi verosimilmente compromessi a livello di file e Registro di sistema.

    Considera che non installando il Service Pack 1 avrai l'accesso interdetto alla maggior parte dei successivi aggiornamenti di Windows.

    Comunque, la scelta è tua.

    Grazie a te per il feedback e buon proseguimento.

    Cheers,
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    martedì 8 marzo 2011 12:09
    Moderatore