none
Come mai 2 server di exchange si passano le mail prima di inviarle fuori, ma solo a volte? RRS feed

  • Domanda

  • Ciao a tutti,

    Ho 2 server exchange 2003 in un dominio.

    servers virtuali SMTP configurati in maniera pressochè identica e standard.

    configurato connettori SMTP per l'invio verso dominio specifico e uno per tutti gli indirizzi.

     

    Nel tracking dei messaggi del server primario noto che i messaggi in uscita vengono prima passati al secondario e poi fatti uscire.

    Le cassette di posta che inviano i messaggi si trovano sul primario.

    Mi sapete dire come mai e come forzare l'inoltro dei messaggi verso l'esterno con uno piuttosto che con l'altro?

     


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    venerdì 26 novembre 2010 11:54

Risposte

  • @Peppacci: esattamente, è dal tracking che ho "spottato" questa cosa.. l'organizzazione ha qualche problemino di posta e siamo andati a vedere a campione e...

     

    @Andrea: ho il connettore SMTP nel routing group, ma prima dell'altro giorno il server "secondario" non era listato nei server locali (These servers can send mail over this connector ) di quel connettore.
    Comunque il cost-box ha senso se ho più connettori e voglio scegliere da quale mandare fuori, in questo caso parliamo di un singolo connettore SMTP (ce n'è un altro per un singolo dominio in trust in un altra sede con nome dominio locale != nome dominio internet, ma non fa testo.)

     

    RISOLUZIONE:

    Ho aggiunto il server secondario come server locale abilitato all'invio della posta nel connettore.

    Ho riconfigurato i server virtuali SMTP per avere entrambi le STESSE identiche impostazioni.

    il server virtuale SMTP primario aveva configurato dei DNS esterni e IMF, mentre quello del secondario NO.

    Riconfigurato in questa maniera il flusso della posta ha ricominciato a seguire la strada più corretta. (penso che la chiave di volta sia il fatto che il server di backup non era presente nel connettore)

     

    Sarebbe interessante capire come Exchange decide di instradare la posta verso l'esterno nell'ambito di una situazione come questa....  Ci so potrebbe aspettare che:

    • non essendo abilitato attraverso il connettore
    • non essendo il server Master per quel routing group
    • non essendo il server che riceve la posta in carico dalle connessioni MAPI
    • NON ESSENDO ABILITATO ALL'INVIO DELLA POSTA nel connettore APPOSITAMENTE CONFIGURATO per l'invio della posta a LIVELLO ORGANIZZAZIONE.

    il server secondario NON dovesse spedire nulla....

     

    Anyway, speriamo che questo post opssa aiutare qualcun'altro in futuro...


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Contrassegnato come risposta Diego Castelli martedì 30 novembre 2010 14:48
    martedì 30 novembre 2010 14:48
  • piccolo aggiornamento: ho scoperto come mai veniva scelto il server di backup per instradare la posta.

    Il server primario puntava a DNS del DC primario che inoltrava a DNS del provider come forwarders per i domini non diversamente specificati. Alcuni di questi DNS non sono più validi. Il provider ne aveva dato comunicazione, ma non era stato preso nella corretta considerazione.

    il server secondario, essendo lui un DC di backup, puntava a se stesso per la risoluzione dei nomi ed inoltre usava i root hints per i nomi su internet.

    inoltre quei DNS erano presenti nella lista degli external DNS nella configurazione del SMTP virtual server.

    cco perchè il sistema Exchange dava priorità al server secondario per l'uscita della posta!!!! Andava molto più veloce e stabile nella risoluzione dei nomi!!!!

     

    Spero che questo possa essere di esempio per qualcun'altro in futuro. :-)

     

    P.S. c'è sempre una spiegazione logica!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Contrassegnato come risposta Diego Castelli martedì 7 dicembre 2010 10:40
    martedì 7 dicembre 2010 10:39

Tutte le risposte

  • Ciao Diego,

    Exchange Server 2003 determina il percorso che una e-mail deve prendere in base allo stato e alla disponibilità dei connettori tra i diversi gruppi di routing e dei sistemi di messaggistica esterni attraverso un connettore SMTP o altri connettori.

    Ogni server Exchange memorizza le informazioni sul suo stato in una tabella Link State Table (LST).

    Puoi utilizzare WinRoute per verificare il comportamento di LSA e di conseguenza LST

    Reference:

    http://www.msexchange.org/tutorials/WinRoute-Routing-status-Exchange-organization.html

    http://www.msexchange.org/tutorials/Exchange-Server-2003-Mailflow-Part1.html


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    venerdì 26 novembre 2010 14:59
  • Avevo letto il mailflow tutorial di msexchange, ma sinceramente non capisco come forzare il flusso ad uscire da un server specifico.. c'è questa possibilità?

    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    venerdì 26 novembre 2010 16:01
  • Prova a cambiare il costo a seconda di quello vuoi utilizzare come prioritario

    cerca cost box nella kb seguente

    http://support.microsoft.com/kb/822929/en-us

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    venerdì 26 novembre 2010 16:27
  • Entrambi i server sono nei connettori? Ma da tracking vedi che a livello smtp il messaggio è andato dal server01 al 02 per poi uscire?
     
    Peppacci - MVP -
    Microsoft Exchange Server
    http://blogs.sysadmin.it/peppacci/Default.aspx

    --------------------------------------------------------------------------------
    Peppacci - MVP - Microsoft Exchange Server http://blogs.sysadmin.it/peppacci/Default.aspx

    Peppacci - MVP - Microsoft Exchange Server http://blogs.sysadmin.it/peppacci/Default.aspx
    lunedì 29 novembre 2010 16:04
    Moderatore
  • @Peppacci: esattamente, è dal tracking che ho "spottato" questa cosa.. l'organizzazione ha qualche problemino di posta e siamo andati a vedere a campione e...

     

    @Andrea: ho il connettore SMTP nel routing group, ma prima dell'altro giorno il server "secondario" non era listato nei server locali (These servers can send mail over this connector ) di quel connettore.
    Comunque il cost-box ha senso se ho più connettori e voglio scegliere da quale mandare fuori, in questo caso parliamo di un singolo connettore SMTP (ce n'è un altro per un singolo dominio in trust in un altra sede con nome dominio locale != nome dominio internet, ma non fa testo.)

     

    RISOLUZIONE:

    Ho aggiunto il server secondario come server locale abilitato all'invio della posta nel connettore.

    Ho riconfigurato i server virtuali SMTP per avere entrambi le STESSE identiche impostazioni.

    il server virtuale SMTP primario aveva configurato dei DNS esterni e IMF, mentre quello del secondario NO.

    Riconfigurato in questa maniera il flusso della posta ha ricominciato a seguire la strada più corretta. (penso che la chiave di volta sia il fatto che il server di backup non era presente nel connettore)

     

    Sarebbe interessante capire come Exchange decide di instradare la posta verso l'esterno nell'ambito di una situazione come questa....  Ci so potrebbe aspettare che:

    • non essendo abilitato attraverso il connettore
    • non essendo il server Master per quel routing group
    • non essendo il server che riceve la posta in carico dalle connessioni MAPI
    • NON ESSENDO ABILITATO ALL'INVIO DELLA POSTA nel connettore APPOSITAMENTE CONFIGURATO per l'invio della posta a LIVELLO ORGANIZZAZIONE.

    il server secondario NON dovesse spedire nulla....

     

    Anyway, speriamo che questo post opssa aiutare qualcun'altro in futuro...


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Contrassegnato come risposta Diego Castelli martedì 30 novembre 2010 14:48
    martedì 30 novembre 2010 14:48
  • grazie a voi dell'aiuto!

    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    venerdì 3 dicembre 2010 08:33
  • piccolo aggiornamento: ho scoperto come mai veniva scelto il server di backup per instradare la posta.

    Il server primario puntava a DNS del DC primario che inoltrava a DNS del provider come forwarders per i domini non diversamente specificati. Alcuni di questi DNS non sono più validi. Il provider ne aveva dato comunicazione, ma non era stato preso nella corretta considerazione.

    il server secondario, essendo lui un DC di backup, puntava a se stesso per la risoluzione dei nomi ed inoltre usava i root hints per i nomi su internet.

    inoltre quei DNS erano presenti nella lista degli external DNS nella configurazione del SMTP virtual server.

    cco perchè il sistema Exchange dava priorità al server secondario per l'uscita della posta!!!! Andava molto più veloce e stabile nella risoluzione dei nomi!!!!

     

    Spero che questo possa essere di esempio per qualcun'altro in futuro. :-)

     

    P.S. c'è sempre una spiegazione logica!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Contrassegnato come risposta Diego Castelli martedì 7 dicembre 2010 10:40
    martedì 7 dicembre 2010 10:39