none
Exchange Reinstallazione e ripristino Dati. RRS feed

  • Discussione generale

  • Ho rimosso e reinstallato Exchange 2010 sp2 senza eseguire "/m :recoverserver". Posso ripristinare il backup fatto con wsbackup della vecchia installazione?
    La macchina è la stessa, solito nome, ip, s.o. win 2008, percorsi.
    Il ripristino con wsbackup da errore se effettuato nel percorso originale, invece in caso di scelta del percorso alternativo ...dalla console di exchange , vedo il db ripristinato ma da errore se viene montato.
     
    Grazie
    • Tipo modificato Anca Popa mercoledì 19 febbraio 2014 14:08 discussione in corso
    venerdì 14 febbraio 2014 16:11

Tutte le risposte

  • Ciao, ma il backup di windows come era impostato? macchina completa? o solo db? 
    venerdì 14 febbraio 2014 17:23
    Moderatore
  • Ciao. Backup completo dell'intero volume dedicato a exchange
    venerdì 14 febbraio 2014 17:30
  • Si ok, ma fatto come? Tipo "salva tutto d:\" oppure selezionando dal backup apposito il datastore di exchange in modo che venga correttamente fatto ed azzerati i logs?
    venerdì 14 febbraio 2014 19:46
    Moderatore
  • Backup - custom- x(solo il volume di exchange)- avanzate= vss full backup. Non ho selezionato il full server, ma custom.Ciao
    venerdì 14 febbraio 2014 20:57
  • Ok, prova a ripristinare dando in occhio a questa guida. http://social.technet.microsoft.com/Forums/it-IT/86bd5049-3907-45e0-bec5-d91a50e11204/exchange-2010-restore-database-e-mailbox-tramite-i-recovery-database?forum=benvenutiannunciit
    venerdì 14 febbraio 2014 21:09
    Moderatore
  • Bgiorno

    Il GUID è diverso fra il backup della vecchia installazione con quello della nuova installazione.E' questo il problema?

    Ho fatto anche io la stessa procedura del link, ma non termina il ripristino in caso di percorso originario e  da errore Id evento 739 "Operazione di ripristino di componenti 'be1dadc3-9cde-4a8f-a15c-77bee8aba543' non riuscita con errori alle ore '‎2014‎-‎02‎-‎15T07:50:03.672000000Z'...". Ho utilizzato il comando indicato nel Link e riscontro il GUID differente. Ciao

    sabato 15 febbraio 2014 07:57
  • eh si che sta li il problema...scusa la domanda stupida ma rifare l'install con il /m non l'hai tentata come strada? perchè adesso fargli prendere un db che non è il suo secondo lui non è che sia una cosa fattibile...di quanti GB stiamo parlando? 
    sabato 15 febbraio 2014 09:40
    Moderatore
  • Come da domanda non ho eseguito /m, devo ripristinare circa 300mb. Non e' + possibile?
    sabato 15 febbraio 2014 10:01
  • ok, ma hai riprovato a rilanciare la procedura col /m invece? 300Mb? solo? Ma non sono niente...ma questo server da quanto tempo era in piedi scusa? Non hai nessuna copia sui client?
    sabato 15 febbraio 2014 10:25
    Moderatore
  • Devo disinstallare e reinstallare con /m? Se eseguo il setup recovery /m sulla nuova installazione non la termina, da ruoli già installati. I client hanno il pst, ma non trovo l'email che mi interessa. Ciao
    sabato 15 febbraio 2014 10:56
  • Be' chiaro che ti dice che è già su, dovresti rimuovere di nuovo exchange e rimetterlo su col /m. Perdonami ma tutto sto disastro per recuperare una mail? prendi giù un programma di terze parti che ti estrae le mail dal db e prendila fuori con quello in versione demo te ne fanno recuperare al massimo 5...perdere 2gg per una mail non ha senso anche a livello di costi..un discorso diverso è un db da 50Gb...non credi?

    A.

    sabato 15 febbraio 2014 11:29
    Moderatore
  • No, per l'organizzazione o il cliente potrebbe avere un valore inestimabile. L'esigenza dell'utenza non ha limiti, oggi una sola email domani altre... Se ripristino l'intero archivio soddisfo eventuali richieste successive.
    Ho disinstallato e reinstallato con "Setup /M:RecoverServer" ma da il seg errore

    " ... Nessun server
    installato nel computer. Installare Exchange Server.
    Impossibile trovare il server in Active Directory. Per eseguire il necessario che il server sia presente in Active Directory.
    Errore rilevato dal programma di installazione di Exchange Server." Ciao

    sabato 15 febbraio 2014 13:06
  • Ma questo server non è anche un domain controller vero? Cioè era un server dedicato exchange domain joined corretto?
    sabato 15 febbraio 2014 14:55
    Moderatore
  • Si, si corretto.
    sabato 15 febbraio 2014 15:04
  • Ok, ora per fare le cose fatte bene devi rimuovere questo server con la disinstallazione di exchange e poi rifare la macchina col recoverserver switch, la cosa che mi lascia un po perplesso è come veniva effettivamente eseguito il backup perchè non capisco se hai tutto quello che ti serve per riprenderlo indietro...ad ogni modo te ne accorgi subito, se si ferma in reinstallazione sei a piedi a quel punto mi sa che per forza devi orientarti su un estrattore di terze parti perchè non ho altre soluzioni per farti rimontare il db. Se i colleghi hanno altre idee naturalmente le metteranno in campo.
    sabato 15 febbraio 2014 15:59
    Moderatore
  • Devo disinstallare exchange, poi tolgo il server dal dominio e rifaccio il join del server al dominio e re installo exchange con /m ? Non so e' rilevante, la disinstallazione e' stata portata a termine con la disabilitazione delle cassette postali.
    sabato 15 febbraio 2014 16:23
  • si esatto. Ma la disinstallazione andava fatta con la rimozione delle cassette postali non solo la disabilitazione, tanto quando fai un recoverserver /m rimette tutte le cassette preesistenti al posto giusto. Non so però visto tutto quello che hai fatto se riuscirai a riprendere indietro il server come prima perchè la tua AD secondo me è molto sporca..in ogni modo puoi tentare. Tieni presente gli estrattori del DB, io avrei già soprasseduto, 2gg per recuperare 300Mb di posta non sono accettabili, ma capisco il "provarle tutte". 

    Ciao.

    A.

    domenica 16 febbraio 2014 09:46
    Moderatore
  • Ok provo questa strada.
    Vi chiedo un chiarimento, ma se l'hardware fosse stato irreparabile, questo backup del solo volume non avrei potuto recuperalo in un'altra macchina?
    Ciao
    • Modificato Win3000 venerdì 28 febbraio 2014 20:09 test
    domenica 16 febbraio 2014 14:47
  • Per il bare metal backup e conseguente recovery devi impostare il salvataggio in un certo modo http://technet.microsoft.com/en-us/library/ee849849(v=ws.10).aspx#BKMK_BMR Personalmente non ho mai testato però il tutto su un server exchange usando il backup di windows, uso programmi di terze parti per i server di posta, non perchè il windows backup non sia affidabile ma ho bisogno di gestire e navigare i backup in velocità e volendo di porterli virtualizzare in poche ore. Ciao. A.
    domenica 16 febbraio 2014 15:10
    Moderatore
  • Ciao,

    Che errore ?
    Esegui il ripristino in "Alternate Location" per avere i file .edb e .log poi fammi sapere che andiamo avanti da lì.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    lunedì 17 febbraio 2014 09:40
  • Ciao,

    Non abbiamo ricevuto alcun aggiornamento e mi chiedevo se ci sono stati eventuali sviluppi dopo i consigli di Alessandro e Gabriele.

    Se così fosse ti saremmo grati di condividere il feedback in questo spazio ricordandoti che altri membri della community potrebbero riscontrare comportamenti simili.

    Grazie in anticipo,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    mercoledì 19 febbraio 2014 14:07