none
Migrazione Exchage 2007 > 2010 RRS feed

  • Domanda

  • Salve a tutti, e scusate subito se il post è un po' lungo .....

    dopo aver cartato varie soluzioni mi trovo in una situazione "fastidiosa"

    Questa la cronostoria:

    In origine c'era un win2003 X64 con DC e Exchange 2007 (so che non andrebbe EX2007 su DC ma purtroppo questa era situazione)

    A questo punto sono stati aggiunti due DC e trasferiti i ruoli FSMO e GC (uno fisico e uno virtuale)

    Poi è stato aggiunto un 2008R2 membro di dominio e su questo installato EX2010

    Migrate le cassette postali e tutto sembrava ok (i client sono passati quasi in modo automatico sotto EX2010)

    A questo punto abbiamo tentato di effettuare la disitallazione di EX2007 ma riporta sempre errori che non può disintallare i ruolo cassetta postale (nonostante siano tutte trasferite)

    Poi sono cominciati i problemi.......

    Abbiamo declassato a membro di dominio il server che ha EX2007 e qui le cose sono peggiorate (nonostante sembra che tutto funzioni (riceviamo posta su EX2010 e inviamo regormante)

    Quello che succede e che non si riesce a togliersi dai piedi questo EX2007 e qualche traccia sel vecchio DC negli errori.

    La EMC continua a dare errori al primo click su rami

    ------

    Questo un esmpio dell'errore che trovo in 2008r2

    Preciso che il server "SERVERDC1" è il vecchio DC con EX2007

    Il server "MX1" invece è il nuovo 2008 membro di dominio con EX2010

    Sotto trovate anche un screenshoot dei uno degli errori che compiaio in EMC

    Nome registro: Application
    Origine:       MSExchange Configuration Cmdlet - Remote Management
    Data:          15/10/2012 11:36:18
    ID evento:     4
    Categoria attività:Generale
    Livello:       Errore
    Parole chiave: Classico
    Utente:        N/D
    Computer:      mx1.XXXXXXXX.it
    Descrizione:
    (PID 5800, Thread 12) L'attività Get-OwaVirtualDirectory ha compilato un messaggio di errore durante l'elaborazione del record di indici 0. Errore: Microsoft.Exchange.Management.Metabase.IISGeneralCOMException: Impossibile creare una voce di directory di IIS. Messaggio di errore: Accesso negato.
    . HResult = -2147024891. ---> Microsoft.Exchange.Management.Metabase.COMDetailException: Accesso negato.
    .
    Percorso di directory: IIS://serverdc1.XXXXXXXX.it/W3SVC/1/ROOT/Exadmin
    Dettaglio:
    server name: serverdc1.XXXXXXXX.it
    local machine name: MX1
    local machine fqdn: mx1.XXXXXXXX.it ---> System.Runtime.InteropServices.COMException (0x80070005): Accesso negato.

       in System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
       in System.DirectoryServices.DirectoryEntry.Exists(String path)
       in Microsoft.Exchange.Management.Metabase.IisUtility.CreateIISDirectoryEntry(String iisDirectoryEntryPath, TaskErrorLoggingDelegate writeError, Object identity)
       --- Fine dell'analisi dello stack dell'eccezione interna ---
       --- Fine dell'analisi dello stack dell'eccezione interna ---
    XML evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange Configuration Cmdlet - Remote Management" />
        <EventID Qualifiers="49152">4</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-10-15T09:36:18.000000000Z" />
        <EventRecordID>6571</EventRecordID>
        <Channel>Application</Channel>
        <Computer>mx1.XXXXXXXX.it</Computer>
        <Security />
      </System>
      <EventData>
        <Data>5800</Data>
        <Data>12</Data>
        <Data>Get-OwaVirtualDirectory</Data>
        <Data>0</Data>
        <Data>Microsoft.Exchange.Management.Metabase.IISGeneralCOMException: Impossibile creare una voce di directory di IIS. Messaggio di errore: Accesso negato.
    . HResult = -2147024891. ---&gt; Microsoft.Exchange.Management.Metabase.COMDetailException: Accesso negato.
    .
    Percorso di directory: IIS://serverdc1.XXXXXXXX.it/W3SVC/1/ROOT/Exadmin
    Dettaglio:
    server name: serverdc1.XXXXXXXX.it
    local machine name: MX1
    local machine fqdn: mx1.XXXXXXXX.it ---&gt; System.Runtime.InteropServices.COMException (0x80070005): Accesso negato.

       in System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
       in System.DirectoryServices.DirectoryEntry.Exists(String path)
       in Microsoft.Exchange.Management.Metabase.IisUtility.CreateIISDirectoryEntry(String iisDirectoryEntryPath, TaskErrorLoggingDelegate writeError, Object identity)
       --- Fine dell'analisi dello stack dell'eccezione interna ---
       --- Fine dell'analisi dello stack dell'eccezione interna ---</Data>
        <Data>{5b237a09-4da4-4269-8c32-2adba39c520a}</Data>
      </EventData>
    </Event>

    Alcuni Screeshoot da EMC

    • Tipo modificato Anca Popa mercoledì 17 ottobre 2012 19:07 in attesa di ulteriori feedback
    • Tipo modificato Anca Popa giovedì 25 ottobre 2012 11:03 thread risolto
    lunedì 15 ottobre 2012 13:39

Risposte

  • http://www.commodore.ca/windows/exchange/how_to_upgrade_exchange_2007_to_exchange_2010_in_2hours.htm

    Qui sono riassunti i passaggi fondamentali per la migrazione. Verifica se ti sei perso qualche pezzo.


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    • Contrassegnato come risposta Anca Popa giovedì 25 ottobre 2012 11:09
    mercoledì 17 ottobre 2012 06:40
    Moderatore
  • Finale......

    La procedura alla fine è stata:

    di creare una vm 2003r2 x64  +(aggiornamenti vari)

    resettare vecchio server dal dominio

    dare lo stesso nome del vecchio srv alla nuova virtuale, fare join a dominio della vm

    download di ex2007sp3 ed esecuzione di setup.com /m:RecoverServer /DoNotStartTransport

    a questo punto ho rimosso tutte le replice dalle cartelle pubbliche e distintallato ex2007

    Tolto la macchia dal dominio e ciaooooooo

    Finalemente !!

    Adesso parte una nuova avventura... migrare Sharepoint 2007 a 2010 ...... ma posterò in altro forum!!

    • Contrassegnato come risposta Anca Popa giovedì 25 ottobre 2012 11:09
    venerdì 19 ottobre 2012 17:30

Tutte le risposte

  • Ciao Riccardo,

    A parte gli accessi negati quando apri la console/shell di E2K10 mi sembra che il problema sia disinstallare Exchange 2007.

    Che errore ti da quando cerchi di farlo ?

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    lunedì 15 ottobre 2012 14:27
  • In questo momento non riuscendo ad avviarsi lo store mi segnala che non è possbile disinstallare

    Questo gli errori in avvio di store

    Errore 0x80004005 durante l'inizializzazione della Libreria di conversione Internet di Microsoft Exchange Server (ID 1180)

    Impossibile inizializzare il servizio Archivio informazioni di Microsoft Exchange.   - Errore 0x80004005. (ID 5000)

    lunedì 15 ottobre 2012 19:49
  • Faccio una richiesta ulteriore...... come posso capire se qualche "pezzo" del vecchio EX2007 è ancora necessario all'organizzazione ?

    Mi spiego meglio, se spengo il vecchio server ci sembra di vedere dei disservizi (non ancora ben chiari) sul nuovo Ex2010. Se invece è acceso anche Ex2010 sembra funzionare meglio.

    Premetto che tutte le porte 25/443 sono "nattate" sul nuovo Ex2010

    martedì 16 ottobre 2012 08:12
  • http://www.commodore.ca/windows/exchange/how_to_upgrade_exchange_2007_to_exchange_2010_in_2hours.htm

    Qui sono riassunti i passaggi fondamentali per la migrazione. Verifica se ti sei perso qualche pezzo.


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    • Contrassegnato come risposta Anca Popa giovedì 25 ottobre 2012 11:09
    mercoledì 17 ottobre 2012 06:40
    Moderatore
  • Allora posto degli aggiornamenti per i posteri......

    Gli errori degli screenshoot sono scomparsi dopo aver installato SP1 e SP2

    Le stranezze sui client e la presunta dipendenza dal vecchio server sono sparite dopo aver cancellato e ricreato la rubrica offline (in precedenza era solo stata riassegnata al nuovo server)

    Terza ed ultima cosa sul client è stata forzata il download della rubrica "Elenco indirizzi globale"

    Adesso diciamo che tutto"gira" ma ancora non sono riuscito a disinstallare ex2007 in quanto lo store non si avvia...

    Ho provato ha usare setup /m:RecoverServer ma mi segnala che una precedente tentativo di disinstallazione ha fallito.

    Che consigli potete darmi ..... provo questa o c'è qualcosa di meglio? Grazie 1000

    http://www.msexchange.org/tutorials/Recovering-Exchange-2007-Server-RecoverServer-switch.html

    giovedì 18 ottobre 2012 12:51
  • Con store intendi il DB? Se così fosse e se sei sicuro che su quel db non ci sono più mailbox puoi cancellarlo tramite adsiedit

    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    venerdì 19 ottobre 2012 12:21
    Moderatore
  • Finale......

    La procedura alla fine è stata:

    di creare una vm 2003r2 x64  +(aggiornamenti vari)

    resettare vecchio server dal dominio

    dare lo stesso nome del vecchio srv alla nuova virtuale, fare join a dominio della vm

    download di ex2007sp3 ed esecuzione di setup.com /m:RecoverServer /DoNotStartTransport

    a questo punto ho rimosso tutte le replice dalle cartelle pubbliche e distintallato ex2007

    Tolto la macchia dal dominio e ciaooooooo

    Finalemente !!

    Adesso parte una nuova avventura... migrare Sharepoint 2007 a 2010 ...... ma posterò in altro forum!!

    • Contrassegnato come risposta Anca Popa giovedì 25 ottobre 2012 11:09
    venerdì 19 ottobre 2012 17:30
  • Ok

    Grazie per il feedback.


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx

    venerdì 19 ottobre 2012 17:51
    Moderatore