none
Credenziali di accesso RemoteApp RRS feed

  • Domanda

  • Buongiorno, ho configurato un ambiente con 1 TS SESSION BROKER che gestisce il carico di connessioni tra 3 TS. I TS pubblicano una RemoteApp. La sequenza di accesso alla RemoteApp risulta per gli utenti fastidiosa in quanto:

    1) è necessario accedere tramite browser al link http://tsbroker/rdweb dove è necessario inserire account/pwd di dominio

    2) appare una form intitolata RemoteApp dove vengono richieste le credenziali per accedere al TS SESSION BROKER è quindi necessario inserire nuovamente account/pwd di dominio

    3) Appare un messaggio di errore relativo al nome del certificato associato alla RemoteApp. Questo perchè il nome del computer remoto è FarmTSBroker mentre il nome del certificato è quello del TS che pubblica la RemoteApp

    Gli utenti mi chiedono di consentire l'esecuzione della RemoteApp inserendo esclusivamente le credenziali al punto 1.

    Potete suggerirmi come procedere ?

    Grazie

    Lele

    venerdì 13 maggio 2011 07:49

Tutte le risposte

  • apri iis manager, consenti l'accesso anonimo a http://tsbroker/rdweb quindi ti verrà richiesta solo la password del punto 2.

    per il certificato, devi trustarlo inserendolo nei nei trusted root certificates di ciascun client.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    venerdì 13 maggio 2011 08:23
    Moderatore
  • In IIS la situazione di partenza era:

    Anonymous authentication enabled, asp.net impersonation disabled, forms authentication disabled, windows authentication enabled

    Poi ci sono le sottocartelle di RDWeb per le quali ci sono delle differenze:

    app_data - Anonymous authentication enabled, asp.net impersonation disabled, forms authentication disabled, windows authentication enabled

    error - Anonymous authentication enabled, asp.net impersonation disabled, forms authentication disabled, windows authentication enabled

    feed - Anonymous authentication enabled, asp.net impersonation disabled, forms authentication enabled, windows authentication enabled

    feedlogin - Anonymous authentication disabled, asp.net impersonation disabled, forms authentication disabled, windows authentication enabled

    pages - Anonymous authentication enabled, asp.net impersonation disabled, forms authentication enabled, windows authentication disabled

    Sono corretti ? L'unica cartella che ha Anomymous authentication - disabled è "feedlogin" .

    Rimane il problema del certificato, pur avendolo installato in "Autorità di certificazione fonti attendibili" del mio client appare il messaggio di errore "Il nome del server presente sul certificato è errato". Pur selezionando "Non visualizzare più questo messaggio per le connessioni a questo computer" la situazione non cambia,.

     

    Grazie

    Emanuele

     


    venerdì 13 maggio 2011 09:11
  • 1) non ho capito se il rpoblema di una sola richiesta credenziali è risolto oppure no.

    2) l'errore sul certificato ce l'hai perchè il common name del certificato non corrisponde al sito a cui punti: affinchè non compaia quell'errore il common name del certificato deve coincidere con quello del sito.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    venerdì 13 maggio 2011 11:55
    Moderatore
  • Ciao Edoardo:

     

    1) ho impostato "Anonymous authentication" enabled per rdweb/feedlogin e sembra che mi vengano richieste solo le credenziali al punto 1, quindi questo dovrebbe essere ok

    2) il problema è che facendo parte i 3 TS di una Farm del TS Session Broker il computer remoto a cui ci si connette ha il nome della Farm "FarmTSBroker.domain.local" mentre i certificati hanno il nome ognuno del TS session host in cui sono stati generati (quindi ho 3 certificati ognuno con il nome di un TS e sono quelli che ho importato nel mio client). C'è un modo per generare un certificato con il nome della Farm ?

    Ciao

    Emanuele

     

    venerdì 13 maggio 2011 12:52
  • 2) il problema è che facendo parte i 3 TS di una Farm del TS Session Broker il computer remoto a cui ci si connette ha il nome della Farm "FarmTSBroker.domain.local" mentre i certificati hanno il nome ognuno del TS session host in cui sono stati generati (quindi ho 3 certificati ognuno con il nome di un TS e sono quelli che ho importato nel mio client). C'è un modo per generare un certificato con il nome della Farm ? 


    certo che il modo c'è: basterrebe richiedere un certificato ad-hoc alla tua CA. tu come hai generato i certificati ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    venerdì 13 maggio 2011 13:06
    Moderatore
  • Dallo snap-in Certificates dei 3 ts ho richiesto un nuovo certificato "Server Authentication" e viene assegnato in automatico il nome del TS. A me invece servirebbe un certificato con il nome della Farm che non corrisponde al nome di alcun server.

    Ciao

    Lele

     

    venerdì 13 maggio 2011 13:26
  • Guarda questo thread, si tratta di "customizzare" il template

    http://social.technet.microsoft.com/Forums/en-US/winserversecurity/thread/f033467f-f3d1-4f57-8b12-9348a5be112e


    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    venerdì 13 maggio 2011 13:32
  • Putroppo si ripropone il problema della doppia richiesta password:

    mi viene nuovamente richiesta sia nel form di accesso al TS BROKER che dopo aver lanciato la RemoteApp.

     

    Lele

    venerdì 13 maggio 2011 14:06
  • Hai provato a richiedere il certificato con il template modificato e usando il nome della farm come da mio post precedente ?
    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    venerdì 13 maggio 2011 14:16
  • Ciao FAbrizio, ricomincerò a laovrarci oggi pomeriggio. Ancora non sono arrivato alla modifica del template volevo prima risolvere il problema della doppia richiesta della password. Nonostante abbia abilitato "Anonymous logon" in IIS ed abbia impostato l'autenticazione rdp delle RemoteApp continua la doppia richiesta della password.

    Da cosa può dipendere ?

     

    Ciao

    lunedì 16 maggio 2011 10:59