none
Mail con intestazioni non valide RRS feed

  • Domanda

  • Salve a tutti,

    ho un problema con un exchange 2007 sp1 e il connettore pop3 sull'sbs2008.

    Quando il connettore va a scaricare le mail dal server del provider segnala spesso che ci sono una o più mail con intestazioni non valide e non le scarica lasciandole dove stanno causando non pochi problemi. Vi è una maniera per dirgli di scaricarle lo stesso e recapitarle alla cassetta postale di destinazione come tutte le mail "buone" ed evitare di andare via webmail del provider a leggerle e cancellarle ?

    Qualcuno sa dirmi a cosa sono dovute queste intestazioni strane (leggevo di antivirus, antispam,.... che possono causare tale problema) ?

    Grazie

    M.Cris

    mercoledì 2 novembre 2011 08:11

Risposte

Tutte le risposte

  • Hola M.Cris,
     
    parto dal concetto che non vuoi o non puoi pubblicare exchange quindi sei
    obbligato a usare un connettore POP3.
     
    Quale errore trovi esattamente nell'event viewer?
    Hai provato a usare un altro connettore?
    Hai lo stesso problema?
    Come mai hai solo il SP1 di Exchange? Non tieni aggiornato il server?
     
     

    Mitch
    Microsoft Exchange MVP | MCSE | MCTS | MCITP | MCT
    http://blogs.dotnethell.it/mitch
    http://www.windowserver.it
    http://www.windowservers.es

    mercoledì 2 novembre 2011 15:44
  • Ciao,

    per la pubblicazione hai ragione, loro non vogliono anche se sembra ci siano ripensamenti, comunque ci vorrà ancora tempo.

    per l'event viwer l'errore preciso non c'è l'ho adesso però diceva che una o più mail ha il campo d'intestazione non valido ....... Appena riesco vedo di recuperarlo con precisione.

    Per quanto riguarda un 'altro connettore sinceramente non ho provato dato che avevo quello dell'sbs a disposizione.

    Per quanto riguarda l'sp1 il fatto è che è un cliente appena preso a livello tecnico che aveva già tutto ma montato in maniera a dir poco disastrosa (sia pc che rete che srv -definiamolo tale- in maniera fai-da-tè e non utilizzando quello che aveva già) e che ci ha contattato per sistemare un po' il tutto. Un pezzo alla volta e arrivo anche all'sp3 ......

    M.Cris

    giovedì 3 novembre 2011 08:24
  • Hola M.Cris,
     
    aspettiamo l'errore esatto, il fatto di provare un altro connettore era per
    vedere se quello del 2008 aveva problemi.
    Aparte del sp3 di exchange, ovviamente sono importanti anche quelli di sbs,
    quindi un buon windows update completo.
     
     

    Mitch
    Microsoft Exchange MVP | MCSE | MCTS | MCITP | MCT
    http://blogs.dotnethell.it/mitch
    http://www.windowserver.it
    http://www.windowservers.es

    giovedì 3 novembre 2011 19:20
  • Ciao,

    allora l'id nell' event viewer del connetttore pop3 è il 217 e come dicevo dice che uno ho più messaggio hanno le intestazioni non valide .....

    Girando per internet ho trovato un paio di comandi che possono forse risolvere il mio problema e volevo, se possibile, una vostra opinione, se basta fare un "brutale" copia e incolla come penso dato che nel comando ci sono delle variabili o devo adattarlo, se prima devo fare sp3 poi lanciarli perchè nell'sp1 non ci sono questi comandi o ....... qualsiasi altra cosa (sempre niubbo sono ancora nel campo exchange e probabilmente lo rimarrò per molto tempo :( ).

    I comandi sono:

    Set-ReceiveConnector -Identity ($Env:computername + "\Windows SBS Fax Sharepoint Receive " + $Env:computername) -DefaultDomain $Env:UserDNSDomain

    Set-ReceiveConnector -Identity ($Env:computername + “\Windows SBS Fax Sharepoint Receive ” + $Env:computername) -MaxProtocolErrors 500

    ( rif. http://sistarelli.com/category/posta-elettronica/ )

    Da quel che ho capito il primo dovrebbe riscrivere l'header in modo corretto e risolvere il problema mentre il secondo è un semplice workaround in quanto aumenta solo il numero di errori ma le mail non le scarica. E' corretto ???

    M.Cris

    P.s. ma il Sistarelli del blog mi sembra di averlo visto girare per questo forum o ho preso un abbaglio ??

    venerdì 4 novembre 2011 15:11
  • Hola M.Cris,
     
    esegui quello che ti dice il blog, come hai visto il primo comando serve
    nel caso la mail abbia un determinato header non configurato bene, mentre
    l'altro alza il livello dei possibili errori.
    I comandi usano variabili per non doverli ritoccare, quindi usali cosi.
     
    Saluti
     
     

    Mitch
    Microsoft Exchange MVP | MCSE | MCTS | MCITP | MCT
    http://blogs.dotnethell.it/mitch
    http://www.windowserver.it
    http://www.windowservers.es

    • Contrassegnato come risposta Anca Popa martedì 8 novembre 2011 14:08
    venerdì 4 novembre 2011 16:49
  • P.s. ma il Sistarelli del blog mi sembra di averlo visto girare per questo forum o ho preso un abbaglio ??

    Ciao M. Cris,

    Non abbiamo ricevuto delle notizie quindi per ora segno come corretto l'intervento di Michele. Ovviamente se ti servono ulteriori consigli per il tuo itinerario puoi ancora postare in questo spazio.

    Intanto per rispondere alla domanda quotata sopra ti lascio una lettura :-)

    I moderatori di TechNet: conoscili da vicino

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come inserire immagini nei post

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 8 novembre 2011 14:07
  • Ciao,

    sono riuscito a lanciare il comando (il primo, così com'è scritto) solo ieri che ero dal cliente, e mi ha risolto il problema delle mail non ricevute che hanno intestazioni non valide in quanto mi ha scaricato le mail giacenti sul server remoto comprese le notifiche di mancato recapito e di lettura e il connettore pop3 ha smesso di dare errore.

    Il secondo non lo ho lanciato (lo tengo di scorta, nel caso di ...).

    M.Cris

    venerdì 11 novembre 2011 09:37