none
Problemi configurazione Apache 2.4 Windows server 2016 RRS feed

  • Domanda

  • Salve, questo è il mio primo post nel forum.

    ho recentmente installato windows server sul Desktop di casa e volevo impostare un server accessibile all'esterno tramite dns dinamico e xampp.

    il dynamic update client (che riferirò come duc) è già impostato correttamente utilizzando l'ip fornito dal servizio che è 78.12.187.239

    passando a xampp, ho configurato apache per ascoltare l'indirizzo qui sopra indicato e quindi sono passato ad avviare il servizio sul pannello controllo di xampp, ma niente. quindi provo ad avviarlo da riga di comando usando il comando httpd ma ricevo il seguente errore:

    (OS 10049)Indirizzo richiesto non valido nel proprio contesto.  : AH00072: make_sock: could not bind to address 78.12.187.239:80
    AH00451: no listening sockets available, shutting down
    AH00015: Unable to open logs

    inoltre, provando a dare un'occhiata per verificare se il servizio di apache è attivo server manager mi dice che è stato arrestato, provo ad avviarlo ma anche qui dà errore dicendo che è impossibile avviare il servizio.

    come faccio a risolvere questo problema?

    sono un nuovo utente a riguardo del mondo windows server, inoltre se possibile vorrei evitare di usare altri software diversi da xampp dato che è il software che usiamo a scuola.

    In caso abbiate bisogno di qualche screenshot rappresentante il problema non esitate a mandarmi un messaggio.

    In ultimo, la configurazione del mio PC se può servire è:

    CPU: AMD Phenom 9500 Quad core 2.20GHz

    RAM: 4 GB DDR2

    MoBo: ASUS M4A78 Pro

    Scheda Video Zotac GT710 (Nvidia gt 710) 2GB ram dedicata

    HD 80GB Hitachi Sata

    Scheda di rete Realtek rtl 8139/810x

    Vi ringrazio in anticipo per la risposta, Spinoni31.

    mercoledì 17 ottobre 2018 14:56

Risposte

  • PS io una 80 su un ip pubblico che oltretutto hai pubblicato su un forum nazionale non la aprirei...a meno che tu non abbia un IPS\IDS a monte. Vedi tu...

    ;-) 

    potresti avere un ip dinamico comunque, sul residenziale non danno statici naked a meno che non paghi e solo su richiesta.

    ciao!

    A.


    giovedì 18 ottobre 2018 13:54
    Moderatore

Tutte le risposte

  • Mi sa che non hai fatto il port forwarding sul tuo router... Se si nattato (come è probabile) non devi usare l'ip pubblico...


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    mercoledì 17 ottobre 2018 20:08
    Moderatore
  • PS io una 80 su un ip pubblico che oltretutto hai pubblicato su un forum nazionale non la aprirei...a meno che tu non abbia un IPS\IDS a monte. Vedi tu...

    ;-) 

    potresti avere un ip dinamico comunque, sul residenziale non danno statici naked a meno che non paghi e solo su richiesta.

    ciao!

    A.


    giovedì 18 ottobre 2018 13:54
    Moderatore
  • qui non è un problema di natting sul tuo router, qui è un problema che il servizio stesso di pubblicazione web non rimane neppure avviato forse perchè hai qualcos'altro in ascolto sulla porta 80.

    dovresti lanciare il comando netstat -an e postare qui il risultato.

    ciao


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    e[dot]benussi[at]outlook[dot]it

    lunedì 22 ottobre 2018 09:07
    Moderatore
  • 78.12.187.239
    • dynamic-adsl-78-12-187-239.clienti.tiscali.it
    No open ports

    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere



    lunedì 22 ottobre 2018 18:45
    Moderatore
  • ci saranno pure le porte chiuse ma il servizio non rimane avviato quindi, secondo me, gli conviene prima capire perchè il servizio non rimane su, poi si preoccuperà di aprire le porte.

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    e[dot]benussi[at]outlook[dot]it

    martedì 23 ottobre 2018 07:25
    Moderatore
  • ci saranno pure le porte chiuse ma il servizio non rimane avviato quindi, secondo me, gli conviene prima capire perchè il servizio non rimane su, poi si preoccuperà di aprire le porte.

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    e[dot]benussi[at]outlook[dot]it

    Ho postato lo scan per vedere se nel frattempo aveva seguito il mio consiglio cioè togliere l'ip pubblico dal conf di apache, infatti, avevo detto in precedenza "Se sei nattato (come è probabile) non devi usare l'ip pubblico..."  ero stato buono con un "(come è probabile)"

    Se utilizzi un IP non nella tua sottoclasse nel conf di apache  NON PARTE con l'errore postato dal nostro OP:  (OS 10049)Indirizzo richiesto non valido nel proprio contesto.  : AH00072: make_sock: could not bind to address 78.12.187.239:80 

    RIPETO: HA MESSO L'IP PUBBLICO NELL'' HTTPD.CONF !!!!

    I passi per risolvere sono:

    1. Mettere nell'https.conf Listen 0.0.0.0:80 anzicchè Listen 78.12.187.239:80 (osiia far funzionare Apache come dice Edoardo)
    2. Abilitare il port forwarding della porta 80 sull'ip privato dove gira apache
    3. avere un sistema per la gestione dinamica dei nomi suo DUC (unica cosa fatta bene. forse...) in alternativa, avere un ip statico (fastweb lo fonisce gratutitamente anche sul residenziale)

    Caio Gastone


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere


    martedì 23 ottobre 2018 11:41
    Moderatore