none
.Net Framewok 1.1 su Windows Server 2012 R2 RRS feed

  • Domanda

  • Ciao a tutti, premettendo che non sono un esperto di queste cose più "tecniche", ho letto che il framework 1.1 non è supportato su Windows server 2012 R2. E' possibile installarlo comunque? Se si cosa comporta la cosa?  Fa cadere la licenza?

    Grazie

    S.

    mercoledì 17 maggio 2017 09:08

Risposte

  • devo correggere la risposta sia perchè l'op parla esplicitamente della versione 1.1 del framework e non della 2.0 ma soprattutto perchè le versioni del framework possono tutte coesistere sulla stessa macchina ma non sono aggiornamenti di versioni precedenti. questo significa che una versione successiva può avere più classi di oggetti della precedente versione ma non è necessariamente una sua estensione quindi potrebbero essere definiti proprietà e/o metodi degli oggetti in maniera diversa rispetto alla versione precedente. quando poi si sviluppa del codice, si fa riferimento stretto alla versione del framework adottata sin dall'inizio. se si vuole cambiare versione è necessario fare una migrazione (che Visual Studio fa quasi automaticamente) e ricontrollare tutto il codice per verificare la presenza di errori causati proprio dalla non totale retrocompatibilità delle versioni del fw.

    per questo motivo, per testare la versione 1.1 del framework bisogna installare in macchina virtuale un s.o. che supporti quella versione.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org


    lunedì 29 maggio 2017 14:42
    Moderatore

Tutte le risposte

  • Ciao, dai una lettura alla seguente documentazione https://msdn.microsoft.com/en-us/library/hh925570(v=vs.110).aspx

    Saluti
    Nino

    mercoledì 17 maggio 2017 10:53
    Moderatore
  • Ciao Nino, grazie per la risposta. Quel doc l'avevo già letto e speravo di trovare qualcosa che parlasse anche della licenza. Perchè il mio sistemista dice che l'installazione fa cadere la licenza ma cercando in giro non ho trovato nulla in questo senso.

    S.


    mercoledì 17 maggio 2017 12:04
  • Probabilmente intendeva dire che non è una soluzione supportata. Infatti se apri un ticket ed il supporto riscontra una configurazione non supportata semplicemente lo chiude. In questo caso non vai a compromettere la licenza.

    Quello che ti posso consigliare è di attivare una VM con una versione di valutazione e di installare Framework 3.5 che include la versione 2.0. Una volta completata l'installazione potete eseguire tutti i test del caso.

    Saluti
    Nino

    mercoledì 17 maggio 2017 12:16
    Moderatore
  • Grazie Nino.

    S.

    mercoledì 17 maggio 2017 12:31
  • devo correggere la risposta sia perchè l'op parla esplicitamente della versione 1.1 del framework e non della 2.0 ma soprattutto perchè le versioni del framework possono tutte coesistere sulla stessa macchina ma non sono aggiornamenti di versioni precedenti. questo significa che una versione successiva può avere più classi di oggetti della precedente versione ma non è necessariamente una sua estensione quindi potrebbero essere definiti proprietà e/o metodi degli oggetti in maniera diversa rispetto alla versione precedente. quando poi si sviluppa del codice, si fa riferimento stretto alla versione del framework adottata sin dall'inizio. se si vuole cambiare versione è necessario fare una migrazione (che Visual Studio fa quasi automaticamente) e ricontrollare tutto il codice per verificare la presenza di errori causati proprio dalla non totale retrocompatibilità delle versioni del fw.

    per questo motivo, per testare la versione 1.1 del framework bisogna installare in macchina virtuale un s.o. che supporti quella versione.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org


    lunedì 29 maggio 2017 14:42
    Moderatore