none
[Exchange 2010]: servizio Transport non trova certificato RRS feed

  • Domanda

  • Ciao a tutti.

    Ieri ho terminato con successo una migrazione SBS2003-->SBS2011. Stamane i client Outlook non riescono a connettersi, col messaggio "Impossibile aprire le cartelle di Outlook".

    Controllando nell'Event Viewer di SBS2011, ho notato parecchi errori ed avvisi relativi a vari componenti di Exchange 2010. In particolare ho visto questo:

    ID Evento: 12014
    Origine: MSExchangeTransport
    Descrizione: Impossibile trovare un certificato che contenga il nome di dominio mail.miodominio.com nell'archivio personale nel computer locale. Pertanto, il verbo SMTP STARTTLS non è disponibile per il connettore Default SBS2011 con il parametro di un nome di dominio completo di mail.miodominio.com. Se non è specificato il FQDN del connettore verrà usato il FQDN del computer. Verificare la configurazione dei connettori e i certificati installati per assicurarsi che sia presente un certificato con un nome di dominio per tutti i nomi di dominio completi dei connettori. Se il certificato esiste, eseguire Enable-ExchangeCertificate -Services SMTP per accertarsi che il servizio di trasporto di Microsoft Exchange abbia accesso alla chiave di certificato.

    Ora, la situazione è questa: il server in questione è MX per "miodominio.com", ma non ho mai (su SBS2003) avuto problemi legati a certificati. Può il messaggio di cui sopra essere motivo per cui Outlook non si connette ad Exchange?

    Altro messaggio nel registro eventi:

    Origine:       MSExchange ActiveSync
    ID evento:     1033
    Descrizione: Impostazione ExternalProxy nel file Web.Config non valida. Il valore precedente NULL è stato impostato su .

    Cosa indica questo qui sopra?

    Infine, guardando nell'elenco dei servizi, ho notato che ci sono alcuni servizi che dovrebbero avviarsi in automatico, ma che non l'hanno fatto. Eccoli:

    Microsoft Exchange EdgeSync
    Microsoft Exchange IMAP4
    Microsoft Exchange POP3
    Servizio di accesso client RPC di Microsoft Exchange
    Servizio di autenticazione basata su moduli di Microsoft Exchange

    Ah, altro evento "strano":

    Origine: MSExchangeServiceHost
    ID Evento: 2011
    Descrizione: Si è verificato un errore sconosciuto. Non sono stati caricati moduli e il servizio non eseguirà alcuna operazione. Informazioni di diagnostica:

    Microsoft.Exchange.Data.Directory.NoSuitableServerFoundException: Il servizio di topologia di Microsoft Exchange Active Directory sul server localhost non ha restituito alcun controller di dominio idoneo.

    [ho tagliato un elenco lunghissimo di dati qui sotto, se serve lo posto]

    Dopo che ho avviato i due servizi

    Servizio di accesso client RPC di Microsoft Exchange
    Servizio di autenticazione basata su moduli di Microsoft Exchange

    il tutto ha ripreso a funzionare.

    Come risolvo la situazione (poichè ad un eventuale riavvio, il tutto mi si ripresenterebbe)?

    Grazie!

    F.


    FlavioB
    venerdì 1 luglio 2011 07:24

Risposte

  • Ciao Flavio,

    Di seguito provo a lasciarti qualche dritta per il troubleshooting, pur non avendo ancora una soluzione definitiva al tuo scenario.

    Per l’evento 1033, ho trovato questa risposta:

    “Consulted our activesync team here and received the following feedback:

    If this is not a partner-hosted environment, you can safely ignore this error.
    It is simply a warning that the ExternalProxy setting is not set in the web.config.
    We use a default value of null when we find this.

    If you are not partner hosted and want to get rid of the warning, add a key under the <appSettings> key in your \Program Files\Microsoft\Exchange Server\V14\ClientAccess\Sync\web.config file:

    <add key="ExternalProxy" value=""></add>
    

    The warning should have only been appearing when the application pool was recycled and just spinning up. You will need to either recylce the MSExchangeSyncAppPool or do an iisreset and then check your application log. You should no longer see the event.”

    Fonte: The setting ExternalProxy in the Web.Config file was not valid

    Segui anche questo post.

    Per l’evento 12014, ti giro i blog post di alcuni MVP:

    How to fix MSExchangeTransport Event ID 12014 on Edge and Hub Transport servers

    Troubleshooting Event ID 12014 in Exchange 2007/2010

    Per gli altri comportamenti riportati: hai anche provato a eseguire il Best Practices Analyzer?

    Forse non è molto però almeno hai un minimo spunto :-)


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    • Contrassegnato come risposta Anca Popa giovedì 7 luglio 2011 09:44
    lunedì 4 luglio 2011 13:18