locked
File in uso. Aprire in sola lettura. RRS feed

  • Domanda

  • Salve a tutti,

    ho un notebook Sony Vaio PCG-81212M con Windows 7 Professional 64 bit e Office 2010 che quando apre documenti condivisi su di un File Server compare l'errore:

    File in uso.
    nomedelfile è utilizzato al momento da nomeutente

    Aprire in 'Sola lettura' o fare clic sul pulsante 'Notifica' per aprire in sola lettura e ricevere un messaggio di avviso quando il file originale sarà disponibile.

    il problema è che il file non è aperto da nessuno, infatti se chiudo e riapro lo stesso file riesco ad aprirlo in modifica, cosa può essere?

    Altri accedono allo stesso server ma nessuno ha lo stesso problema.

    Il server è un server linux con servizio Samba per la condivisione.


    Grazie e buona giornata -- Thomas --

    mercoledì 4 aprile 2012 10:39

Risposte

Tutte le risposte

  • Ciao, ultimamente la discutiamo abbastanza spesso. E' un problema dovuto all'anteprima dei files che crea dei thumbs.db e li blocca.

    Qui ti allego come risolvere il problema. Vedi se fa al caso tuo.

    http://serverfault.com/questions/364262/deleting-blocked-caused-by-thumb-db-on-windows-2008-as-a-file-server

    Ciao A.

    • Contrassegnato come risposta Thomas_TT martedì 22 maggio 2012 08:59
    mercoledì 4 aprile 2012 13:42
    Moderatore
  • Su che tipo di file si verifica il problema?

    Se sono documenti di office controlla qui

    Ciao Gas


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!

    mercoledì 4 aprile 2012 20:03
    Moderatore
  • Ciao a tutti,

    il problema si presenta su file di excel,

    entro la prossima settimana dovrei riuscire a testarne la soluzione, poi vi faccio sapere, nel frattempo vi ringrazio.


    Grazie e buona giornata -- Thomas --

    giovedì 5 aprile 2012 09:33
  • l problema si presenta su file di excel

    Infatti, la mia domanda era stata fatta perchè sospettavo la cosa...

    http://blogs.technet.com/b/the_microsoft_excel_support_team_blog/archive/2011/05/02/file-is-locked-for-editing-by-another-user.aspx
     Questo particolare problema si manifesta quando tenta  di accedere ad un file excel presente in una condivisione di rete. All'apertura del file, viene visualizzato un errore "File in uso da un altro utente...aprire in sola lettura". Excel visualizza "un altro utente", invece del nome di un utente reale, quando non riesce ad individuare chi ha bloccato il workbook. Il problema accade tipicamente su sistemi vista/window7 che accedono ai file in una risorsa di rete condivisa da un windows 7 o windows 2008...

    linux+samba e Opportunistic Locking 
    Nel precedentemente link  riportato, avrai trovato sei possibili soluzioni le prime cinque, riguardano operazioni da effettuare sul client, la sesta riguarda l'"Opportunistic Locking" del  server windows in cui risiedono i files, ma nel tuo caso trattandosi di un server linux, ovviamente non è applicabile così come presentata....
    Comunque è possibile modificare il comportamento di samba riguardo il locking; per fare ciò, dovresti verificare nel tuo /etc/samba/smb.conf come l'"Opportunistic Locking" sia stato settato...
    http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/locking.html#id2616998
    http://oreilly.com/openbook/samba/book/ch05_05.html

    Ciao


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!


    giovedì 5 aprile 2012 10:26
    Moderatore
  • OTTIMOOOOOOO,

    grazie ancora, allora provo anche questo e vi faccio sapere =).


    Grazie e buona giornata -- Thomas --

    giovedì 5 aprile 2012 10:51
  • Salve a tutti,

    volevo comunicarvi che ho semplicemente rimosso l'anteprima dalla visualizzazione dell'esplora risorse e tutto è tornato a funzionare, mi è successa la stessa identica cosa in una rete con un server sbs 2003, stesso errore stessa risoluzione, rimossa l'anteprima dall'esplora risorse e tutto è tornato a funzionare, per me non era una cosa necessaria, quindi ho risolto rimuovendola.

    Grazie a tutti per il supporto


    Grazie e buona giornata -- Thomas --

    martedì 22 maggio 2012 08:58
  • Ciao Thomas,

    Grazie di essere tornato sul forum per riferire la soluzione.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    La Conferenza Italiana sulla Virtualizzazione

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    martedì 22 maggio 2012 12:53