none
DNS RRS feed

  • Discussione generale

  • Ciao a tutti, ho una rete strutturata come segue

    Firewall (linux) con interfaccia WAN verso internet e interfaccia LAN 192.168.0.200 (DHCP attivo) con wins verso 192.168.0.201 e dns 192.168.0.201 e gtw 192.168.0.200

    Server win 2008 AD DC 192.168.0.201 (con dns interno) e wins attivo

    server win 2008 in DC 192.168.202 (no dns server)

    server win 2012 in DC 192.168.203 (con Echange 2013) no dns server)

    ho il dubbio che ho il dns pasticciato

    come posso capire se funziona tutto regolare? c'e' possibilita ' di fare un reset del dns?

    seconda domanda :il dhcp in questo tipo di configurazione ha senso che sia sul server dns o va bene anche cosi'?

    forse sono stato poco chiaro al limite chiedete altre info

    Grazie



    martedì 27 febbraio 2018 15:24

Tutte le risposte

  • Ciao

    Leggi qui

    https://docs.microsoft.com/en-us/powershell/module/dnsserver/test-dnsserver?view=win10-ps

    Marco

    P.s. Anche questo post (qui si usano piu dc)

    https://social.technet.microsoft.com/Forums/it-IT/407e2a7c-82c9-4c12-b48c-e79b7664a9a5/configurazione-dns-della-scheda-di-rete-su-dc?forum=windowsserverit

    mercoledì 28 febbraio 2018 08:13
  • ciao Marco grazie della risposta

    nel primo caso non posso fare il test, non mi prende il comando, io uno win server 2008 e client win 7

    forse e' per quello? li mi pare siano comandi di win 10

    mercoledì 28 febbraio 2018 08:30
  • Sostanzialmente hai 3 server di cui 1 solo è DNS. Non capisco il tuoi dubbi. Hai errori sull'eventviewer a livello DNS? da dove nasce la preoccupazione? Personalmente dove c'è un Domain Controller è lui che mi fa DHCP ma non è obbligatorio.

    Se il DNS ha un server di inoltro esterno magari e nessuna segnalazione nel registro eventi ed i client lo ricevono corretto non vedo grandi problematiche..quindi la tua domanda nasce da un problema.

    quale?

    ciao.

    A.

    mercoledì 28 febbraio 2018 17:17
  • il problema nasce che ho spesso rallentamenti, ho un wifi sulla rete impostato come AP , acquisisce l'ip al dhcp e se faccio un ping -t sia sul serve che su internet ha una peerdita pacchetti esagerata praticamente non e' utilizzabile, succede anche con cavo ma molto meno e quindi gli utenti se ne acorgono poco

    poi se faccio un nsllookup dai server verso ad esempio www.goole.com la risposta e' immedita se lo faccio dal client mi va in time out e non da esito, e' normale?? io penso di no in effetti  a me pare lenta la cosa

    tu consigli di usare il dhcp di windows? oppure domanda migliore, il dns va importato in quealche modo per dirgli che il server dhcp e' un'altro ?

    mercoledì 28 febbraio 2018 22:56
  • guarda che la perdita di pacchetti non c'entra niente col DNS...li è un problema di networking bello e buono....per averne riscontro invece di pingare i nomi, se pinghi gli ip il risultato è diverso? In caso sia diverso...allora vediamo..se è lo stesso...non è il dns. Io uso sempre il DC come dhcp, ma una volta che l'indirizzo te l'ha dato se risolve male o perde pacchetti non è più un problema di dhcp..

    fai un po di test in questo senso..

    giovedì 1 marzo 2018 06:16
  • Ciao

    Hai un wifi impostato come access point intendi:

    Un router Wi-Fi dove hai disattivato il dhcp è abilitato il wifi?

    Un access point puro ?

    ...........

    Come ha detto Alessandro il dns non c'entra nulla ma a questo punto ti chiedo se il problema ti si presenta solo con il wifi?

    Hai dei switch manage?

    Vlan?

    Marco

    giovedì 1 marzo 2018 07:07
  • si diciamo che con il wifi e' davvero eccessivo

    si e' un router che ha l'impostazione AP, disabilitato il DHCP

    dici che non centra nulla? io forse ho il dns un po' pasticciato ma se mi dite cosi' ci credo ma come posso fare a capire cosa e'?

    si ho degli switch manage ma sulla LAN non ci sono VLAN attive

    c'e' la possibilita di fare un rest del DNS? cosi' da impostarlo di base e parto da li?

    seconda cosa io ho attivato la replica dei server e pare funzioni

    posso chiderti questa cosa :

    se vado du DC e faccio un nslookup su www.google.com funziona correttamente

    se lo faccio da un client mi da time out e scade la richiesta, eppure il pc naviga, e' normale?

    giovedì 1 marzo 2018 08:50
  • Capisco che insisti sul dns ma secondo me devi mettere in ordine il networking. 

    Curiosità

    Mi fai un ipconfig /all sul client e posti.

    Mi fai un nslookup sul server e posti.

    Marco 


    giovedì 1 marzo 2018 09:32
  • si vero mi sono fissato con il dns, se non lo e' preferisco :)

    ecco i due dati che mi hai chiesto

    “nslookup dal DC AD e DNS”

    C:\user\administrator.dominio\nslookup

    Server predefinito:    UnKnown

    Address: 192.168.2.247

    >

    ---------------------------------------

    “ipconfigng dal client”

    Configurazione IP di Windows

       Nome host . . . . . . . . . . . . . . : B737

       Suffisso DNS primario . . . . . . . . : SEDE.local

       Tipo nodo . . . . . . . . . . . . . . : Ibrido

       Routing IP abilitato. . . . . . . . . : No

       Proxy WINS abilitato . . . . . . . .  : No

       Elenco di ricerca suffissi DNS. . . . : SEDE.local

                                               sede

    Scheda LAN wireless Connessione rete wireless 3:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso

       Suffisso DNS specifico per connessione:

       Descrizione . . . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter

       Indirizzo fisico. . . . . . . . . . . : 8C-70-5A-69-7A-C9

       DHCP abilitato. . . . . . . . . . . . : S

       Configurazione automatica abilitata   : S

    Scheda Ethernet Connessione alla rete locale (LAN) 2:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso

       Suffisso DNS specifico per connessione:

       Descrizione . . . . . . . . . . . . . : TAP-Windows Adapter V9

       Indirizzo fisico. . . . . . . . . . . : 00-FF-97-16-EB-7A

       DHCP abilitato. . . . . . . . . . . . : S

       Configurazione automatica abilitata   : S

    Scheda LAN wireless Connessione rete wireless 2:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso

       Suffisso DNS specifico per connessione:

       Descrizione . . . . . . . . . . . . . : Intel(R) Centrino(R) Advanced-N 6205 #2

       Indirizzo fisico. . . . . . . . . . . : 8C-70-5A-69-7A-C8

       DHCP abilitato. . . . . . . . . . . . : S

       Configurazione automatica abilitata   : S

    Scheda Ethernet Connessione alla rete locale (LAN):

       Suffisso DNS specifico per connessione: sede

       Descrizione . . . . . . . . . . . . . : Intel(R) 82579LM Gigabit Network Connection

       Indirizzo fisico. . . . . . . . . . . : E4-11-5B-5A-E1-7A

       DHCP abilitato. . . . . . . . . . . . : S

       Configurazione automatica abilitata   : S

       Indirizzo IPv6 locale rispetto al collegamento . : fe80::1001:7cbf:544a:27d0%11(Preferenziale)

       Indirizzo IPv4. . . . . . . . . . . . : 192.168.2.38(Preferenziale)

       Subnet mask . . . . . . . . . . . . . : 255.255.255.0

       Lease ottenuto. . . . . . . . . . . . : gioved 1 marzo 2018 09:30:42

       Scadenza lease . . . . . . . . . . .  : gioved 1 marzo 2018 12:30:42

       Gateway predefinito . . . . . . . . . : 192.168.2.252

       Server DHCP . . . . . . . . . . . . . : 192.168.2.252

       IAID DHCPv6 . . . . . . . . . . . : 249827675

       DUID Client DHCPv6. . . . . . . . : 00-01-00-01-1E-5D-FE-E1-E4-11-5B-5A-E1-7A

       Server DNS . . . . . . . . . . . . .  : fe80::1%11

                                               192.168.2.247

       Server WINS primario . . . . . . . .  : 192.168.2.247

       NetBIOS su TCP/IP . . . . . . . . . . : Attivato

    Scheda Tunnel isatap.sede:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso

       Suffisso DNS specifico per connessione: sede

       Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter

       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP abilitato. . . . . . . . . . . . : No

       Configurazione automatica abilitata   : S

    Scheda Tunnel isatap.{2697CFA7-40BC-451E-AD90-7E55026ABB21}:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso

       Suffisso DNS specifico per connessione:

       Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter #2

       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP abilitato. . . . . . . . . . . . : No

       Configurazione automatica abilitata   : S

    Scheda Tunnel isatap.{9716EB7A-84DC-4DA4-84E4-9E077A173E1E}:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso

       Suffisso DNS specifico per connessione:

       Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter #3

       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP abilitato. . . . . . . . . . . . : No

       Configurazione automatica abilitata   : S

    Scheda Tunnel Teredo Tunneling Pseudo-Interface:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso

       Suffisso DNS specifico per connessione:

       Descrizione . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP abilitato. . . . . . . . . . . . : No

       Configurazione automatica abilitata   : S

    Scheda Tunnel isatap.{68EFC4E0-BF7D-4BE7-B414-4382BA18265E}:

       Stato supporto. . . . . . . . . . . . : Supporto disconnesso

       Suffisso DNS specifico per connessione:

       Descrizione . . . . . . . . . . . . . : Microsoft ISATAP Adapter #4

       Indirizzo fisico. . . . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP abilitato. . . . . . . . . . . . : No

       Configurazione automatica abilitata   : S

    giovedì 1 marzo 2018 09:50
  • Ciao,

    per quanto riguarda il server Unknow devi rivedere i PTR nel server DNS ma a questo punto mi chiedo da quanto tempo hai questo problema.

    Come ti ha detto Alessandro questo non risolve i problemi dei pacchetti persi.

    Metti un ip statico su un client senza dns e senza gtw

    Poi fai un ping -t sul firewall e vedi cosa accade

    Marco

    giovedì 1 marzo 2018 10:41
  • questo problema della perdina del Wifi mi succede da qualche mese, pensavo fosse l'apparato orma andato visto che era molto vecchio e ne ho acquistato uno nuovo , ma il problema rmane quindi presumo sia successo appunto qualcosa

    ora ti faccio il ping e te lo posto

    giovedì 1 marzo 2018 10:49
  • ho fatto questa prova con cavo, ha perso solo una volta e l'ho fatta con il WIFI il risultato e' questo

    Esecuzione di Ping 192.168.2.252 con 32 byte di dati:
    Risposta da 192.168.2.252: byte=32 durata=190ms TTL=64
    Risposta da 192.168.2.252: byte=32 durata=77ms TTL=64
    Risposta da 192.168.2.252: byte=32 durata=1ms TTL=64
    Richiesta scaduta.
    Richiesta scaduta.
    Risposta da 192.168.2.252: byte=32 durata=1ms TTL=64
    Risposta da 192.168.2.252: byte=32 durata=1ms TTL=64
    Richiesta scaduta.
    Risposta da 192.168.2.252: byte=32 durata=1ms TTL=64
    Richiesta scaduta.
    Risposta da 192.168.2.252: byte=32 durata=1ms TTL=64
    Richiesta scaduta.
    Richiesta scaduta.
    Risposta da 192.168.2.252: byte=32 durata=1ms TTL=64
    Richiesta scaduta.
    Risposta da 192.168.2.252: byte=32 durata=1ms TTL=64
    Richiesta scaduta.

    Statistiche Ping per 192.168.2.252:
        Pacchetti: Trasmessi = 17, Ricevuti = 9, 
        Persi = 8 (47% persi),
    Tempo approssimativo percorsi andata/ritorno in millisecondi:
        Minimo = 1ms, Massimo =  190ms, Medio =  30ms
    Control-C

    giovedì 1 marzo 2018 12:02
  • Il wifi non sta andando come deve. Parere mio l'access point od il cavo di rete (meno probabile) o la porta di rete a cui è attaccato sullo switch ha dei problemi ( anche quella a muro..non so come è fatto).

    Un pacchetto sulla lan ci sta, qui il problema è palese invece. Il DNS non ha niente a che fare in questo. Hai un problema fisico non software.

    Cambia porta sullo switch per iniziare e riprova e poi scali coi test.

    ciao.

    A.

    giovedì 1 marzo 2018 12:49
  • Risolvi prima i problemi del wifi andando per esclusione come ti hanno consigliato,

    il resto lo risolvi poi.

    Marco

    giovedì 1 marzo 2018 13:18
  • e ma il punto e' questo non ho idea di cosa abbia, non da errori da nessuna parte ho fatto come detto escludento gtw e dns ma il problema rimane

    giovedì 1 marzo 2018 13:51
  • cavi, porte ecc ecc cambiati in primis, addirittura pernsavo ad un problema hardware me lo sono pure fatto sostituire

    consiglio

    conviene configuararlo sulla stessa lan°? l'AP ha un ip statico sulal stessa sub della lan, ovviamente DHC disabilitato quindi tutte le info le prende da DHCP

    la cosa assurda e' che e' sempre andato non so cosa sia successo , per quello ho pensato ad un pasticcio sul dns o cose del genere, ma dalla prova che mi avete fatto fre e' eviente che non lo e'

    esistono dei test che posso fare ? almeno per individurare il problema

    giovedì 1 marzo 2018 13:56
  • L'indirizzo ip sull'access point non serve a niente se non per il management eventuale, può essere anche su classe totalmente diversa a meno che non gli fai fare da dhcp allora ti serve sulla stessa classe. 

    E' abbastanza evidente che il problema ce l'hai quando sei attaccato al wireless quindi la prova da fare è: cambiare il wireless. 

    Se a cavo non perdi pacchetti non ci sono altre possibilità. Io spegnerei quell'AP, mi prenderei un TPlink da 30€ e proverei con quello a vedere cosa succede attancandolo direttamente sullo switch. Se escludendo apparato e rete il problema rimane siamo nella fantascienza informatica. Ma così secondo me i dati poi li hai per mettere in campo una soluzione. Userei anche un analizzatore wifi da cellulare per vedere se c'è sovrapposizione di segnali che in realtà non ci sia uno stacca\attacca del wifi.

    Però qui siamo molto OT...qui risolviamo problemi sui sistemi operativi MS..non facciamo debug networking avanzato.

    ciao.

    A.

    giovedì 1 marzo 2018 14:04
  • ma ho gia' fatto qeusta prova questo e' il terzo AP

    il primo l'ho cambiato per sto motivo perche' pensavo fosse ormai andato il secondo pensavo fosse guasto, questo e' il terzo

    pero' vorrei andare pure io per gradi

    vorrei sistemare quella consa del PTR

    cosa devo fare? creare un puntamento inverso? di ogni server? mi dai delle info? non me ne intendo di questo

    giovedì 1 marzo 2018 14:51
  • Ma cosa c’entra il PTR col fatto che perdi i ping?!?! Miami, questo è networking, non possiamo “buttare su” cose senza senso che non hanno niente a che fare col tuo problema. Io dubito che se tu ti attacchi con un AP direttamente sullo switch principale e gli agganci un client staccando tutti gli altri AP tu abbia lo stesso problema. In quel caso allora o è lo switch oppure c’è qualcosa che ti fa interferenza ma dovresti avere delle disconnessioni. Non so su quanti client tu abbia il problema, ma devi provare ad isolare l’anomalia. Che ne so ti fai una rete ad hoc, una subnet diversa e vedi come si comporta. Però devi capire che non possiamo farti il debug di tutta la rete su un forum oltretutto questo è un forum Microsoft, non “tuttologia delle reti”...li o ce la fai tu oppure ti appoggi a qualcuno esterno che ha quel tipo di esperienza..siamo partiti da un problema DNS, per capire che era un problema in realtà fisico ed ora stiamo al PTR. Sono passati 2gg e siamo ancora al punto di partenza. Direi che ci fermiamo qui. Mi spiace, ma non faccio io le regole. Sposto in OT, poi se Qualche collega vuole continuare la discussione è il benvenuto. Ciao. A.
    giovedì 1 marzo 2018 17:29
  • grazie mille, il discorso DNS lo dicevo io ero convinto fosse qello il problema

    cerco di fare dei test ma gli switch ostituiti sabato cavi di rete

    interfereze? possibile ma non si disconnette perde solo pacchetti di bruto a tal punto da non poterlo usare

    grazie mille a tutti per i consigli

    giovedì 1 marzo 2018 20:24
  • Ciao a tutti volevo condividere con voi la quasi risoluzione del problema, e visto che riguarda argomenti microsoft ne volevo parlare

    allora il problema nslookup che dava server non riconosciuto l'ho risolto con due passaggi

    1) andava creata una zona inversa del server dns che e' anche AD, fatto questo il serve e' stato riconoscuto

    2) ho dovuto sul client disabilitare IP6

    poi ho abilitato il DHCP in modo che registri anche host non del AD , tipo stampanti di rete ecc ecc

    Disabilitandolo anche sulla scheda Wifi del pc l'IP6 pare che adesso funzioni bene senza interruzioni

    a tal proposito volevo fare una domanda a proposito di IP6, ma devo necessariamente disabilitarlo su tutti i client? piu' di 60..... :(:(:( opprue c'e' un modo per farlo coesistere con IP4 senza creare problemi? magari va solo configurarato? preciso che sulla macchina AD e' disabilitato

    grazie a tutti

    martedì 6 marzo 2018 15:08