locked
Attivazione in automatico di InPrivate Filtering all'avvio di Internet explorer RRS feed

  • Domanda

  • Tempo fa in un forum ho trovato un articolo in cui suggerivano di modificare la chiave di registro HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Safety\PrivacIE impostando il valore StarMode ad 1, in modo tale che all'avvio di IE il filtro si attivasse in automatico. Avevo eseguito la modifica con effettivi pessimi poichè andava in crash IE. Adesso però, dopo i suggerimenti avuti in un discussione relativa ad  InPrivate Filtering nel NG, in cui mi  avete spiegato che Spybot e Spywareblaster (che utilizzavo all'epoca in cui avevo provato la modifica del valore di registro) non sono compatibili con IE8, mi viene da pensare che la causa potessero essere i predetti softwar. Pertanto (per non ricadere nell'errore) chiedo il vostro parere in merito alla modifica della chiave di registro in questione, poichè ritengo sia comodo che il filtro si attivi in automatico.
    Grazie  

    lunedì 28 dicembre 2009 16:44

Risposte

Tutte le risposte

  • Certo, riprova:
    Enable InPrivate Filtering by Default for All Internet Explorer 8 Sessions

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    lunedì 28 dicembre 2009 17:40
    Moderatore
  • Certo, riprova:
    Enable InPrivate Filtering by Default for All Internet Explorer 8 Sessions

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo

    Grazie.
    lunedì 28 dicembre 2009 17:57
  • Grazie.
    Prego.
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    lunedì 28 dicembre 2009 18:36
    Moderatore
  • Poco fa ho ho modificato la chiave in questione creando la stringa "StartMode" ed impostandola ad "1", riavviato il pc. All'avvio di IE l'icona in basso a destra di InPrivate Filtering risulta attiva ma se espando la finestra a tendina, risulta la spunta su "disattiva", andando nelle impostazione non risulta spuntata nessuna delle tre opzioni: "blocca automaticamente" - "scegli contenuto da bloccare o consentire" - "disattiva". Pertanto non viene filtrato nulla. Se spunto manualmente su "blocca automaticamente" mantiene l'impostazione salvo che chiudendo e riaprendo IE si ripresenta lo stesso problema, in sostanza anche se l'icona risulta attiva per rendere operativo il filtro devo agire sempre manualmente. 
    Cos'è che mi sfugge? 
    Grazie
    martedì 29 dicembre 2009 16:31
  • Poco fa ho ho modificato la chiave in questione creando la stringa "StartMode" ed impostandola ad "1", riavviato il pc. All'avvio di IE l'icona in basso a destra di InPrivate Filtering risulta attiva ma se espando la finestra a tendina, risulta la spunta su "disattiva", andando nelle impostazione non risulta spuntata nessuna delle tre opzioni: "blocca automaticamente" - "scegli contenuto da bloccare o consentire" - "disattiva".
    [...]
    Quando hai eseguito la modifica al Registro di sistema era attivo il tuo antivirus? O programmi antispyware?
    Prova a chiudere Internet Explorer, disattiva l'antivirus ed ogni altra applicazione di sicurezza, quindi modifica il Registro, verifica che chiave e valore siano OK e lancia Internet Explorer.


    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    martedì 29 dicembre 2009 16:51
    Moderatore
  • Poco fa ho ho modificato la chiave in questione creando la stringa "StartMode" ed impostandola ad "1", riavviato il pc. All'avvio di IE l'icona in basso a destra di InPrivate Filtering risulta attiva ma se espando la finestra a tendina, risulta la spunta su "disattiva", andando nelle impostazione non risulta spuntata nessuna delle tre opzioni: "blocca automaticamente" - "scegli contenuto da bloccare o consentire" - "disattiva".
    [...]
    Quando hai eseguito la modifica al Registro di sistema era attivo il tuo antivirus? O programmi antispyware?
    Prova a chiudere Internet Explorer, disattiva l'antivirus ed ogni altra applicazione di sicurezza, quindi modifica il Registro, verifica che chiave e valore siano OK e lancia Internet Explorer.


    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo

    Eliminato valore stringa "StartMode", riavviato pc. Disattivato Suite di sicurezza McAfee, ricreato valore stringa. riavviato pc, riattivato programma sicurezza. lanciato IE, stesso problema di prima.

    martedì 29 dicembre 2009 17:20
  • Eliminato valore stringa "StartMode", riavviato pc. Disattivato Suite di sicurezza McAfee, ricreato valore stringa. riavviato pc, riattivato programma sicurezza. lanciato IE, stesso problema di prima.
    http://support.microsoft.com/kb/923737/it
    "Utilizzo della funzionalità Reimposta Internet Explorer".
    Reimposta IE8.
    Potrebbe non essere sufficiente ma è un tentativo. 

    Possibile causa del problema potrebbe essere la suite McAfee che purtroppo non è sufficiente disattivare ma andrebbe rimossa.

    Prova ad applicare la .reg fix prelevandola dal sito di Ramesh:
    Enable InPrivate Filtering by Default for All Internet Explorer 8 Sessions
    - Download inpriv-filt-enable.zip, unzip and run the file inpriv-filt-enable.reg
    Ricorda di disattivare temporaneamente l'antivirus prima di lanciare il file .reg.


    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    martedì 29 dicembre 2009 17:41
    Moderatore
  • http://support.microsoft.com/kb/923737/it
    "Utilizzo della funzionalità Reimposta Internet Explorer".
    Reimposta IE8.
    Potrebbe non essere sufficiente ma è un tentativo. 

    Possibile causa del problema potrebbe essere la suite McAfee che purtroppo non è sufficiente disattivare ma andrebbe rimossa.

    Prova ad applicare la .reg fix prelevandola dal sito di Ramesh:
    Enable InPrivate Filtering by Default for All Internet Explorer 8 Sessions
    - Download inpriv-filt-enable.zip, unzip and run the file inpriv-filt-enable.reg
    Ricorda di disattivare temporaneamente l'antivirus prima di lanciare il file .reg.


    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    Reimpostato Internet Explorer. Disattivato McAfee, scompattato il file zip inpriv-filt-enable. zip, lanciato il file "inpriv.filt-enable.reg", riavviato, riattivato McAfee, avviato Internet Explorer, l'icona del filtro è attiva la modalità nella finestra a tendina risulta su "blocca automaticamente", per accedere alle impostazioni però, ha visualizzato la finestra iniziale di quando si attiva per la prima volta InPrivate Filtering dove scegliere la modalità del blocco, ho cliccato su "blocca automaticamente". Conclusione, si avvia in automatico con la configurazione apparenemente corretta, ma di fatto non blocca nulla.
    Nel registro di sistema ovviamente figura il valore di stringa "StartMode", tipo "reg_dword" valore "1", uguale a quando l'avevo modificato io, tranne che a me come "tipo" indicava reg_sz (non so se può avere importanza, non conosco la differenza e non ho fatto ricerche nel web per documentarmi...).
    I valori presenti nella sottocartella PrivacIE, oltre ovviamene a StartMode, sono: LastMode impostato a 1; ShowFirstRun impostato a 0; Threshold impostato ad "a10" ed in fine un "predefinito" non impostato.

    Mi viene un dubbio, all'interno della cartella zippata oltre al file "inpriv.filt-enable.reg" c'era il file "undo.reg" che io non ho utilizzato, dovevo? (scusami ma la mia conoscenza in informatica è terra-terra) 

    mercoledì 30 dicembre 2009 11:19
  • [...]
    Conclusione, si avvia in automatico con la configurazione apparenemente corretta, ma di fatto non blocca nulla.
    [...]
    Mi viene un dubbio, all'interno della cartella zippata oltre al file "inpriv.filt-enable.reg" c'era il file "undo.reg" che io non ho utilizzato, dovevo?
    [...]
    No, non dovevi utilizzare il file undo.reg, che serve per rimuovere dal Registro la modifica apportata dal file inpriv-filt-enable.

    Rimuovi IE8:
    http://support.microsoft.com/default.aspx/kb/957700
    "Modalità di disinstallazione o rimozione di Internet Explorer 8"
    Automaticamente verrà ripristinata la precedente versione di Internet Explorer.

    http://windows.microsoft.com/it-it/windows-vista/proper-installation-of-Windows-Internet-Explorer-8
    Reinstalla IE8 seguendo attentamente la guida.

    Se anche reinstallando correttamente Internet Explorer 8 noti un comportamento irregolare del browser ti suggerisco di rimuovere la suite McAfee per test, prima da Pannello di controllo -> Installazione applicazioni e poi utilizzando lo strumento di rimozione McAfee.

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    mercoledì 30 dicembre 2009 11:45
    Moderatore
  • Rimuovi IE8:
    http://support.microsoft.com/default.aspx/kb/957700
    "Modalità di disinstallazione o rimozione di Internet Explorer 8"
    Automaticamente verrà ripristinata la precedente versione di Internet Explorer.

    http://windows.microsoft.com/it-it/windows-vista/proper-installation-of-Windows-Internet-Explorer-8
    Reinstalla IE8 seguendo attentamente la guida.

    Se anche reinstallando correttamente Internet Explorer 8 noti un comportamento irregolare del browser ti suggerisco di rimuovere la suite McAfee per test, prima da Pannello di controllo -> Installazione applicazioni e poi utilizzando lo strumento di rimozione McAfee.

    Seguite le istruzioni dei due link: disinstallato IE8, verificato retrocessione ad IE7. Scaricato IE8. Applicato i 7 passaggi pre installazione, installato IE8, scaricati aggiornamenti. Ma non è cambiato nulla.

    McAfee e' la suite che c'era preinstallata, nell'OEM, in versione trial per 60gg. Dopo aver provato le principali suite di sicurezza con le quali ho avuto con diverse modalità problemi di stabilità con il s.o. e di aggiornamenti automatici delle firme virali (seppur abbia sempre usato prima di installare una nuova suite, i tool di rimozione dedicati), mi sono deciso a malincure ad acquistarlo, proprio per evitare i problemi di cui sopra e (a quanto pare) di quello per cui stiamo discutendo. 

    Dopo aver disinstallato McAfee, per il test come proteggo il s.o.?
    mercoledì 30 dicembre 2009 18:28

  • Seguite le istruzioni dei due link: disinstallato IE8, verificato retrocessione ad IE7. Scaricato IE8. Applicato i 7 passaggi pre installazione, installato IE8, scaricati aggiornamenti. Ma non è cambiato nulla.
    Non è cambiato nulla solo ed esclusivamente in relazione alla modifica per l'attivazione automatica di InPrivate Filtering?
    Per il resto Internet Explorer 8 funziona regolarmente? Navighi nei siti correttamente?

    Una considerazione importante: non so in quale stato è il sistema operativo ma sembra verosimilmente compromesso o danneggiato a livello di Registro, forse anche per l'utilizzo di più programmi per la sicurezza offensivi/invasivi o quanto meno incompatibili con IE8. Forse è il caso di reinstallare "in pulito" sistema operativo (quale hai?), applicazioni e browser.
    McAfee e' la suite che c'era preinstallata, nell'OEM, in versione trial per 60gg. Dopo aver provato le principali suite di sicurezza con le quali ho avuto con diverse modalità problemi di stabilità con il s.o. e di aggiornamenti automatici delle firme virali (seppur abbia sempre usato prima di installare una nuova suite, i tool di rimozione dedicati), mi sono deciso a malincure ad acquistarlo, proprio per evitare i problemi di cui sopra e (a quanto pare) di quello per cui stiamo discutendo. 
    Molti utenti lamentano problemi con le suite McAfee e Norton che trovano preinstallate nel computer appena acquistato, motivo per il quale se ne disfano immediatamente per installare altri prodotti più leggeri e meno invasivi.

    Dopo aver disinstallato McAfee, per il test come proteggo il s.o.?
    Avira Antivir free per uso personale o Avira Premium Security Suite a pagamento.
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    giovedì 31 dicembre 2009 06:00
    Moderatore
  • 1. Non è cambiato nulla solo ed esclusivamente in relazione alla modifica per l'attivazione automatica di InPrivate Filtering?
    Per il resto Internet Explorer 8 funziona regolarmente? Navighi nei siti correttamente?

    2. Una considerazione importante: non so in quale stato è il sistema operativo ma sembra verosimilmente compromesso o danneggiato a livello di Registro, forse anche per l'utilizzo di più programmi per la sicurezza offensivi/invasivi o quanto meno incompatibili con IE8. Forse è il caso di reinstallare "in pulito" sistema operativo (quale hai?), applicazioni e browser.

    3. Molti utenti lamentano problemi con le suite McAfee e Norton che trovano preinstallate nel computer appena acquistato, motivo per il quale se ne disfano immediatamente per installare altri prodotti più leggeri e meno invasivi.

    4. Avira Antivir free per uso personale o Avira Premium Security Suite a pagamento.
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    1. Chiaro in riferimento al filtro, per il resto il funzionamento è corretto.

    2. A parte spybot e spywareblaster, che dopo le vostre indicazioni ho disinstallato, ho soltanto la suite McAfee, con Windows firewall e Defender disattivati. Utilizzo programmi Antimalware free per scansioni manuali, Malwarebytes; Superantispyware e di recente Prevx3, quest'ultimo con disabilitato il csi scanner e le altre funzioni per il monitoraggio in real time.
    Il s.o. è vista Hom Premium sp2, 32bit, aggiornato. Devo dire che non rilevo problemi durante l'utilizzo che risulta abbastanza fluido, compatibilmente con le caratteristiche hardware della macchina che sono mediocri. Ho riscontrato soltanto un peggioramente nel tempo  di avvio, ma a quanto pare, da una discussione che ho aperto nella sezione dedicata a vista del forum è da ricondurre alle caratteristiche del pc.      

    3. Per quanto riguarda McAfee, come ti ho scritto l'ho acquistato dopo aver provato le altre suite con scarsa fortuna.

    4. grazie

    Comunque quanto prima disinstallerò McAfee e vedremo se è la causa del problema. Se negativa anche questa prova, invece di formattare potrei provare a ripristinare un immagine di sistema creata qualche tempo fa dopo una formattazione, che ne pensi?
    ciao e buon anno
    giovedì 31 dicembre 2009 18:44
  • Torniamo all'oggetto del tuo post qui nel Forum.
    La procedura per l'attivazione automatica di InPrivate Filtering descritta nel Blog post del mio collega MVP Ramesh è corretta e, se applicata, funziona perfettamente in gran parte dei casi.
    Quindi, a parte la modesta "anomalia" che riscontri, verosimilmente causata, come dicevo nella mia precedente risposta, da software di terze parti o da una corruzione del Registro di sistema, se IE8 per il resto ha un comportamento regolare resta a te decidere se "convivere" o meno con questa piccola imperfezione.

    Considera che l'installazione/rimozione dei vari software per la sicurezza (SpyBot S&D, SpywareBlaster, ecc.) potrebbe aver danneggiato il Registro di sistema, causando l'inconveniente che hai lamentato.

    Per quanto riguarda McAfee, si, ti consiglio di rimuoverlo per test (installa subito Avira Antivir, freeware, in modo tale da proteggere il sistema durante le verifiche).

    In relazione al ripristino del sistema con l'immagine da te creata subito dopo una trascorsa formattazione non posso che essere d'accordo. Se le prove che condurrai non produrranno un effetto positivo, carica pure quell'immagine e poi aggiorna immediatamente il sistema visitando il sito Microsoft Windows Update.

    Ciao,


    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    venerdì 1 gennaio 2010 06:58
    Moderatore
  • Grazie.
    ciao
    lunedì 4 gennaio 2010 15:36
  • Grazie.
    ciao
    YW. Grazie a te per il feedback.

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security - Since 2003.
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    lunedì 4 gennaio 2010 15:45
    Moderatore