locked
Windows Seven Service Pack 1 errore 0x800f0a12 RRS feed

  • Domanda

  • Ciao a tutti. Stavo cercando di installare il service pack di windows 7 64bit su un pc in dual boot con linux.

    Ottengo sempre errore 0x800f0a12.

    ulteriori dettagli:

    Il System Update Readiness Tool si installa senza far problemi o scrivere errori particolari nel log.
    durante l'installazione del service pack 1 di seven il log errori si è popolato con queste righe.
    (SPIRegQueryDWORDValue:413)Failed to query registry value: ComponentsRemoved er=0x2
    (SPCVerifyTrust:1664)Failed to CryptCATAdminCalcHashFromFileHandle GLE=0x57
    (SPIRegQueryDWORDValue:413)Failed to query registry value: UploadDisableFlag er=0x2
    (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
    (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
    (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
    (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
    (CSPInstall::AutoMountDisableCheck:1026)Bcdedit failed with error code 0x1 hr=0x800f0a12
    (CSPInstall::CompatibilityApplicabilityScan:1471)AutoMountDisable check failed hr=0x800f0a12
    (PerformSPInstallation:833)Failed to install SP using UI hr=0x800f0a12
    (wmain:1105)Failed to perform SP installation hr=0x800f0a12
    (SPIRegQueryStringValue:700)Failed to query registry value: MiscString2 er=0x2
    (CSystem::GetMachineName:395)Failed to query machine name from RAC hr=0x80070002

    in sostanza l'update si blocca in tempi brevissimi, nella fase di preparazione con l'errore 0x800f0a12.
    in rete si parla di usare mountall /e (non risolve il mio problema) ma sono aperto a suggerimenti
    oppure di usare diskpart automont enable (non risolve il mio problema) ma sono aperto a suggerimenti
    mercoledì 9 marzo 2011 11:51

Risposte