none
Errore esecuzione NTBACKUP ed errore windows update RRS feed

  • Domanda

  • Salve a tutti,

    il mio server windows 2003 R2 sp2 con  exchange 2003 installato sta manifestando due problemi piuttosto gravi:

    1) Il salvataggio su nastro (unità DTL VS160 con nastri DLTVS160) con NTBACKUP fa sistematicamente "cilecca" (si ferma e viene espulsa la cassetta) durante il salvataggio dei dati di exchange. Ecco il log del backup:

    Stato: backup
    Operazione: backup
    Destinazione backup attivo: DLT
    Nome supporto: "Backup effettuato il 25/08/2011 alle ore 23.00.00"

    Creazione copia shadow del volume: Tentativo 1.
    Backup (via copia shadow) di "C: "
    Set di backup #1 sul supporto #1
    Descrizione del backup: "Backup effettuato il 25/08/2011 alle ore 23.00.00"
    Nome supporto: "Backup effettuato il 25/08/2011 alle ore 23.00.00"

    Tipo di backup: Normale

    Backup avviato il 25/08/2011 alle 23.02.
    Backup completato il 25/08/2011 alle 23.10.
    Directory: 3491
    File: 30796
    Byte: 5.919.764.892
    Durata:  8 minuti e  9 secondi
    Backup (via copia shadow) di "E: Data"
    Set di backup #2 sul supporto #1
    Descrizione del backup: "Backup effettuato il 25/08/2011 alle ore 23.00.00"
    Nome supporto: "Backup effettuato il 25/08/2011 alle ore 23.00.00"

    Tipo di backup: Normale

    Backup avviato il 25/08/2011 alle 23.10.
    Backup completato il 26/08/2011 alle 1.28.
    Directory: 6796
    File: 66471
    Byte: 78.524.918.684
    Durata:  2 ore,  18 minuti e  43 secondi
    Backup di "NTSVR02\Microsoft Information Store\Primo gruppo di archiviazione"
    Set di backup n. 3 sul supporto n. 1
    Descrizione del backup: "Backup effettuato il 25/08/2011 alle ore 23.00.00"
    Nome supporto: "Backup effettuato il 25/08/2011 alle ore 23.00.00"

    Tipo di backup: Normale

    Backup avviato il 26/08/2011 alle 1.28.
    Installazione supporto richiesto non riuscita. Operazione terminata.
    Operazione terminata.
    Backup completato il 26/08/2011 alle 2.05.
    Directory: 2
    File: 3
    Byte: 19.603.125.322
    Durata:  36 minuti e  17 secondi

    ----------------------

    Operazione non completata.

    ----------------------

    Ho fatto vari controlli e verifiche l'unico dubbio che mi rimane è che il nastro non sia sufficiente a contenere tutti i dati di backup (80GB nativi 160Gb compressi), ma in quel caso ntbackup non dovrebbe richiederne uno nuovo? Mi aspetterei di trovare ancora in esecuzione NTBACKUP con la richiesta di inserire un nuovo supporto. ed invece niente.

     

    2) Windows update non funziona, internet explorer 8 segnala il seguente codice di errore: 0x80072EFD. Anche in questo caso ho seguito varie guide e fatti vari controlli ma niente da fare... (il server è dietro ad un firewall, ma può "uscire" liberamente, inoltre non ci sono proxy di mezzo...)

     

    Qualunque aiuto sarà ben accetto.

    Grazie

     

    Alessio


    Alessio
    venerdì 26 agosto 2011 06:27

Risposte

  • Per il problema del backup ho fatto delle prove ed eseguendo il salvataggio "interattivamente" ho scoperto che il backup falliva perché si esauriva lo spazio sulla cassetta, tra l'altro avevo provato ad eseguire il backup anche su un altro server e lì non segnalava problemi e il tutto si completava con successo. Riducendo la mole di dati da salvare funziona tutto, inoltre non vengono più segnalati errori relativamente ad una potenziale corruzionte del database.

    Invece per quannto riguarda l'update nessuno dei vostri suggerimenti ha dato esito positivo.

     

    Grazie

     

    Alessio


    Alessio
    giovedì 1 settembre 2011 09:42
  • Ciao Alessio, non ti ho chiesto se il problema di Windows Update lo riscontri soltanto sul server oppure se è generalizzato su tutta l'infrastruttura. Non hai risposto alla domanda se il protocollo https (443) è regolarmente instradato (https://www.microsoft.com)

     

    Saluti

    Nino

     

    giovedì 1 settembre 2011 11:52
    Moderatore
  • Risolto!!!

    Avevi ragione il 443 non era instradato correttamente per quel server... infatti andando su https://www.microsoft.com non si apriva niente, mentre per gli altri server della rete funzionava...

    Ho corretto l'instradamento ed adesso funziona correttamente.

     

    Grazie a tutti per il vostro supporto!!


    Alessio
    • Contrassegnato come risposta Alessio Artini giovedì 1 settembre 2011 14:22
    giovedì 1 settembre 2011 14:21

Tutte le risposte

  • Ciao Alessio, per problemi di visibilità forse sarebbe meglio dividere il 3D in due.

     

    1) Dovresti avere degli eventi riguardanti il backup puoi postarli

     

    2) Segui le indicazioni riportate qui http://support.microsoft.com/kb/836941/it ti ricordo che devi avere anche la porta 443 aperta.

     

    Saluti

    Nino

     


    venerdì 26 agosto 2011 07:05
    Moderatore
  • per la parte relativa al backup (a cui Nino non ha risposto) prova ad aggiungere alla stringa di backup in fondo lo switch /um

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    venerdì 26 agosto 2011 07:20
    Moderatore
  • Grazie per le risposte.

    Per quanto riguarda il backup ecco alcuni messaggio nel registro di sistema:

     

    Tipo evento:    Informazioni
    Origine evento:    ESE
    Categoria evento:    Connessione/Ripristino
    ID evento:    222
    Data:        26/08/2011
    Ora:        2.05.10
    Utente:        N/D
    Computer:    NTSVR02
    Descrizione:
    Information Store (4280) Primo gruppo di archiviazione: Sta per terminare il backup del file E:\Programmi\Exchsrvr\mdbdata\priv1.edb. Non tutti i dati nel file sono stati letti (letti 19471269888 byte di 21688037376 byte).

    #----

    Tipo evento:    Informazioni
    Origine evento:    NTBackup
    Categoria evento:    Nessuno
    ID evento:    8001
    Data:        26/08/2011
    Ora:        2.05.10
    Utente:        N/D
    Computer:    NTSVR02
    Descrizione:
    Fine backup di 'NTSVR02\Microsoft Information Store\Primo gruppo di archiviazione' '
    Operazione completata.'

         Verifica:  Off
         Modalità:  Append
         Tipo:  Normal
     
    Per ulteriori dettagli consultare il rapporto di backup.

    #-----
    Tipo evento:    Informazioni
    Origine evento:    ESE
    Categoria evento:    Connessione/Ripristino
    ID evento:    225
    Data:        26/08/2011
    Ora:        2.05.10
    Utente:        N/D
    Computer:    NTSVR02
    Descrizione:
    Information Store (4280) Primo gruppo di archiviazione: Impossibile troncare i file di registro. 


    #-----

    Tipo evento:    Informazioni
    Origine evento:    ESE
    Categoria evento:    Connessione/Ripristino
    ID evento:    213
    Data:        26/08/2011
    Ora:        2.05.10
    Utente:        N/D
    Computer:    NTSVR02
    Descrizione:
    Information Store (4280) Primo gruppo di archiviazione: Procedura di backup completata.

    #-------

    Tipo evento:    Errore
    Origine evento:    NTBackup
    Categoria evento:    Nessuno
    ID evento:    8019
    Data:        26/08/2011
    Ora:        2.05.11
    Utente:        N/D
    Computer:    NTSVR02
    Descrizione:
    Fine operazione: Si sono verificati avvisi o errori.
    Per ulteriori dettagli, consultare il Rapporto di backup.

     

    Per quanto riguarda l'update, avevo già visto il link che mi hai indicato ma non mi è stato di aiuto.

     

    Grazie


    Alessio
    venerdì 26 agosto 2011 08:02
  • Ecco il comando che lancio quando eseguo il backup:

    [...]

    C:\WINDOWS\system32\ntbackup.exe backup "@E:\script\Backup_Ntsvr02.bks" /n %txt% /d %txt% /v:no /r:no /rs:no /hc:on /m normal /j "Backup_Ntsvr02" /l:s /p "DLT" /UM

     

    come puoi vedere è già presente lo switch /um.

     

    Grazie


    Alessio
    venerdì 26 agosto 2011 08:03
  • se lanci l'esecuzione del backup interattivamente, funziona ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    venerdì 26 agosto 2011 09:05
    Moderatore
  • Cosa intendi interattivamente?

    eseguire lo script del post precedente con una sessione aperta o aprire da zero ntbackup selezionare i dati da salvare impostare le opzioni e poi dare il via al backup stesso?


    Alessio
    venerdì 26 agosto 2011 09:08
  • esatto.
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    venerdì 26 agosto 2011 09:18
    Moderatore
  • Adesso non posso fare una prova.

    Penso che potrò fare dei test in tal senso lunedì o martedì prossimi.

    Farò un post con l'esito delle prove.

    Per ora Grazie.


    Alessio
    venerdì 26 agosto 2011 09:21
  • Ciao Alessio, scusa il ritardo ma visto che ieri era il mio ultimo giorno di ferie ho approfittato per l'ultimo bagno...

     

    @Edoardo Benussi: Non sarebbe meglio dividere in due il 3D?

    @Edoardo Benussi: ho risposto chiedendo i log :)))

     

    1) Il primo evento (222) porta ad una eventuale corruzione del database http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Exchange&ProdVer=8.0&EvtID=222&EvtSrc=ESE&LCID=1033, prova ad eseguire delle verifiche seguendo questi due articoli http://support.microsoft.com/kb/328804/en-us e http://support.microsoft.com/kb/192185/en-us

     

    2)Effettua un ripristino delle impostazioni di IE e cancella la cache, mi è capitato di avere problemi similari dovuti al browser. Anche se dovresti già avere l'ultima versione verifica con questa http://support.microsoft.com/kb/949104. Ricordati di verificare la porta 443

     

    Saluti

    Nino

     

    sabato 27 agosto 2011 06:46
    Moderatore
  • Ciao Alessio,

    Intanto ho modificato il tipo di questo thread in "discussione generale", rimaniamo in attesa di ulteriori feedback da tua parte.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    giovedì 1 settembre 2011 06:43
  • Per il problema del backup ho fatto delle prove ed eseguendo il salvataggio "interattivamente" ho scoperto che il backup falliva perché si esauriva lo spazio sulla cassetta, tra l'altro avevo provato ad eseguire il backup anche su un altro server e lì non segnalava problemi e il tutto si completava con successo. Riducendo la mole di dati da salvare funziona tutto, inoltre non vengono più segnalati errori relativamente ad una potenziale corruzionte del database.

    Invece per quannto riguarda l'update nessuno dei vostri suggerimenti ha dato esito positivo.

     

    Grazie

     

    Alessio


    Alessio
    giovedì 1 settembre 2011 09:42
  • grazie per aver fornito le spiegazioni alla community.

    per il windows update hai seguito il consiglio di Nino scritto qui http://support.microsoft.com/kb/836941/it ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    giovedì 1 settembre 2011 10:23
    Moderatore
  • Purtroppo ho guardato il link indicato ma non mi è stato di auto.

    Ciao

     

    Alessio


    Alessio
    giovedì 1 settembre 2011 11:20
  • hai verificato e provato tutti i 6 metodi dell'articolo ?
    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    giovedì 1 settembre 2011 11:37
    Moderatore
  • Ciao Alessio, non ti ho chiesto se il problema di Windows Update lo riscontri soltanto sul server oppure se è generalizzato su tutta l'infrastruttura. Non hai risposto alla domanda se il protocollo https (443) è regolarmente instradato (https://www.microsoft.com)

     

    Saluti

    Nino

     

    giovedì 1 settembre 2011 11:52
    Moderatore
  • Risolto!!!

    Avevi ragione il 443 non era instradato correttamente per quel server... infatti andando su https://www.microsoft.com non si apriva niente, mentre per gli altri server della rete funzionava...

    Ho corretto l'instradamento ed adesso funziona correttamente.

     

    Grazie a tutti per il vostro supporto!!


    Alessio
    • Contrassegnato come risposta Alessio Artini giovedì 1 settembre 2011 14:22
    giovedì 1 settembre 2011 14:21
  • Direi che è andata bene, 2 su 2 :))

    Grazie per il riscontro.

     

    Saluti

    Nino

    giovedì 1 settembre 2011 14:23
    Moderatore