locked
In un dominio gestito da Windows 2003, le uniche tre macchine con Windows 7 non riescono a riconnettere le unità di rete all'avvio. RRS feed

  • Domanda

  • Gestisco un dominio Windows 2003 con circa 15 postazioni attive, di cui 3 con windows 7 (due professional a 32 bit e 1 professional a 64 bit). Le rimanenti postazioni sono XP o Windows 2000.

    Le tre postazioni Windows 7 non riescono quasi mai a riconnettere tutte le unità di rete quando l'utente accende il pc ed effettua il login. Ogni utente ha in media 8 connessioni di rete.

    Le connessioni vengono gestite al logon da un batch che viene eseguito in base al reparto di lavoro, ma che è nella sostanza identico per tutti, ed è nella forma

    NET USE X: \\Server\share /persistent:yes

    Questo batch risale alla notte dei tempi, credo da quando c'era ancora il server NT... Comunque ha sempre funzionato come un orologio e nessuno lo ha mai cambiato.

    Questo batch con le macchine 7 funziona (alla prima esecuzione le unità vengono create senza problemi), ma ai successivi riavvi cominciano a manifestarsi i problemi: appare il messaggio "Impossibile riconnettere tutte le unità di rete", se si apre l'explorer tutte le unità di rete (o quasi) sono marcate con 'X' rosso. Cliccando su ognuna, la croce sparisce e l'unità ritorna disponibile.

    Guardando nel registro eventi:

    Errore    23/11/2010 08:21:41    NETLOGON    5719    Nessuna

    Nome registro: System
    Origine:       NETLOGON
    Data:          23/11/2010 08:21:41
    ID evento:     5719
    Categoria attività:Nessuna
    Livello:       Errore
    Parole chiave: Classico
    Utente:        N/D
    Computer:      Aurora-pc041.sertek.lan
    Descrizione:
    Impossibile stabilire una sessione sicura con un controller di dominio nel dominio SERTEK per la causa seguente:
    Nessun server di accesso è attualmente disponibile per soddisfare la richiesta di accesso.
    Ciò può provocare problemi di autenticazione. Verificare che il computer sia connesso alla rete. Se il problema persiste, rivolgersi all'amministratore del dominio. 

    INFORMAZIONI AGGIUNTIVE
    Se il computer è un controller di dominio per il dominio specificato, stabilirà la sessione sicura con l'emulatore del controller di dominio primario nel dominio specificato. In caso contrario, il computer stabilisce la sessione sicura con un controller di dominio qualsiasi nel dominio specificato.
    XML evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="NETLOGON" />
        <EventID Qualifiers="0">5719</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-11-23T07:21:41.000000000Z" />
        <EventRecordID>15185</EventRecordID>
        <Channel>System</Channel>
        <Computer>Aurora-pc041.sertek.lan</Computer>
        <Security />
      </System>
      <EventData>
        <Data>SERTEK</Data>
        <Data>%%1311</Data>
        <Binary>5E0000C0</Binary>
      </EventData>
    </Event>

    Ho poi un altro evento:

    Nome registro: System
    Origine:       Microsoft-Windows-DNS-Client
    Data:          23/11/2010 08:21:52
    ID evento:     1014
    Categoria attività:Nessuna
    Livello:       Avviso
    Parole chiave:
    Utente:        SERVIZIO DI RETE
    Computer:      Aurora-pc041.sertek.lan
    Descrizione:
    Timeout della risoluzione dei nomi per il nome _kerberos._tcp.dc._msdcs.sertek.lan. Nessun server DNS configurato ha risposto.
    XML evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-DNS-Client" Guid="{1C95126E-7EEA-49A9-A3FE-A378B03DDB4D}" />
        <EventID>1014</EventID>
        <Version>0</Version>
        <Level>3</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x4000000000000000</Keywords>
        <TimeCreated SystemTime="2010-11-23T07:21:52.401339800Z" />
        <EventRecordID>15190</EventRecordID>
        <Correlation />
        <Execution ProcessID="1404" ThreadID="1780" />
        <Channel>System</Channel>
        <Computer>Aurora-pc041.sertek.lan</Computer>
        <Security UserID="S-1-5-20" />
      </System>
      <EventData>
        <Data Name="QueryName">_kerberos._tcp.dc._msdcs.sertek.lan</Data>
        <Data Name="AddressLength">16</Data>
        <Data Name="Address">02000035AC1014380000000000000000</Data>
      </EventData>
    </Event>

    Poi si trova un evento 1014:

    Nome registro: System
    Origine:       Microsoft-Windows-DNS-Client
    Data:          23/11/2010 08:22:29
    ID evento:     1014
    Categoria attività:Nessuna
    Livello:       Avviso
    Parole chiave:
    Utente:        SERVIZIO DI RETE
    Computer:      Aurora-pc041.sertek.lan
    Descrizione:
    Timeout della risoluzione dei nomi per il nome 16.172.in-addr.arpa. Nessun server DNS configurato ha risposto.
    XML evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-DNS-Client" Guid="{1C95126E-7EEA-49A9-A3FE-A378B03DDB4D}" />
        <EventID>1014</EventID>
        <Version>0</Version>
        <Level>3</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x4000000000000000</Keywords>
        <TimeCreated SystemTime="2010-11-23T07:22:29.946658400Z" />
        <EventRecordID>15202</EventRecordID>
        <Correlation />
        <Execution ProcessID="1404" ThreadID="304" />
        <Channel>System</Channel>
        <Computer>Aurora-pc041.sertek.lan</Computer>
        <Security UserID="S-1-5-20" />
      </System>
      <EventData>
        <Data Name="QueryName">16.172.in-addr.arpa</Data>
        <Data Name="AddressLength">16</Data>
        <Data Name="Address">02000035C0AF30010000000000000000</Data>
      </EventData>
    </Event>

    Dopo alcuni minuti compare questo errore:

    Nome registro: System
    Origine:       bowser
    Data:          23/11/2010 08:36:31
    ID evento:     8003
    Categoria attività:Nessuna
    Livello:       Errore
    Parole chiave: Classico
    Utente:        N/D
    Computer:      Aurora-pc041.sertek.lan
    Descrizione:
    Il master ha ricevuto un annuncio server dal computer W3KSRV01 che ritiene di essere il master per il dominio sul trasporto NetBT_Tcpip_{82E3EB27-6A86-4766-B83D-982A6FD2C. Il master sta per essere arrestato o si sta forzando un'elezione.
    XML evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="bowser" />
        <EventID Qualifiers="49152">8003</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-11-23T07:36:31.515142800Z" />
        <EventRecordID>15229</EventRecordID>
        <Channel>System</Channel>
        <Computer>Aurora-pc041.sertek.lan</Computer>
        <Security />
      </System>
      <EventData>
        <Data>\Device\LanmanDatagramReceiver</Data>
        <Data>W3KSRV01</Data>
        <Data>NetBT_Tcpip_{82E3EB27-6A86-4766-B83D-982A6FD2C</Data>
        <Binary>000000000300280000000000431F00C0000000000000000000000000000000000000000000000000</Binary>
      </EventData>
    </Event>

    Eventi come quest'ultimo continuano per tutta la mattinata (ce ne sono altri 5),  e credo che ad ognuno di questi eventi corrisponda un reset della connessione di rete (l'utente si lamenta che una applicazione gestionale client/server che esegue va in errore di rete), e gli orari coincidono.

    Qualcuno ha un'idea?

     

    martedì 23 novembre 2010 16:45

Tutte le risposte

  • Se il file batch che configura le connessioni di rete viene eseguito ad ogni logon toglierei il parametro PERSISTENT, dopodichè vedi se modificando la funzionalità autodisconnect il problema si risolve (http://support.microsoft.com/kb/297684):

    net config server /autodisconnect:-1

    I client che hanno problemi, che server DNS usano.

    Ciao


    martedì 23 novembre 2010 23:11
  •  

    Se il file batch che configura le connessioni di rete viene eseguito ad ogni logon toglierei il parametro PERSISTENT, dopodichè vedi se modificando la funzionalità autodisconnect  il problema si risolve (http://support.microsoft.com/kb/297684 ):

     

    net config server /autodisconnect:-1

    I client che hanno problemi, che server DNS usano.

    Ciao

     

    Non credo sia questo il caso, comunque provo. La non-riconnessione c'è solo al logon, poi se uno riconnette a manina tutte le share può lavorare tranquillo per il resto della giornata. L'esempio citato si riferisce ad una postazione che ha problemi più evidenti delle altre. Adesso le ho cambiato il cavo di rete, vediamo se riduciamo i problemi solo al logon.

    Tutte le postazioni usano w3ksrv01.sertek.lan come DNS. La configurazione è con IP statici.

    Un'altra cosa che mi sfugge: ho degli eventi dove interpreto "non ho trovato un DHCPv4 o DHCPv6", però entrambi i protocolli usano indirizzi statici.


    mercoledì 24 novembre 2010 08:17
  • Ciao andrew15,

    Per cortesia, possiamo avere qualche notizia sul tuo caso? Sei riuscito a risolvere?

    Sarebbe utile di condividere la soluzione sul forum, così aiutiamo gli altri membri della community che si trovano di fronte a problemi simili.

    Grazie per la tua collaborazione!


    Anca Popa Follow ForumTechNetIt on Twitter

    FAQ:

    Quando utilizzare un print server

    PowerShell: Salvare/leggere le credenziali da un file

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie Microsoft. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte di Microsoft. 

    lunedì 6 dicembre 2010 10:51
  • Ciao andrew15,

    Per cortesia, possiamo avere qualche notizia sul tuo caso? Sei riuscito a risolvere?

    Sarebbe utile di condividere la soluzione sul forum, così aiutiamo gli altri membri della community che si trovano di fronte a problemi simili.

    Grazie per la tua collaborazione!


    Anca Popa Follow ForumTechNetIt on Twitter

    No, al momento ancora buio completo. Ho cambiato il cavo ad una delle postazioni ed ho ottenuto almeno la non-disconnessione improvvisa delle condivisioni di rete  e delle applicazioni client/server, ma lo scherzo della mancata riconnessione all'avvio continua.

    Io sono dell'avviso che si tratti di una questione legata all'avvio dei servizi, perché su due installazioni virtualizzate con Xen, che uso per testare il software, non ho di questi problemi, essendo l'avvio più lento e successivamente gestito tramite Remote Desktop.

    Sulle macchine reali il prompt "Premere Ctrl-Alt-Canc per iniziare" è rapidissimo, ma se non si esegue login e si lascia procedere si vede che Seven continua a macinare per circa un paio di minuti, poi entra in idle. Se a quel punto si fa login, la probabilità di trovare le share non collegate è più bassa (circa 40%), mentre se si fa login subito è quasi una certezza.

    Trovassi uno straccio di evento nei log....

     


    Andrea Quaglia
    giovedì 9 dicembre 2010 17:34
  • Il master ha ricevuto un annuncio server dal computer W3KSRV01 che ritiene di essere il master per il dominio sul trasporto NetBT_Tcpip_{82E3EB27-6A86-4766-B83D-982A6FD2C. Il master sta per essere arrestato o si sta forzando un'elezione.

     

     

    Questo evento, penso sia generato perchè è avviato il servizio "Browser di computer".

    Se lo disabiliti non dovrebbe più comparirti il messaggio sul server.

    Ma non risolve il Tuo problema Penso.

     

    Buon Lavoro!


    Paolo Costamagna
    giovedì 10 marzo 2011 15:54
  • Ciao,

    prima di creare le connessioni con NET USE, le cancelli?

    Io ho degli script simili, e funzionano bene anche su W7.. se magari posti lo script posso dargli un'occhiata e confrontarlo con i miei...

    Hai già fatto un'analisi del traffico di rete, per vedere se c'è moolto broadcast o poco? la lentezza potrebbe essere data da una rete non proprio ok..

    Puoi usare uno sniffer di rete per fare questa analisi... tipo wireshark o qualcosa di simile...

    Best Regards!


    Paolo Costamagna

    martedì 6 marzo 2012 12:31