none
errore nella configurazione dei DAG RRS feed

  • Discussione generale

  • Salve a tutti,

    è da una settimana che sto cercando di risolvere un problema nella configurazione dei DAG appunto, ma non riesco a venirne a capo.

    La configurazione delle VM che sto utilizzando è la seguente: 3 VM entrambe con Windows Server 2012 Datacenter ed Exchange 2013 RTM.

    Sulla prima VM è installato sia il ruolo CAS che Mailbox e fa anche da server witness, mentre sulle due VM che fanno parte del DAG è installato solo il ruolo Mailbox.

    Il problema nasce nella configurazione dei DAG, in particolar modo con ipv6. In pratica l'unico modo che ho per aggiungere il secondo nodo del DAG al cluster, è quello di disabilitare completamente ipv6 sia sul server witness che sui nodi che faranno parte del DAG. 

    Nel momento in cui provo a riattivare ipv6 dalla interfaccia di rete di uno dei nodi, rimane up un solo nodo.

    L'errore che ottengo è il seguente: 


    "Cluster node was removed from the active failover cluster membership. The Cluster service on this node may have stopped. This could also be due to the node having lost communication with other active nodes in the failover cluster. Run the Validate a Configuration wizard to check your network configuration. If the condition persists, check for hardware or software errors related to the network adapters on this node. Also check for failures in any other network components to which the node is connected such as hubs, switches, or bridges.

    EVENT ID 1135"

    Ho provato davvero qualunque soluzione, anche quella di disattivare completamente il firewall, ma non è servito a nulla. Quale potrebbe essere secondo voi il problema?

    Luca


    • Modificato FREEDOM80 martedì 13 novembre 2012 15:24
    • Tipo modificato Anca Popa lunedì 19 novembre 2012 15:08 in attesa di ulteriori aggiornamenti
    martedì 13 novembre 2012 15:17

Tutte le risposte

  • Lancia il wizard di validazione del cluster, prima di tutto. Vediamo che dice...

    Ciao,


    Dario Palermo

    mercoledì 14 novembre 2012 11:00
  • Ciao Dario,

    al momento per utilizzare entrambi i nodi ho disabilitato dall'interfaccia di rete ipv6 e quindi quando lancio il wizard per la validazione del cluster tutto va a buon fine.

    Quando invece abilitavo ipv6 e facevo la validazione del cluster veniva riportato un errore di comunicazione tra i nodi che è esattamente quello del log che ho riportato nel mio primo post.

    Dalle verifiche che ho fatto però non sembrerebbe esserci invece alcun problema in questo senso, anche perché ho effettuato i test con il firewall spento su tutte le VM e poi creando una regola any<-->any tra le tre VM. Oltre a ciò ho anche verificato che tutte le eccezioni per Exchange fossero presenti su fw e così è, compresa la porta 3343--UDP per l'heartbet tra i nodi del cluster.

    Sistematicamente appena attivo ipv6 su un nodo quello senza ipv6 viene quasi immediatamente disconnesso dal cluster e non ho modo di riattivarlo se non rimuovendo completamente il gruppo di disponibilità del database e riconfigurando tutto da zero senza ipv6 ovviamente.

    Luca

    mercoledì 14 novembre 2012 11:26
  • Ciao Luca,

    Non abbiamo ricevuto alcun aggiornamento e mi chiedevo se possiamo aiutarti ulteriormente o se il problema è stato risolto.

    Se così fosse ti saremmo grati di condividere il tuo feedback in questo spazio ricordandoti che altri membri della community potrebbero riscontrare comportamenti simili.

    Grazie in anticipo,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    lunedì 19 novembre 2012 15:07
  • Salve,

    ahimè ancora non sono riuscito a risolvere il problema. Attualmente la mia installazione di Exchange 2013 è configurata senza ipv6.

    Sto utilizzando questa configurazione in attesa di trovare qualche soluzione.

    Luca

    lunedì 19 novembre 2012 15:16
  • Proviamo a fare un passo indietro.

    Quando abiliti l'IPv6 su "nodo1" e fai un ping a "nodo1" ti risponde con l'indirizzo in IPv4 o IPv6 ?
    Quando abiliti l'IPv6 su "nodo2" e fai un ping a "nodo1" ti risponde con l'indirizzo IPv4 o IPv6 ? e soprattutto risponde ?

    I cluster Windows comunicano nativamente in IPv6 per cui mi verrebbe da dire che non si pingano quando usano l'IPv6 :-)

    Le VM su cosa girano ? Hyper-V ? VMWare ? Che versione ?

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    martedì 20 novembre 2012 08:51
  • Ciao Gabriele,

    cerco di rispondere alle tue domande.

    La mia infrastruttura è basata interamente su Windows Server 2012, sia host fisici che vm, quindi quest'ultime girano su Hyper-V. 

    Quando provo a creare il cluster e configurare i server che faranno parte del DAG spengo il firewall su tutte le vm di exchange, nel mio caso 3, una vm CAS-Mailbox e due solo Mailbox(DAG).

    L'unico modo che ho trovato per configurare i DAG con Exchange 2013 è il seguente:

    Preconfigurare l'oggetto computer-DAG  in AD(Windows Server 2102), inserendo i permessi per i server che faranno parte del DAG ed il gruppo Exchange Trusted Subsystem ai quali va dato full control. Poi disabilito l'oggetto appena creato.

    Creare un host name all'interno del DNS corrispondente ovviamente all'oggetto computer appena creato in AD con l'ip scelto, selezionando poi il flag "allow any authenticated user to update this record..."

    Fatto questo devo necessarimanete disabilitare ipv6 dalla scheda di rete sia sul server CAS-Mailbox che è anche il witness server che sui nodi del DAG dov'è installato solo il ruolo mailbox. Oltre a ciò disabilito completamente il fw sulle vm. 

    Questo è l'unico modo che creare il DAG su exchange 2013, altrimenti becco sempre questo errore:

    "

    Operazione di amministrazione del gruppo di disponibilità del database sul lato server non riuscita. Errore: The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"AddClusterNode() (MaxPercentage=100) failed with 0x5b4. Error: This operation returned because the timeout period expired"' failed.. [Server: ]

    "

    Ciao,

    Luca

    • Modificato FREEDOM80 martedì 20 novembre 2012 11:55
    martedì 20 novembre 2012 11:53
  • Ciao,

    La mie domande sono molto più semplici:

    1) Con l'IPv6 abilitato riesci a fare un ping tra le VM Exchange/Nodi del cluster ?

    Le risposte possibili sono: Sì/No.

    2) Quando risolve da nome a IP vedi l'IPv4 o IPv6 ? (sempre con IPv6 abilitato)

    Le risposte possibili sono: IPv4/IPv6.

    La procedura che usi mi sembra alquanto macchinosa :-)

    Exchange 2013 si installa con il FW attivo proprio perchè aggiunge le regole che gli servono. Non è che il FW era disabilitato durante il setup di Exchange ?

    Tutte le operazioni che hai descritto (creazione oggetto macchina, DNS, permessi, etc...) le dovrebbe fare in automatico. Che permessi ha l'utente che usi per creare il DAG ?

    Il DAG lo crei dall'Exchange Administration Center (EAC) o da Powershell ?

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    martedì 20 novembre 2012 13:58
  • Allora:

    1)Con IPv6 abilitato riesco a pingare tutte le VM;

    2)Quando cerco di risolvere il nome della VM mi viene restituito in IPv6;

    Mi rendo conto che la procedura che uso è macchinosa, ma è l'unica che mi permette al momento di testare i DAG :-)

    L'installazione di Exchange l'ho effettuata con il fw attivo, infatti tutte le regole che servono ad Exchange per il corretto funzionamento sono state create. Spengo il fw solo quando tento di configurare i DAG.

    E' vero quando dici che le operazioni di creazione oggetto, DNS etc... dovrebbe farle in automatico(come utente utilizzo l'amministratore di dominio), infatti con Exchange 2010 sp1/sp2 non ho mai avuto problemi del genere, ma con Exchange 2013 così non è. Ho trovato molta gente in rete che ha riscontrato i miei stessi problemi, è le soluzioni dei problemi di permessi sull'oggetto cluster, DNS etc.. sono quelle che ho descritto poco sopra.

    Infine la creazione del DAG l'ho effettuata sia da EAC che da powershell, ottenendo sempre il medesimo errore quado IPv6 è attivo.

    Al momento infatti ho riattivato IPv6 per fare le prove che mi chiedevi ed un nodo del cluster puntualmente è andato down.

    L'errore riportato è il seguente:

    "Cluster node 'BAGDEN' was removed from the active failover cluster membership. The Cluster service on this node may have stopped. This could also be due to the node having lost communication with other active nodes in the failover cluster. Run the Validate a Configuration wizard to check your network configuration. If the condition persists, check for hardware or software errors related to the network adapters on this node. Also check for failures in any other network components to which the node is connected such as hubs, switches, or bridges."

    Ciao,

    Luca

    martedì 20 novembre 2012 16:05
  • Domani vado in ufficio e provo con un lab simile.
    Vedo di replicare il problema.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    martedì 20 novembre 2012 20:45
  • Ti ringrazio per il supporto.

    Ciao,

    Luca

    martedì 20 novembre 2012 22:27
  • Provato con Lab identico al tuo.

    Il DAG si è creato senza problemi (con IPv6 abilitato e non)

    Ho provato anche a creare il DAG con il solo IPv4 abilitato e ad abilitare l'IPv6 successivamente.

    L'evento 1135 è apparso ma subito dopo le risorse sono tornate online e un test-replicationhealth ha dato tutti i test a passed.

    Prova anche tu con il cmdlet.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    mercoledì 21 novembre 2012 13:14
  • Ciao Gabriele,

    nuovamente grazie per il supporto.

    Ieri sera ho provato nuovamente a configurare il DAG via powershell come mi suggerivi tu, con questi comandi:

    New-DatabaseAvailabilityGroup -Name DAG -WitnessServer HC1 -WitnessDirectory C:\FSW -DatabaseAvailabilityGroupIPAddresses "indirizzo ip"

    Add-DatabaseAvailabilityGroupServer -Identity DAG -MailboxServer MB1

    Add-DatabaseAvailabilityGroupServer -Identity DAG -MailboxServer MB2

    Ho mantenuto abilitato sia il FW che IPv6 e come al solito il primo server è stato inserito all'interno del cluster mentre il secondo no. Ottengo sempre questo errore:

    "Operazione di amministrazione del gruppo di disponibilità del database sul lato server non riuscita. Errore: The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"AddClusterNode() (MaxPercentage=100) failed with 0x5b4. Error: This operation returned because the timeout period expired"' failed.. [Server: ]"

    C'è qualche procedura particolare che forse non tengo in considerazione per la configurazione corretta dei DAG?

    Questa mattina  comunque provo un setup con Exchange 2010 per vedere cosa succede e ti aggiorno nuovamente. 

    Se anche un setup con Exchange 2010 dovesse dare gli stessi problemi, dovrò fare un controllo accurato sulla configurazione del cluster sul quale installo le VM per Exchange 2013 e/o sugli apparati di rete del Datacenter presso il quale sono ospitati i server.

    Ciao e grazie,

    Luca

    P.S. Volevo farti altre due domande se posso:

    La configurazione delle VM l'hai fatta con ip pubblici o privati?

    AD l'hai configurata su Win 2012 o 2008R2?

     
    • Modificato FREEDOM80 giovedì 22 novembre 2012 09:17
    giovedì 22 novembre 2012 09:14
  • AD Windows 2008R2

    Una subnet pubblica per il MAPI impostata "Internal"
    Una subnet privata per l'heartbeat impostata "private"

    Ciao
    Gabriele

    P.S. Non posso cambiare perchè è un ambiente in coesistenza 2010/2007


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    giovedì 22 novembre 2012 15:03
  • Ho provato ha configurare Exchange 2010 SP1 con AD Windows Server 2008R2 ed ho sempre lo stesso problema, con ipv6 attivato non riesco ad aggiungere il secondo DAG, mentre con ipv6 disabilitato tutto ok.

    Per ora partirò con una configurazione senza ipv6.

    Ciao e grazie dell'aiuto e della tua disponibilità,

    Luca

    giovedì 22 novembre 2012 15:36