none
EXCHANGE 2016 problemi vari e ruolo mancante dopo CU2 RRS feed

  • Domanda

  • Ciao a tutti,

    Ho un cliente che ha exchange 2016 installato su windows server 2012 R2 e giovedì sera ho installato il CU1
    Venerdì mi chiama per dirmi che non vanno più le mail in uscita (interne ed esterne), allora venerdì sera installo il CU2 per vedere se risolvo qualcosa
    L' installazione si pianta a metà con qualche errore e eschange praticamente non funziona più (no owa, no ecp, no outlook) e se provo a far ripartire l' installazione mi dice "installazione non completa" e prova a reinstallarsi finendo in errore
    Stanotte verso le 5 di mattina riesco a far ripartire exchange, e noto che i telefoni non riescono più a connettersi e le mail non partono comunque
    Analizzo meglio il server e mi accorgo che si è "disinstallato" il ruolo di trasporto edge, e se provo a installarlo va in errore
    Penso che se riuscissi a reinstallare il ruolo, tutto si risolverebbe

    Consigli?

    Altrimenti come potevo fare per spostare il db in un nuovo server exchange 2016?

    Grazie mille

    sabato 2 luglio 2016 13:44

Tutte le risposte

  • L' errore è questo :

    Componente Ruolo Trasporto Edge di Exchange Server non riuscito. 
    Errore: Errore:
    Si è verificato il seguente errore durante l'esecuzione di "$error.Clear(); 
    new-ExchangeServer

    ": "System.ArgumentNullException: Il valore non può essere null.
    Nome parametro: Impossibile ottenere oggetto secondario di ADObjectId: this is a GUID based ADObjectId.
       in Microsoft.Exchange.Data.Directory.ADObjectId.GetChildId(String prefix, String unescapedCommonName)
       in Microsoft.Exchange.Data.Directory.ADDataSession.IsConfigScoped(ADScope scope)
       in Microsoft.Exchange.Data.Directory.ADDataSession.GetConnection(String preferredServer, Boolean isWriteOperation, String optionalBaseDN, ADObjectId& rootId, ADScope scope)
       in Microsoft.Exchange.Data.Directory.ADDataSession.GetReadConnection(String preferredServer, String optionalBaseDN, ADObjectId& rootId, ADRawEntry scopeDeteriminingObject)
       in Microsoft.Exchange.Data.Directory.ADDataSession.InternalFind[TResult](ADObjectId rootId, String optionalBaseDN, ADObjectId readId, QueryScope scope, QueryFilter filter, SortBy sortBy, Int32 maxResults, IEnumerable`1 properties, Boolean includeDeletedObjects)
       in Microsoft.Exchange.Data.Directory.SystemConfiguration.ADTopologyConfigurationSession.GetAdministrativeGroup()
       in Microsoft.Exchange.Data.Directory.SystemConfiguration.ADTopologyConfigurationSession.GetAdministrativeGroupId()
       in Microsoft.Exchange.Management.SystemConfigurationTasks.NewExchangeServer.PrepareDataObject()
       in Microsoft.Exchange.Configuration.Tasks.SetTaskBase`1.InternalValidate()
       in Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
       in Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
       in Microsoft.Exchange.Configuration.Tasks.Task.ProcessTaskStage(TaskStage taskStage, Action initFunc, Action mainFunc, Action completeFunc)
       in Microsoft.Exchange.Configuration.Tasks.Task.ProcessRecord()
       in System.Management.Automation.CommandProcessor.ProcessRecord()".

     
    sabato 2 luglio 2016 20:02
  • Ciao, cosa c'entrano i telefoni con Exchange? intendi ActiveSync per i mobile? Ad ogni modo non puoi spostare un DB da un'altra parte, quindi non ci sono soluzioni di questo tipo. Hai installato CU1 per quale motivo? il server non funzionava correttamente? Installare CU2 su CU1 non funzionante non è una buona idea...

    Ad ogni modo guardando i tuoi log stai messo male al momento non credo ci sia modo da qui di riuscire a guidarti in una soluzione, l'unica è il supporto Exchange a pagamento..ma secondo me devi prepararti a reinstallare tutto...ed estrarre i pst delle mailboxes..

    Ciao,

    A.

    lunedì 4 luglio 2016 09:24
    Moderatore