none
AD Connect e Office 365. Problemi con il connector e gli utenti migrati su O365 RRS feed

  • Domanda

  • Provo a formulare domanda su questo forum... nel caso mi direte.

    Buongiorno a tutti

    Scenario:
    Dominio AD. No Exchange on premise. Livello funzionalità dominio 2003.
    Office 365 Business (Microsoft Forms - Plan E1)

    Abbiamo lanciato sincronizzazione utilizzando Azure Ad Connector.
    La situazione attuale è che in O365 gli utenti hanno come nome utente "nomeutente@dominioO365.onmicrosoft.com" (dato che NON posso modificare)
    Se tento di configurare una mail  su outllok devo scrivere come nome utente quello segnalato sopra.
    Anche se come mail principale riferita all'utente ho "nomeutente@nomedominesterno.it" le mail escono come "nomeutente@dominioO365.onmicrosoft.com"

    Nota: Se creo dentro a O365 un nuovo user viene corretto (Nome utente = "nomeutente@nomedominesterno.it")

    Cosa ho sbagliato ?
    Grazie 1000 per ogni consiglio

    Carlo Patrizio Falco

    mercoledì 17 gennaio 2018 11:08

Tutte le risposte

  • Ciao Carlo, nella configurazione di O365 hai già aggiunto il dominio? https://support.office.com/en-us/article/change-your-email-address-to-use-your-custom-domain-f4d8cae9-6d06-4c4b-b4e5-6581fd05ea82

    Saluti
    Nino


    www.testerlab.it

    mercoledì 17 gennaio 2018 11:36
  • Hai detto che stai sincronizzando con AD, gli UPN degli utenti come sono messi?

    Per essere tutto ok devi aggiungere come suffisso UPN in AD il dominio pubblico che usi per la mail e impostarlo su tutti gli utenti che sincronizzi, in questo modo l'utente viene impostato online con il dominio corretto e non con quello "onmicrosoft"

    Roberto


    Roberto Ferazzi
    Microsoft® MVP Office Server & Services (Exchange Server)
    Moderator in the Microsoft TechNet Italy Forums
    My MVP Profile

    MSExchange.Community

    mercoledì 17 gennaio 2018 13:33
    Moderatore
  • Lo avevo aggiunto...

    Grazie

    lunedì 22 gennaio 2018 14:38
  • Mi pareva una bella dritta ed ho provato.. ma sono rimasti onmicrosoft..

    Ho trovato questo documento che pare il mio.

    https://blogs.perficient.com/microsoft/2014/04/office-365-configuring-ad-fs-dirsync-with-an-alternate-login/

    Provo

    Grazie Carlo

    lunedì 22 gennaio 2018 14:39
  • Ciao Carlo,

    Hai detto che gli utenti che hanno la mail user@dominio.it escono come onmicrosoft.com.

    Puoi controllare quale SMTP predefinto utilizzano in amministrazione di Exchange di Office365?

    Da powershell, se puoi lancia il comando sotto ed assicurati quali SMTP stai utlizzando:

    Get-Mailbox | Select-Object DisplayName,@{Name=“EmailAddresses”;Expression={$_.EmailAddresses |Where-Object {$_ -LIKE “SMTP:*”}}} | Sort | Format-List

    Esempio

    Marco


    lunedì 22 gennaio 2018 16:27
  • Grazie della riposta.

    Questo il risultato su un utente. Uguale gli altri

    DisplayName    : Nome Cognome
    EmailAddresses : {SMTP:n.cognome@xxxxxxxx.it, smtp:m.vignali@xxxxxxxxmfb.onmicrosoft.com}

    Sto ancora tentando di capire..

    martedì 23 gennaio 2018 10:33
  • Questo è un utente creato in office365 ?

    Postami il risultato di un utente che invia come onmicrosoft.

    Marco

    martedì 23 gennaio 2018 10:39
  • (NOTA: La situazione è particolare, nel senso che abbiamo ereditato una installazione O365 che veniva usata solo per la parte  Share Point.
    La richiesta cliente è stata di implementare servizi posta, ed abbiamo aggiunto servizi Exchange on Line. Dopo abbiamo fatto una Sincro AD.)

    RISPOSTA:
    Quello che segnalo è uno degli utenti, ma in O365 son tutti così.
    Se faccio un nuovo utente mi prende correttamente come Nome utente = "nomeutente@nomedominesterno.it"
    Ma quelli importati sono tutti così.
    Nome utente = "nomeutente@nomedominomfb.onmicrosoft.com"

    Saluti

    Carlo Patrizio Falco

    venerdì 26 gennaio 2018 09:14
  • Correggo NOTA.

    Il cliente ha acquistato servizi Office 365 Essential, prima non avevano nulla riferito a O365.

    (Share point era locale)

    venerdì 26 gennaio 2018 09:25
  • Mi sto perdendo...

    Ricapitoliamo il tutto:

    1. Il cliente ha acquistato Office365 business essential ( ma la business essential ha gia Exchange e Sharepoint)
    2. Avete aggiunto il "nomedominesterno.it" autenticato etc etc
    3. Poi avete fatto ciò "Abbiamo lanciato sincronizzazione utilizzando Azure Ad Connector."

    con il seguente risultato quando inviate le email:

    • "Se faccio un nuovo utente mi prende correttamente come Nome utente = nomeutente@nomedominesterno.it"
    • "quelli importati sono tutti così.
      Nome utente = nomeutente@nomedominomfb.onmicrosoft.com

    Quindi se vai in amministrazione di Office365 ed utenti e selezioni uno degli utenti importati hai una situazione del genere?

    venerdì 26 gennaio 2018 09:44
  • Se è tutto confemato allora ho questa ipotesi.

    Ad connect "non ha trovato corrispondenza" tra il dominio on premises ed il dominio di office365 per questo gli utenti importati sono stati "settati" con il dominio di default di Azure che è onmicrosoft.com

    Fonte:https://docs.microsoft.com/en-us/azure/active-directory/connect/active-directory-aadconnect-user-signin

    Una soluzione potrebbe essere:

    https://support.microsoft.com/en-us/help/2669550/changes-aren-t-synced-by-the-azure-active-directory-sync-tool-after-yo

    Facci sapere

    • Proposto come risposta Marco Borgia giovedì 4 ottobre 2018 15:20
    venerdì 26 gennaio 2018 10:06
  • Grazie 1000..
    Penso, leggendo le righe sopra, che il nostro errore sia stato (appunto) che abbiamo lanciato la SYNC senza aver prima ribadito negli utenti l'indirizzo mail corretto..

    provo suggerimento...

    Grazie Ancora

    venerdì 26 gennaio 2018 10:43
  • Arrivo lungo e me ne scuso.. ma con questa "dritta" abbiamo brillantemente risolto

    Grazie 1000000000

    Carlo

    mercoledì 3 ottobre 2018 11:43
  • Grazie a te, 

    buon lavoro.

    Marco

    mercoledì 3 ottobre 2018 12:01