none
Impossibile stampare da RDS Windows Server 2012 RRS feed

  • Domanda

  • Salve a tutti, ho un server Windows Server 2012 e un client Windows 7 che si collega in rdp. Il server l'ho configurato come terminal server senza dominio e gli ho installato il driver della stampante HP Laserjet M1212nf che è collegata fisicamente al client in usb. Se dal client mi collego al server come administrator IN CONSOLE, viene correttamente reindirizzata la stampante e stampa correttamente, in alternativa se non aggiungo l'opzione "/admin" al comando "mstsc" la stampante viene comunque reindirizzata ma col driver easy print, e mi dice "impossibile stampare". Lo stesso accade se mi connetto con un utente "user" abilitato all'accesso.

    Cosa posso fare?

    domenica 12 ottobre 2014 12:11

Risposte

Tutte le risposte

  • Ciao Antonio, hai provato a disattivare l'easy print? Dai una lettura al seguente articolo Windows server 2012 Remote desktop services | Terminal server Printing without Easy Print.

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    domenica 12 ottobre 2014 13:59
    Moderatore
  • Si ho già provato, e quando mi connetto non reindirizza la stampante dando nell'event viewer l'errore 1102 dicendo che manca il driver!

    Ma se così fosse perché se mi connetto in console il driver magicamente compare?

    lunedì 13 ottobre 2014 06:55
  • mi viene da supporre che centri in qualche modo lo user right

    - load and unload device drivers


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    lunedì 13 ottobre 2014 08:32
    Moderatore
  • Finalmente ho risolto. Ho disattivato l'utilizzo dell'easy print da "gpedit.msc". Anche se l'opzione di default dice che utilizzerebbe prima il driver specifico, così non è. Ecco il percorso:

    Computer Configuration\Policies\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Printer Redirection\Use Terminal Services Easy Print printer driver first

    -        - Disable

    User Configuration\Policies\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Printer Redirection\Use Terminal Services Easy Print printer driver first

    -        - Disable

    G

    Grazie di tutto!
    lunedì 13 ottobre 2014 11:10