none
Errore windows server backup su windows server 2008 R2 RRS feed

  • Domanda

  • Oggi andando a guardare il servizio backup del server mi sono accorto che è da marzo he da errore quando cerca di fare il backup. L'errore è questo:"Operazione non riuscita. Riprovare. Se il probelma persiste, eliminare e quindi ricreare le impostazioni del backup pianificato. La destinazione di backup specificata non è valida."

    Facendogli fare il backup unico con le impostazioni pianificate mi dice sempre: "La destinazione di backup specificata non è valida." mentre se metto le impostazioni a mano (imposto le stesse del backua) funziona.

    Ho provato come suggerito a eliminare le impostazioni e ricrearlo ma andando su "pianificazione guidata" e selezionando "interrompi backup" mi da errore che posto come immagine:

    http://www.alescan.it/errori%20server/errore%20snap-in.png

    Selezionando la seconda opzione (rimuovi snap-in e continua) mi da questo altro errore:

    http://www.alescan.it/errori%20server/errore.png



    Qualche idea su come risolvere una delle due cose?

    Grazie
    Alessandro

    martedì 21 giugno 2011 14:45

Risposte

Tutte le risposte

  • Oggi andando a guardare il servizio backup del server mi sono accorto
    che è da marzo he da errore quando cerca di fare il backup. L'errore è
    questo:"Operazione non riuscita. Riprovare. Se il probelma persiste,
    eliminare e quindi ricreare le impostazioni del backup pianificato. La
    destinazione di  backup specificata non è valida."

    Prima di tutto... riavvia il sistema ... no, non sto scherzando, il fatto è che alcuni processi del "backup" potrebbero essere ancora in memoria impedendo ad ulteriori tentativi di backup di funzionare (ad esempio perchè l'unità di backup viene tenuta "bloccata" da tali istanze fantasma) perciò, il mio suggerimento è il seguente:

    * Riavvia il sistema (eventualmente, visto che ci sei, procedi ad un check degli aggiornamenti su "windows update", installa gli stessi e riavvia)

    * Apri la MMC relativa al backup, elimina quel job schedulato e procedi ricreando lo stesso

    * Verifica che il job funzioni correttamente

    Oltre a quanto sopra, ti consiglio caldamente la lettura di

    http://redmondmag.com/articles/2010/04/01/backup-basics-in-windows-server-2008-r2.aspx

    ed in particolare della seconda parte dell'articolo che mostra alcuni esempi di "batch" utilizzabili per avviare i backups; considera che per mia esperienza diretta, consiglio sempre di usare dei files batch schedulati al posto del "job" standard creato in automatico dato che questi ultimi sono più flessibili e che permettono anche di gestire in maniera migliore le procedure di backup

    Per ulteriori informazioni

    http://technet.microsoft.com/en-us/library/cc742083%28WS.10%29.aspx

    http://www.wbadmin.info/articles/how-does-windows-server-2008-backup-work.html

    http://maximumpcguides.com/windows-vista/schedule-a-complete-pc-backup/

    http://technet.microsoft.com/en-us/library/cc770266%28WS.10%29.aspx


    martedì 21 giugno 2011 14:57
  • Ho provato a riavviare come mi hai suggerito ma quando ho riprovato a eliminare il job mi ha dato lo stesso l'errore.

     

     

    mercoledì 22 giugno 2011 18:36
  • Ho provato a riavviare come mi hai suggerito ma
    quando ho riprovato a eliminare il job mi ha dato
    lo stesso l'errore.

    Aspetta un attimo... mi stai dicendo che hai riavviato il sistema
    e poi hai tentato di eliminare il backup job (SENZA avviarlo)
    e la cosa ha causato un errore ?

    In tal caso sarebbe utile avere dettagli relativi all'errore
    e ad eventuali messaggi presenti nell'eventlog; inoltre,
    hai letto le informazioni presenti ai vari documenti che
    ho linkato nel mio messaggio precedente ?

    giovedì 23 giugno 2011 07:18
  • Si ho riavviato e provando a eliminarlo sempre tramite la procedura descritta sopra (andando su "pianificazione guidata" e selezionando "interrompi backup") mi da sempre l'errore di prima.

    Anche se provo a modificare il job dal server manager mi da sempre l'errore snap-in.

    Per il log se mi dici dove lo trovo o come farlglielo creare te lo posto volentieri.


    giovedì 23 giugno 2011 13:03
  • Si ho riavviato e provando a eliminarlo sempre tramite la procedura descritta sopra (andando su "pianificazione guidata" e selezionando "interrompi backup") mi da sempre l'errore di prima.

    Per il log se mi dici dove lo trovo o come farlglielo creare te lo posto volentieri.

    Forse, anzi probabilmente non mi sono spiegato; non devi "interrompere" nulla, se riavvii il sistema, il backup NON dovrebbe essere in esecuzione, quindi ti basterà ELIMINARE quella voce di pianificazione ... senza dover interrompere nulla dato che NON dovrebbe essere in esecuzione (in caso contrario credo che ci siano altri problemi) e SENZA avviare il backup; a quel punto, una volta ELIMINATA la pianificazione, potrai procedere ricreando un backup job, verificando che funzioni correttamente e poi ... ricreando la pianificazione

    Ah.. e per il "log" .. mi riferivo al "log eventi" e credo dovresti sapere dove trovarlo :)

     

    giovedì 23 giugno 2011 14:02
  • Si ho capito che devo eliminare ma la voce elimina nel server manager non c'è (come puoi vedere qui:http://www.alescan.it/errori%20server/errore%20snap-in.png) ma c'è "pianificazione backup" che una volta aperto mi fa scegliere se modificare o interrompere il backup pianificato (lo chiama interrompere ma nella descrizione dice:"Interrompe definitivamente la pianificazione del backup. il disco utilizzato verrà rilasciato per il normale e utilizzo e i dati verranno mantenuti").

    Io selezioni interrompere senza aver avviato il backup (comunque se lo avvio mi da errore e si ferma subito) e mi ritorna quell'errore.

    Posto il log sotto:

    Il volume E è dove dovrebbe salvare i backup mentre per il volume G non mi interessa fare backup.

    Event[0]:
      Log Name: Microsoft-Windows-Backup
      Source: Microsoft-Windows-Backup
      Date: 2011-06-22T22:02:07.197
      Event ID: 19
      Task: N/A
      Level: Errore
      Opcode: Informazioni
      Keyword: N/A
      User: S-1-5-18
      User Name: NT AUTHORITY\SYSTEM
      Computer: WIN-FNFGOFP9VFL.EDERA.SRL
      Description:
    Tentativo di avvio dell'operazione di backup alle ore '?2011?-?06?-?22T20:02:07.182225700Z' non riuscito. Codice errore: '2155347980'. Per una soluzione esaminare i dettagli dell'evento, quindi eseguire di nuovo l'operazione di backup dopo aver risolto il problema.

    Event[1]:
      Log Name: Microsoft-Windows-Backup
      Source: Microsoft-Windows-Backup
      Date: 2011-06-22T22:02:06.355
      Event ID: 144
      Task: N/A
      Level: Informazioni
      Opcode: Informazioni
      Keyword: N/A
      User: S-1-5-18
      User Name: NT AUTHORITY\SYSTEM
      Computer: WIN-FNFGOFP9VFL.EDERA.SRL
      Description:
    È stato rilevato un nuovo volume 'G:' non presente nell'elenco di volumi da includere nel backup. Per proteggere il volume, aggiungerlo alla configurazione del backup pianificato.

    Event[2]:
      Log Name: Microsoft-Windows-Backup
      Source: Microsoft-Windows-Backup
      Date: 2011-06-22T22:02:06.355
      Event ID: 144
      Task: N/A
      Level: Informazioni
      Opcode: Informazioni
      Keyword: N/A
      User: S-1-5-18
      User Name: NT AUTHORITY\SYSTEM
      Computer: WIN-FNFGOFP9VFL.EDERA.SRL
      Description:
    È stato rilevato un nuovo volume 'E:' non presente nell'elenco di volumi da includere nel backup. Per proteggere il volume, aggiungerlo alla configurazione del backup pianificato.
    giovedì 23 giugno 2011 14:12
  • Event[0]:
      Log Name: Microsoft-Windows-Backup
      Source: Microsoft-Windows-Backup
      Date: 2011-06-22T22:02:07.197
      Event ID: 19
      Task: N/A
      Level: Errore
      Opcode: Informazioni
      Keyword: N/A
      User: S-1-5-18
      User Name: NT AUTHORITY\SYSTEM
      Computer: WIN-FNFGOFP9VFL.EDERA.SRL
      Description:
    Tentativo di avvio dell'operazione di backup alle ore
    '?2011?-?06?-?22T20:02:07.182225700Z' non riuscito. Codice errore:
    '2155347980'. Per una soluzione esaminare i dettagli dell'evento,
    quindi eseguire di nuovo l'operazione di backup dopo aver risolto il
    problema.

    Vedi http://technet.microsoft.com/en-us/library/cc734218%28WS.10%29.aspx

    giovedì 23 giugno 2011 15:19
  • Ho risolto:

    Da cmd ho dato il comando "wbadmin disable backup" e mi ha rimosso il backup schedulato.

     





    • Contrassegnato come risposta ederasrl giovedì 23 giugno 2011 21:43
    • Contrassegno come risposta annullato Edoardo BenussiMVP, Moderator venerdì 24 giugno 2011 07:55
    • Contrassegnato come risposta ederasrl venerdì 24 giugno 2011 10:30
    giovedì 23 giugno 2011 21:30
  • Ho risolto:

    Da cmd ho dato il comando "wbadmin disable backup" e mi ha rimosso il backup schedulato.


    Cioè... esattamente il comando presente nel documento "technet" che ti ho linkato

    (cfr.  http://technet.microsoft.com/en-us/library/cc734218%28WS.10%29.aspx)

     

    venerdì 24 giugno 2011 07:40
  • Lo leggi solo tu il comando wbadmin disable backup in quella pagina. Ho cercato nel sorgente e non c'è nemmeno lì.
    venerdì 24 giugno 2011 10:30
  • scusa ma una volta arrivati a wbadmin che ci vuole a trovare questa pagina

    http://technet.microsoft.com/en-us/library/cc754015(WS.10).aspx ?


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org
    venerdì 24 giugno 2011 10:36
    Moderatore
  • Si ok ma visto che è un forum, si può evitare di mettere link che rimandano a link per andare a cercare una cosa in mezzo a quel delirio di comandi.
    venerdì 24 giugno 2011 10:42
  • scusa ma una volta arrivati a wbadmin che ci vuole a trovare questa pagina

    http://technet.microsoft.com/en-us/library/cc754015(WS.10).aspx ?

    Ed in effetti il "reference" di wbadmin era tra i links presenti nel mio primo post, mentre il link all'ultimo post spiegava le cause dell'errore riscontrato fornendo (di nuovo) un riferimento a "wbadmin".

    Ad ogni modo, non credo sia necessario farne un "caso", Edo, lasciagli la sua "risposta" e fai contento il nostro "ederasrl"

    Pace & Bene :)


    venerdì 24 giugno 2011 10:43
  • Si ok ma visto che è un forum, si può evitare di mettere
    link che rimandano a link per andare a cercare una cosa
    in mezzo a quel delirio di comandi.

    E NO !! ALT !!!

    Chi risponde su questo forum lo fa su base volontaria ed
    investendo il proprio tempo, se ritieni che tale tempo non
    abbia alcun valore e che solo il TUO tempo sia importante
    ti conviene rivolgerti a qualche consulente e pagarlo per
    ottenere una bella soluzione già pronta che non ti costi
    lo sforzo di leggerti la documentazione

    Buona giornata

    venerdì 24 giugno 2011 10:50