none
Server Collegato AS400 RRS feed

  • Domanda

  • Ciao a tutti,

    ho installato un nuovo server Win 2008 R2 dove ho messo su SQL 2008 R2 per migrare un database da SQL 2000.

    Per il database tutto a posto, ora però è sorto un problema in quanto ho la necessità di connettermi ad un server AS400.

    Ho installato i driver ODBC mettendo su il client access 6.1 con l'ultima patch.

    Il server funziona ma le query danno sempre quest'errore:

    Messaggio 7399, livello 16, stato 1, riga 1
    Il provider OLE DB "MSDASQL" per il server collegato "AS400" ha segnalato un errore. Il provider ha segnalato un errore irreversibile imprevisto.
    Messaggio 7330, livello 16, stato 2, riga 1
    Impossibile recuperare una riga dal provider OLE DB "MSDASQL" per il server collegato "AS400".

     

    Ho fatto dei test su un altra macchina ma con SQL 2008 e i driver del client access 5.4 e tutto funziona tranquillamente.

    A qualcuno è capitato un errore simile?

     Raffaele


    Raffaele
    lunedì 10 gennaio 2011 09:01

Tutte le risposte

  • Ciao Raffele, a vederla così mi pare essere un bug sull'ultima versione dei driver ODBC in questione. Ti conviene rimanere sul 5.4 se ti funziona. Mai aggiornare se non ne hai realmente bisogno.

    E' probabile infatti che dipenda dal tipo di query che fai. Prova a semplificarla per capire se si tratta di un errore costante oppure se è un errore specifico alal query che stai eseguendo.

     

    Ciao,


    Adriano
    giovedì 13 gennaio 2011 13:45