none
Problema durante l'installazione di un certificato SSL (wildcard) su IIS 7 RRS feed

  • Domanda

  • Ciao,

    sto cercando di installare un certificato SSL su IIS 7, per farlo vado in "Complete Certificate Request", compilo i campi indicando dove risiede il .cer e il "Friendly name", confermo e vedo il mio certificato tra quelli elencati, ma se esco e rientro nella scheda dei certificati server il certificato non c'è più...a qualcuno è già capitato?

    Sul server il certificato era già stato installato e non sapendo dove risiede fisicamente, per poter farglielo vedere a IIS ho fatto un'esportazione da MMC del certificato e l'ho salvato, può essere questo l'errore? 

    Sul IIS c'è già un certificato, non wildcard, posso aggiungere uno nuovo wildcard, come sto facendo io?

    Grazie!

    lunedì 4 luglio 2016 10:32

Risposte

  • di solito il motivo per cui viene rimosso è connesso alle caratteristiche stesse del certificato che non è valido per espletare la funzione per cui viene richiesto.

    puoi descrivere come e da quale CA vai a richiedere il certificato ?


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org



    lunedì 4 luglio 2016 12:32
    Moderatore

Tutte le risposte

  • se il certificato l'hai già ottenuto prova a seguire qui

    https://knowledge.geotrust.com/support/knowledge-base/index?page=content&id=SO19990


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org


    lunedì 4 luglio 2016 10:38
    Moderatore
  • Ciao Edoardo,

    purtroppo il mio problema è a monte, nel senso che non riesco a caricarlo in IIS.

    La procedura che seguo è quella che ho indicato in precedenza ed è la stessa riportata nell'articolo, solo che a me il certificato non lo mantiene nella lista "Certificati Server", aggiornando la scheda il certificato viene tolto dalla lista.

    Ti faccio un'altra domanda, dove risiedono fisicamente i certificati? Non vorrei che esportarlo da MMC non vada bene e questo sia il motivo per cui dopo essere stato caricato in IIS viene rimosso.

    Grazie!

    lunedì 4 luglio 2016 10:56
  • di solito il motivo per cui viene rimosso è connesso alle caratteristiche stesse del certificato che non è valido per espletare la funzione per cui viene richiesto.

    puoi descrivere come e da quale CA vai a richiedere il certificato ?


    Edoardo Benussi
    Microsoft MVP - Enterprise Mobility
    edo[at]mvps[dot]org



    lunedì 4 luglio 2016 12:32
    Moderatore
  • Ho risolto.

    In effetti il problema era sul certificato, l'ho riscaricato da godaddy e reimpostato in IIS e adesso me lo vede correttamente per tutti i miei siti.

    Non ho capito il motivo per cui non gli piaceva, dato che dall'MMC il certificato risulta essere lo stesso.


    Grazie!

    Federico

    lunedì 4 luglio 2016 14:05
  • Ciao, ho lo stesso identico problema. Ho preso un certificato SSL standard su godaddy ma non riesco ad installarlo, in pratica "sparisce". ho provato anche a riscaricarlo. puoi darmi qualche diritta?

    Grazie

    domenica 29 ottobre 2017 23:53
  • hai provato a verificare se tra gli scopi del certificato c'è quello di webserver ?

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    e[dot]benussi[at]outlook[dot]it

    lunedì 30 ottobre 2017 08:15
    Moderatore