none
Problema Gestione Criteri di Gruppo RRS feed

  • Domanda

  • Saluto a tutti i membri della community.

    Allora ho 2 DC con Windows Server 2012, in due sedi diversi che si parlano tra di loro con una VPN Site-to-Site.

    Da qualche giorno nel DC Secondario che come DNS Primario ha l'IP dell DC Primario quando vado in:

    Strumenti di Amministrazione> Domini e Trust di Active Directory mi da il seguente errore:

    Aspetto vostra risposta, grazie in anticipo :)


    mercoledì 8 marzo 2017 08:00

Risposte

Tutte le risposte

  • Ciao, puoi eseguire e postare (in formato testo) un ipconfig /all ed un dcdiag dei due server. Inoltre verifica con net share se sono presenti le share di sistema SYSVOL e NETLOGON.

    Saluti
    Nino

    mercoledì 8 marzo 2017 11:47
    Moderatore
  • ECCO QUA

    SRVRN (DC Secondario):

    https://www.dropbox.com/s/gup1r6j9v9x2m6v/dcdiag.txt?dl=0

    https://www.dropbox.com/s/hwsz0uw45tiutj5/ipconfig.txt?dl=0

    https://www.dropbox.com/s/4ensw8ikv1b3iwt/netshare.txt?dl=0

    SRVBO (DC Primario):

    https://www.dropbox.com/s/05ca0gzfm8e76fu/dcdiag.txt?dl=0

    https://www.dropbox.com/s/ojegqh4235b6a6p/ipconfig.txt?dl=0

    https://www.dropbox.com/s/tf0qp7w4ofpxz1f/netshare.txt?dl=0

    Grazie in Anticipo :)

    giovedì 9 marzo 2017 15:13
  • Ciao Denis, il problema quasi sicuramente è dovuto alla VPN. Verifica se sono stati effettuato dei cambiamenti nelle impostazioni degli apparati di front-end oppure da parte dei Service Provider.

    [SRVBO] DsBindWithSpnEx() non riuscita. Errore 1722, Server RPC non disponibile https://support.microsoft.com/en-us/help/2102154/troubleshooting-ad-replication-error-1722-the-rpc-server-is-unavailable

    In ogni caso effettuerei anche un riavvio dei due DC.

    Già che ci sei ti consiglio di adottare la seguente configurazione IPv4 nell'ordine indicato ed eliminando gli altri valori:

    SRVBO
    Server DNS: 192.168.0.11
                       192.168.2.9
    ---
    SRVRN
    Server DNS: 192.168.2.9
                       192.168.0.11

    Saluti
    Nino

     
    giovedì 9 marzo 2017 20:37
    Moderatore
  • Ciao Nino, grazie intanto della risposta

    Allora ho impostato i DNS come descritto ma la situazione non cambia, ovvero l'errore rimane.

    Se lancio dcdiag su SRVRN ho l'errore medesimo.

    La VPN e IPSEC Site-to-Site e i server si Pingano senza problemi entrambi.

    Ho dato un'occhiata al link che mi hai mandato sul troubleshooting per risolvere l'errore, ma non e di immediato utilizzo.

    Cosa mi dici di controllare ancora?

    Grazie in anticipo :)

    domenica 12 marzo 2017 15:57
  • puoi riportare gli errori che trovi nelle sezioni system e application dei due domain controller ?

    già che ci siamo guarda anche gli eventi in Active Directory Services e NTRFS

    riporta qui source e eventid degli errori che trovi nelle sezioni indicate.


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    domenica 12 marzo 2017 17:27
    Moderatore
  • Il fatto che i server si pingano è normale. L'ICPM di solito è libero proprio per testare la connettività. Per questo ti ho chiesto di verificare se sono state apportate delle modifiche.

    Il link che ti ho proposto include una serie di verifiche che normalmente si effettuano nei casi come il tuo.

    Hai riavviato i server? Magari dopo aver preso nota degli eventi fai pulizia e riavvia i server.

    Per monitorare le repliche potresti utilizzare un apposito tool (se vuoi ti giro un link) che potrebbe darti una visione di insieme.

    Saluti
    Nino

    lunedì 13 marzo 2017 07:59
    Moderatore
  • Ciao Edoardo

    Allora Registro Eventi SRVRN:

    https://www.dropbox.com/s/s5o6805pc24g5i9/RegistoEventiSRVRN.txt?dl=0

    Registro Eventi SRVBO:

    https://www.dropbox.com/s/e7z10zoj8mrxn0v/RegistroEventiSRVBO.txt?dl=0

    Eventi AD SRVBO:

    https://www.dropbox.com/s/l0ts7wrnfmufkjy/EventiADSRVBO.JPG?dl=0

    Eventi AD SRVRN:

    https://www.dropbox.com/s/scyqq0q4lqvjhjw/Eventi%20AD%20SRVRN.jpg?dl=0

    Grazie in anticipo :)

    lunedì 13 marzo 2017 08:44
  • Ciao si I server le avevo riavviati entrambi ma il problema persisteva.

    Come faccio a fare pulizia prima di riavviare i server?

    Grazie.

    lunedì 13 marzo 2017 08:45
  • lunedì 13 marzo 2017 18:59
    Moderatore
  • Grazie Nino della Risposta,

    Allora ho pulito entrambi i Registri come mostrato da te  in fiugra e riavviato i server, ho lanciato il seguente comando dcdiag /test:dns su entrambi i DC

    SRVBO (DC Primario):

    https://www.dropbox.com/s/vfystgfr6e3ddgu/testdnssrvbo.txt?dl=0

    SRVRN (DC Secondario):

    https://www.dropbox.com/s/vhj5pwkkanyniig/testdnssrvrn.txt?dl=0

    Ho visto che da alcuni errori su record non registrati correttamente, come posso risolvere?

    Grazie in anticipo




    lunedì 13 marzo 2017 22:36
  • puoi postare un nuovo ipconfig /all e riportare gli errori presenti nei registri.

    Già che ci sei potresti indicare se il DC secondario è stato installato da poco o se sono state apportate delle modifiche all'infrastruttura?

    Prova anche una registrazione: apri un Prompt DOS con credenziali elevate (esegui come Administrator) ed esegui nltest /dsregdns
    martedì 14 marzo 2017 06:32
    Moderatore
  • Ecco qua

    IPconfig SRVBO:

    https://www.dropbox.com/s/5uqlghixhxanfhc/ipconfigSRVBO.txt?dl=0

    Errori Registro Eventi SRVBO:

    https://www.dropbox.com/s/0s37n0xow2v3hmt/RegEventiSistemaSRVBO.JPG?dl=0

    https://www.dropbox.com/s/rhu2nqzf1miqk5v/RegEventiApplicazioniSRVBO.JPG?dl=0

    Nltest SRVBO:

    https://www.dropbox.com/s/hh6g9m3e4j15eem/dsregdnsSRVBO.txt?dl=0

    IPCONFIG SRVRN:

    https://www.dropbox.com/s/wdg4bxli1p9x4aj/ipconfigSRVRN.txt?dl=0

    Errori Registro Eventi SRVRN:

    https://www.dropbox.com/s/yvgezh3tezaskeo/RegEventiApplicazioniSRVRN.JPG?dl=0

    https://www.dropbox.com/s/den5swn7ikvr4ul/RegEventiSistemaSRVRN.JPG?dl=0

    NLTEST SRVRN:

    https://www.dropbox.com/s/frlie1up0o3dp56/dsregdnsSRVRN.txt?dl=0

    :)

    martedì 14 marzo 2017 08:22
  • Allora sono stati formattati entrambi i DC, prima il Secondario e poi anche il Primario.

    Quando poi e stato formattato il PDC (SRVBO), per abassare di livello SRVRN (Il Secondario) ho dovuto spuntare ultimo controller di dominio e rimozione forzata altrimenti la procedura non andava a buon fine visto che si accorgeva di non essere l'ultimo DC del dominio TEST.LOCAL.

    Una volta fuori dal dominio ovvero come membro del gruppo di Lavoro WORKGROUP, sono stati reinstallati i ruoli DNS e Servizi di dominio Active Directory (Installato come Replica del DC SRVBO).


    martedì 14 marzo 2017 08:31

  • Quando poi e stato formattato il PDC (SRVBO), per abassare di livello SRVRN (Il Secondario) ho dovuto spuntare ultimo controller di dominio e rimozione forzata altrimenti la procedura non andava a buon fine visto che si accorgeva di non essere l'ultimo DC del dominio TEST.LOCAL.



    scusa ma, se capisco bene, qui tu hai perso definitivamente il dominio precedente e ne hai creato uno nuovo.

    era proprio quello che intendevi fare ?


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    martedì 14 marzo 2017 09:07
    Moderatore
  • Esattamente Edoardo, Prima e stato formattato il secondario e riaggiunto al DC Primario come Replica, Poi e Stato Formattato il Primario e Creata la stessa foresta precedente ovvero TEST.LOCAL.

    Successivamente ho dovuto riabbassare di livello il secondario ma per fare cio come detto prima ho spuntato l'opzione di rimozione forzata, poi rifatto il Join al Dominio e installato DNS e AD come Replica di SRVBO.


    martedì 14 marzo 2017 10:38
  • prima di formattare il primario avevi trasferito i ruoli fsmo ed era presente il global catalog sul secondario ?

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    martedì 14 marzo 2017 11:27
    Moderatore
  • Si era presente il GC anche sul Secondario, non essendo piu accessibile il Primario perche offline ho usato questa guida:

    https://www.petri.com/delete_failed_dcs_from_ad

    che mi ha aiutato a cancellare dal Secondario il PDC che non era piu raggiungibile, dopodiche ho abbassato di Livello da DC a Membro di Workgroup spuntanto l'opzione "Rimozione Forzata DC".

    Comunque sia non capisco perche la Replica non avviene e gli errori sopraelencati, visto che i DC sono stati formattati entrambi.

    Attendo Risposta, grazie :)

    martedì 14 marzo 2017 20:00
  • , dopodiche ho abbassato di Livello da DC a Membro di Workgroup spuntanto l'opzione "Rimozione Forzata DC".


    forse non mi sono spiegato bene: quando hai eseguito l'operazione quotata qui sopra di fatto hai distrutto il dominio precedente che a quel punto non esisteva più visto che non c'era più nessun dc esistente.

    ora la domanda è: hai rifatto un nuovo dominio ?


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    mercoledì 15 marzo 2017 07:58
    Moderatore
  • SI ho rifatto di nuovo il dominio con lo stesso nome foresta: TEST.LOCAL
    mercoledì 15 marzo 2017 09:01
  • Ok cosa altro devo controllare per risolvere il problema? grazie in anticipo :)
    mercoledì 15 marzo 2017 17:16
  • UPDATE:

    Stamattina ho provato a collegarmi al DC Secondario e a creare degli utenti, poi guardando subito dopo negli Utenti di Active Directory del PDC SRVBO me le sono ritrovati, quindi la replica funziona?

    Altra cosa creando dei criteri di gruppo in Strumenti di Amministrazione > Gestione Criteri di Gruppo nel Secondario anche questi dopo pochi secondi me le trovo nel Primario?

    Pero eseguendo un DCDIAG l'errore 1722 rimane, e ho provato anche a fare un DCDIAG /TEST:DNS ancora su entrami i DC vi riporto qui sotto l'output dei comandi:

    SRVBO:

    https://www.dropbox.com/s/zhc9f6chqpebaon/SRVBOTestDNS.txt?dl=0

    SRVRN:

    https://www.dropbox.com/s/9lho4t1rrizpuz8/SRVRNTestDNS.txt?dl=0

    Grazie in anticipo :), aspetto una vostra risposta in merito.

    giovedì 16 marzo 2017 08:37
  • se è così la replica funziona almeno da SRVRN a SRVBO.

    oltre a verificare se la replica funziona anche nel verso opposto, dovresti precisare nuovamente quali sono i malfunzionamenti che lamenti visto che il thread è diventato troppo lungo per rileggerlo tutto, grazie.


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    giovedì 16 marzo 2017 08:49
    Moderatore
  • Confermo che la replica funziona da entrambi i DC, ho provato ora.

    Ah questo punto rimangono gli errori 1722 RPC da DCDIAG, e se dai un'occhiata ai file che ti ho allegato nella risposta precedente in SRVBO ho svariati errori DNS.

    Da cosa dipende a questo punto l'errore 1722 RPC non disponsibile e gli errori DNS? Se la replica funziona da entrambi i DC?

    Grazie.

    giovedì 16 marzo 2017 10:26
  • puoi postare l'ipconfig /all di entrambi i domain controllers e specificare gli ip privati degli endpoint della vpn site to site

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    giovedì 16 marzo 2017 13:09
    Moderatore
  • Ecco qua:

    Ipconfig SRVBO (DC Primario):

    https://www.dropbox.com/s/h41v1wb8hh6jdzy/SRVBOIPCONFIG.txt?dl=0

    Ipconfig SRVRN (DC Secondario):

    https://www.dropbox.com/s/eohvghjhnk6lmao/SRVRNIPConfig.txt?dl=0

    IP Privati VPN Site-TO-Site

    SRVRN: 192.168.2.99 (Gateway) Gli IP sulla WAN sono IP Pubblici

    SRVBO: 192.168.0.100 (Gateway) Gli IP sulla WAN sono IP Pubblici.


    venerdì 17 marzo 2017 08:58
  • Ciao Denis, per caso questi server sono stati clonati o comunque arrivano dalla stessa immagine?

    Altra domanda, la foresta arriva da una migrazione?

    sabato 18 marzo 2017 07:00
    Moderatore
  • Ciao Nino, allora cerco di riassumere senza dilungami troppo.

    Allora prima della formattazione la foresta si chiamava uguale ad ora ovvero: TEST.LOCAL

    Poi come detto prima e stato formattato prima il DC Secondario poi successivamente anche il primario, quindi non vengono da un Ripristino di una immagine ne da una Clonazione ne da una migrazione.


    domenica 19 marzo 2017 14:17
  • Ok, alcuni degli eventi che hai postato possono essere dovuti all'utilizzo di cloni e/o tracce di migrazioni.

    Gli errori DNS sembrano essere circoscritti a SRVBO ma interessano la registrazione di SRVRNT (192.168.2.9). Apri un prompt DOS con credenziali elevate ed esegui un ipconfig /registerdns

    Saluti
    Nino


    domenica 19 marzo 2017 21:31
    Moderatore
  • Ciao Nino

    Ho eseguito i Comandi su entrambi I DC con privilegi di Amministratore.

    Allora tramite Il Registro Eventi di Windows nelle sezioni Applicazione e Sistema non rilevo errori riguardanti il DNS su entrambi i DC.

    Ma in Server Manager di SRVRN ho Questi avvisi ti allego la foto:

    https://www.dropbox.com/s/1kiwrq74a8lkwf1/DNS_SRVRN_Errori.JPG?dl=0

    Solo li mi appaio errori sempre in quella sezione sotto ServerManager>DNS in non ho Eventi.

    Attendo risposta, grazie.

    lunedì 20 marzo 2017 14:16