locked
errore msvcr80.dll ed sti RRS feed

  • Domanda

  • Ciao,

    stamattina srto riscontrando alcuni errori in windows 7 32bit  durante l'installazione di una applicazione.

    Durante l'installazione mi informa di un errore STI.

    Poi l'installazione procede ma poi durante l'uso l'applicazione (omnipage 17) si blocca e mi appare il classico "l'applicazione ha smesso di funzionare e...modulo che ha causato l'errore MSVCR80.DLL.

    Ho eseguito come amministratore regsvr32 mscvr80.dll

    ma ho ricevuto questo

    http://img534.imageshack.us/img534/1497/catturalg.jpg

    sfc/scannow non trova nessuna violazione di integrità

    Msvcr80.dll non è presente nel sistema.

    Come si risolve?

    sabato 17 aprile 2010 10:15

Risposte

  • Hai per caso un visualizzatore di Power Point o qualche altro tool che potrebbe aver modificato la dll?

    Se lo hai disinstallalo.

    Lancia:

    sfc /scannow e dai invio in un prompt dei comandi eseguito come amministratore.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    lunedì 19 aprile 2010 21:48
    Moderatore

Tutte le risposte

  • Quale "applicazione"?

    Sarà forse una versione di Office non compatibile con Windows 7 ?

    O similari?

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    sabato 17 aprile 2010 12:07
    Moderatore
  • Quale "applicazione"?

    Sarà forse una versione di Office non compatibile con Windows 7 ?

    O similari?

     

     


    Non ho indicato che si trattava di omnipage 17?

    Per altro già installata su win 7 prima della reinstallazione dello stesso

    http://italy.nuance.com/imaging/omnipage/omnipage-professional.asp

     

    sabato 17 aprile 2010 13:56
  • Segui qui:

    http://nuance.custhelp.com/app/answers/detail/a_id/5882/~/unable-to-install-omnipage-17-on-windows-7

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    sabato 17 aprile 2010 14:04
    Moderatore
  • il problema persiste
    sabato 17 aprile 2010 17:30
  • Avvio pulito :

    Digita :
    msconfig
    e dai invio nel box di ricerca del menù start.
    Vai alla sezione Avvio.
    Togli tutte le spunte meno quelle relative all'antivirus.
    Dai ok.
    Non riavviare.
    Vai alla sezione Servizi.
    Metti la spunta per nascondere tutti i servizi Microsoft.
    Disabilita tutti gli altri.
    Dai ok.
    Non riavviare.
    Vai in C:\windows\prefetch
    Cancella tutti i file (compresa la cartella ReadyBoot che verrà ricreata)
    meno il file layout.ini.
    Vai in C:\windows\temp
    Cancella tutti i file cancellabili.
    Pannello di controllo > opzioni internet , clicca su Elimina per ripulire i
    temporanei e la cronologia.
    Dai ok.
    Vuota il cestino.
    Riavvia.
    Al riavvio scarica Wise Registry Cleaner Free Portable:
    http://www.wisecleaner.com/soft/WRCFree.zip
    Lo installi.
    Metti tutte le spunte nella finestra di sinistra.
    Avvia la scansione.
    Ripara , per il momento , tutte le voci verdi.
    Riavvia e riprova.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    sabato 17 aprile 2010 17:32
    Moderatore
  • operazioni eseguite.

    Nessuna differenza tranne l'assenza dell'errore STI.

    sabato 17 aprile 2010 22:23
  • Ok.

    Ora posta esattamente l'errore relativo alla dll

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    sabato 17 aprile 2010 22:47
    Moderatore
  • Ok.

    Ora posta esattamente l'errore relativo alla dll

    Firma problema:
      Nome evento problema:    BEX
      Nome applicazione:    OmniPage17.exe
      Versione applicazione:    17.0.9261.100
      Timestamp applicazione:    4a0765ce
      Nome modulo con errori:    MSVCR80.dll
      Versione modulo con errori:    8.0.50727.4927
      Timestamp modulo con errori:    4a2752ff
      Offset eccezione:    00014c23
      Codice eccezione:    c000000d
      Dati eccezione:    00000000
      Versione SO:    6.1.7600.2.0.0.256.1
      ID impostazioni locali:    1040
      Informazioni aggiuntive 1:    e926
      Ulteriori informazioni 2:    e9263950142051511ceadcb55c0aa80c
      Ulteriori informazioni 3:    d498
      Ulteriori informazioni 4:    d4983e25d487c714ad54704f8224dcd3

    sabato 17 aprile 2010 23:03
  • Aggiornamento:

    ad una ricerca approfondita la dll MSVCR80.DLL sul sistema con win7 32 bit è presente in alcune cartelle:

    ..\\..\\winsxs\x86_microsoft.vc80.crt...2f17b

    ..\\..\\winsxs\x86_micrsoft.vc80.crt...24ad

    ..\\..\\winsxs\x86_microsoft.vc80.crt..2a985d

    ..\\..\\winsxs\x86_microsoft.vc80.crt...b8f8

    è presente anche nei driver ati

    C:\Ati\support e ..\..\programmi

    inonltre è presente come

    UL_MSVCR80.DLL. XXXXXX (seguito da numeri e lettere) in tre cartelle

    C:\Windows\ Installer\$patchcache$\managed\0000000000000....etc

     

    spero vi sia utile

    domenica 18 aprile 2010 13:58
  • Prova a copiarlo anche nella cartella di Ominpage.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    domenica 18 aprile 2010 17:21
    Moderatore
  • Prova a copiarlo anche nella cartella di Ominpage.

    Ciao

     


    copiato nella cartella principale ma l'errore rimane
    domenica 18 aprile 2010 23:30
  • Verifica se Omnipage ha anche creato una cartella in c:\utenti\tuoutente\appdata\local e copia anche lì la dll.

    Prova anche ad installare di nuovo Ominpage in un altro disco/partizione.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    lunedì 19 aprile 2010 06:29
    Moderatore
  • Verifica se Omnipage ha anche creato una cartella in c:\utenti\tuoutente\appdata\local e copia anche lì la dll.

    Prova anche ad installare di nuovo Ominpage in un altro disco/partizione.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience


    non crea nessuna cartella in c:\utenti\tuoutente\appdata\local.

    Ho provato su un'altra partizione nello stesso disco e non va neanche così

    Non so cosa fare per usare Omnipage.

    Lo sto usando sul disco che in precedenza era su un'altro pc e che poi attraverso le procedure indicate ho montato senza formattare su un nuovo pc.

    Sul vecchio pc omnipage andava bene...

    Non vorrei pronunciare la fatidica parola...

    lunedì 19 aprile 2010 10:24
  • Ma , se disinstalli completamente Omnipage , quindi clicchi destro sull'installer e scegli "esegui come amministratore" l'errore si ripresenta?

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    lunedì 19 aprile 2010 13:58
    Moderatore
  • si ripresenta
    lunedì 19 aprile 2010 21:39
  • Hai per caso un visualizzatore di Power Point o qualche altro tool che potrebbe aver modificato la dll?

    Se lo hai disinstallalo.

    Lancia:

    sfc /scannow e dai invio in un prompt dei comandi eseguito come amministratore.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    lunedì 19 aprile 2010 21:48
    Moderatore
  • Hai per caso un visualizzatore di Power Point o qualche altro tool che potrebbe aver modificato la dll?

    Se lo hai disinstallalo.

    Lancia:

    sfc /scannow e dai invio in un prompt dei comandi eseguito come amministratore.

    ehi diablo.

    Ma come hai fatto a sapere che ho un visualizzatore PPS installato?

    Ho dimenticato anche io di averlo installato altrimenti te lo avrei detto.

    Provo subito e riferisco

    martedì 20 aprile 2010 15:09
  • Disinstalla , disinstalla , disinstalla.

    E fai sapere.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    martedì 20 aprile 2010 15:53
    Moderatore
  • Bingo!!

    Problema risolto.

    Fatto come suggerito: poi riavvio.

    Rimozione di OP 17 con tool annesso.

    Riavvio e reistallo OP17: errore sparito.

    Solo errore in fase di installazione di STI che però è solo un fastidio e non pregiudica il lavoro con OP

    Penso però oltre che alla rimozione con tool annesso +pulizia con cleaner + puliazia con WCRfree va meglio.

    Ma almeno così posso usare OP 17

    Per l'errore STI penso di procedere come postato in precedenza.

    Comunque vi terrò informati

    martedì 20 aprile 2010 16:09
  • Perfetto.

    Come volevasi dimostrare era un conflitto tra files di sistema.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    martedì 20 aprile 2010 16:25
    Moderatore