none
WIN10 WIN7 problemi rete multi card RRS feed

  • Domanda

  • Salve,

    nel mio studio utilizzo una macchina principale win10 di nuova generazione insieme ad una poco precedente sulla quale gira WIN7, Entrambe pro e 64bit.

    Le macchine sono collegate ditettamente tramite una coppia di schede tp link identiche con ip dedicati: nel caso d'uso:

    192.168.2.1 e 192.168.2.2.

    La comunicazione fra la macchina WIN10 e WIN7 avviene a livello di interfaccia utente  via RDP.

    La macchina WIN7 espone un servizio di remotizzazione librerie musicali samples tramite ViennaEnsemble Pro. (VEP) (riporto per completezza) che dialoga con la macchina WIN10 tramite plugin VST istanziato nella DAW principale.

    Entrambe le macchine hanno altre schede di rete disabilitate via OS integrate nella mother board.

    Il problema che si manifesta provoca l'interruzione della comunicazione fra le macchine sia via RDP che via netBIOS (per esempio chiamato //192.168.2.x ) utilizzato per condividere contenuti e accesso al file system remoto. (copia di files etc...)

    In particolare puo' succedere che accedendo via netBios si arrivi al prompt  di autenticazione ed una volta autenticato  non si possa trafserire alcun contenuto.

    Tipicamente il blocco avviene (...ma non sempre) dopo aver abilitato sulla WIN10 una seconda scheda di rete (integrata) per mandare trasferire dati su macchine esposte verso internet nella rete domestica. (le macchine coinvolte non sono esposte su web)

    In questo caso la seconda scheda usa un 1ip 92.168.1.x quindi classe diversa.

    Il problema si persiste  anche a successivi riavvi con le sole schede TP LINK attive .

    Ho provato ad abilitare anche sulla macchina WIN7 la schede rete integrata sulla classe 192.168.1.x ed a quel punto le macchine riprendono a comunicare su questa classe di indirizzi,

    Successivamente ri-disabilitando le schede integrate 192.168.1.x  e riavviando con le sole TP LINK  192.168.2.x il problema potrebbe risolversi ma anche no e persistenre divrso tempo.

    Casualmente il problema rientra.

    Durante la fase di interruzione della comunicazione su 192,168,2,* il telnet su 3389 da entrambe le macchine da esito positivo.

    Come posso fare a capire dove stia l'anomalia e come correggerla?

    Graze

    Saluti 

    Matteo


    • Modificato mcremolini lunedì 24 dicembre 2018 23:57
    lunedì 24 dicembre 2018 17:14

Tutte le risposte

  • Sinceramente non capisco la necessità di utilizzare tutte queste schede di rete fisiche con addirittura subnet multiple. Queste configurazioni sono parecchio problematiche, soprattutto se utilizzi un dominio.
    A mio parere dovresti riprogettare l'infrastruttura di rete evitando per quanto possibile l'utilizzo di schede di rete multiple sui client (ad esempio mediante l'implementazione di VLAN), a quel punto dovresti risolvere automaticamente tutte le anomalie che hai riscontrato.
    mercoledì 26 dicembre 2018 10:37
    Moderatore
  • Do qualche informazione aggiuntiva:

    In prima istanza le macchine erano connesse via router Netgear GS108.

    Nessuno problema di rete utilizzando (all'epoca) le interfacce integrate delle schede madri

    Peccato che lo streaming audio, motivo principale dell'utilizzo di due macchine in rete nel mio studio, non era fluido e si avvertivano interruzioni randomiche; in contemporanea nei grafici di WIN10 e WIN7 delle prestazioni di rete si evidenziavano dei drop out nella trasmissione. Non ho fatto analisi con wireshark a quel tempo.

    Il prodotto software che uso per remotizzare librerie è uno standard mondiale utilizzato largamente nel mondo della produzione musicale da film (mio settore) e si chiama Vienna Ensemble Pro. (detto con acronimo VEP).

    Il supporto contattato ha risposto che il problema era nella rete e non poteva andare piu in profondita e consultare uno specialista.

    Ho sentito professionisti IT che hanno consigliato di usare schede non integrate per crescere a livello qualitativo  e connettere direttamente le macchine  senza passare dal router. Cosa fatta sia con cavo standard che cross (cat. 6 o 5p)

    Ecco perché,prima con la seconda scheda integrata nella macchina WIN10, poi con una nuova coppia di TPLInk su PCIExpress sono a descrivere il mio problema.

    Appurato che probabilmente l'interruzione del flussi dati  audio,percepito con un fastidioso rapido silenzio nel suono, potrebbe essere dovuto al router la soluzione più efficace (e che infatti ha eliminato quel problema) era  usare una connessione diretta fra le due macchine.

    Peccato che talvolta io abbia bisogno di accedere anche la rete LAN per aggiornamenti, passaggio files etc...e quindi ecco spiegato il motivo nelle due schede.

    Per completezza non sono in un dominio.

    Ringraziandoti infinitamente per il tuo intervento pongo alcune  domande:

    - Perche WIN10 (client) a valle della presenza di due schede va in panico? Perchè lo fa anche riavviando con una sola attiva? Se potessi resettare una chiave di registro o dimile il problema sarebbe gestito.

    - Una VLAN nel mio use case forse non risolve il problema. Come la implementeresti?

    - Ritornando all'origine ri-includento il router  Netgear nell'infrastruttura, cpme potrei risolvere problemi di drop del segnale. Per completezza i test che ho potuto fare, in un ping o icon utilities che simulano il trasferimento di grosis files,  non si registrano  problemi, ma essendo l'engine dedicato alla riproduzione degli stram in real time e con latenze molto basse una disomogeneità non è accettabile.

    Grazie mille

    ciao

    matteo

    mercoledì 26 dicembre 2018 21:36
  • Ciao Matteo,

    il Netgear GS108 è solo uno switch, non è un router, a cosa è connesso per distribuire ip e connettività a Internet?



    Gianni

    venerdì 28 dicembre 2018 00:59
  • Grazie per le informazioni.

    I SW che uso impongono WIN10  o WIN7 (o OSX...) quindi usare versioni LTSB sia per manutenzione che supporto non è possibile.

    Su cosa posso agire per prioritizzazione traffico?

    venerdì 28 dicembre 2018 08:32
  • Ciao Gianni,

    molto semplicemente lo switch è connesso alla rete di casa (il mio studio è in casa).

    La rete di casa a sua volta ha uno switch connesso ad una semplice vodafone station.

    *switch studio ==> macchina WIN7 + macchina WIN10 (main) + maccina OSX (vecchia solo per web) + switch casa

    **switch casa ==> vodafone station +  porte in varie stanze appartamento.

    Ieri pomeriggio ho lavorato senza problemi usando le due tplink (win7 + win10) direttamente sullo switch studio. In effetti non avevo mai provato lo switch con le due schede non integrate.

    Le macchina WIN7 e WIN10 con IP statico 192.168.1.10/11 senza gateway verso 192.168.1.1 (vodafone station).

    Non sono sicuro che non emergeranno problemi in seguito, per questo l'ideale era mantere una connessione dedicata fra le macchina WIN7 e WIN10 utilizzando on demand la possibilità di uscire su rete web.

    grazie mille

    mt

    venerdì 28 dicembre 2018 08:42
  • Se non hai un router/firewall fra gli switch e la Vodafone Station ti consiglio di mettercelo, così la subnet risulterebbe indipendente dagli umori della Vodafone Station.

    Un router con porta wan di buona qualità dovrebbe andare bene.


    Gianni

    venerdì 28 dicembre 2018 10:08
  • consigli modelli ?

    grazie mille!!!!

    venerdì 28 dicembre 2018 10:13
  • Parti da qui:

    Amazon - D-Link Wireless N Unified Services Router

    e dai un'occhiata alla sezione "Confronta con articoli simili".

    Non mi assumo responsabilità.


    Gianni

    venerdì 28 dicembre 2018 11:05
  • ok grazie
    venerdì 28 dicembre 2018 14:39
  • Secondo me sarebbe opportuno prima di tutto fare una VLAN dedicata per le due schede esterne e lasciare quelle interne  nella vlan di default con la vodafone station.
    Ti risparmi di comprare un ulteriore apparato, che introdurrebbe un minimo di latenza verso internet e sfrutteresti le caratteristiche avanzate del tuo GS108, ho visto che ne esitono 3 modelli  v1,v2,v3 ,  supportano vlan e QoS  (ho letto le specifiche solo v2 e v3), fatto ciò saresti isolato dagli umori della vodafone station e lan locale...

    Farei anche un po' di prove,  per verificare la soluzione migliore.

    Mi è capitato facendo dei test con iperf e trasferimento file,  che due schede di rete performassero molto meglio attravenso un buon switch che con collegamento diretto !!!

    Mi è capitato che con driver non aggiornatissimi alcune nic non performassero bene.

    Mi è capitato che dopo aver disabilitato il tcp offload  mi aumentasse throughput.

    Mi è capitato che modelli di schede Gbe performassero meglio di altri...

    Need recommendation for BEST 8 port Gigaswitch For VEP


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere


    venerdì 28 dicembre 2018 16:15
    Moderatore
  • Grazie Gastone per il tuo suggerimento e i preziosi link.

    Il mio GS108 è il v3. Non ho ben chiaro se posso gestire o meno QoS con questo switch.

    Per altro se raggiungo l'ip 192.168.1.1 che dovrebbe farmi accedere al pannello di cfg dello switch arrivo dritto al router di vodafone.

    In ultimo per provare a creare VLAN devo usare qualche particolare configurazione? (nn lho mai fatte )

    grazie mille

    mt

    venerdì 28 dicembre 2018 22:29
  • Ogni switch ha la sua GUI per la gestione fai riferimento al manuale

    http://www.downloads.netgear.com/files/GDC/GS105EV2/WebManagedSwitches_UM_EN.pdf

    leggi le istruzioni su  port-based vlan

    1. Crei una vlan con id e nome che non confligga con quelle predefinite  (es vlanVEPro e id 100)
    2. Collega le due schede esterne a due porte ben note (es. porta 1 e 2) e associa queste con la gui  alla tua nuova vlan.

    Con questo post abbiamo concluso, siamo già  ampiamente "fuori tema"

    Ciao Gastone


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    venerdì 28 dicembre 2018 23:19
    Moderatore
  • Grazie infinite a tutti.

    Vi tengo aggiornati sulle mie evoluzioni

    Siete stati etremamente disponibili e professionali.

    matteo

    sabato 29 dicembre 2018 08:39
  • il mio switch non consente la gestione custom vlan, è un modello unmanaged, poco male lo cambiero'.

    il mio problema originario era pero' il fatto che win10 ha difficoltà nel gestire due schede di rete.

    Nello scenario  2 nic con vlan per vep e esterna per rete produzione/web avendo cmq 2 schede simultanee non rischio di tornare al problema? 

    Grazie mille

    domenica 30 dicembre 2018 10:39