none
Allegato pdf firmato su Ipad RRS feed

  • Discussione generale

  • Salve a tutti spero possiate aiutarmi , ho un windows server 2008 con exchange 2007 sp3 , vi spiego il problema :

    Il client windows 7 e outlook 2010 invia una mail con allegato un file pdf , il destinatario riceve la mail  nella sua casella di posta in exchange scaricata tramite popcon che poi visualizza sul suo Ipad , apre il file pdf da Ipad e lo firma rispedendolo al mittente il quale riceve la mail ma senza il file allegato in outlook 2010 mentre se si collega tramite OWA il file allegato c'e' ed  si visualizza correttamente .

    p.s. : La stessa mail se viene scaricata con thunderbird il file pdf allegato all'interno arriva tranquillamente

    Qualcuno ha una spiegazione ?

    Vi ringrazio anticipatamente per la disponibilità , spero di essere stato chiaro .

    • Tipo modificato Anca Popa venerdì 12 ottobre 2012 07:23 in attesa di ulteriori feedback
    martedì 9 ottobre 2012 18:32

Tutte le risposte

  • Nel caso in cui un messaggio con codifica MIME che include un allegato inline viene recapitato in Microsoft Exchange Server e si tenta di accedere al messaggio da un client Outlook l'allegato risulta invisibile/ nascosto mentre risulta visibile da OWA.

    Se sei in questo scenario puoi risolvere il problema eseguendo da EMS il comando seguente:

    Set-OrganizationConfig - ShowInlineAttachments:$ true

    ciao


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.


    • Modificato Andreagx martedì 9 ottobre 2012 19:15
    martedì 9 ottobre 2012 19:14
  • Grazie per l'interessamento Andrea , scusami quindi devo agire dalla shell e scrivere il comando pari pari come l'hai scritto ? rischio di provocare danni ?

    Grazie ancora 

    martedì 9 ottobre 2012 20:02
  • Non rischi nulla.

    Direi che almeno un pochino di me ti puoi fidare :-)

    Ciao


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.

    martedì 9 ottobre 2012 20:22
  • Figurati Andrea mai dubitato , mi dispiace che hai frainteso  , ma sai non vorrei poi stare ore per ripristinare il tutto :-))) Grazie mille appena posso eseguo il comando e ti faccio sapere , garzie ancora buona serata .

    p.s: ultima domanda , dopo devo riavviare i servizi exchange o la modifica viene effetuato subito ?

    martedì 9 ottobre 2012 20:33
  • p.s: ultima domanda , dopo devo riavviare i servizi exchange o la modifica viene effetuato subito ?

    Ciao smelzino,

    Abbiamo ancora la tua richiesta aperta nel Forum di Exchange Server. 

    Ci sono stati sviluppi a seguito dei consigli ricevuti?

    Per quanto riguarda il riavvio, sembra che non sia necessario: 

    You cannot use an Outlook 2007 client to display or download an attachment when you access a message that includes an inline attachment from Microsoft Exchange Server 

    Grazie in anticipo di qualsiasi feedback, 

    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    giovedì 11 ottobre 2012 13:35
  • Ciao Anca , settimana prossima vado dal cliente x eseguire quest'operazione e ti faccio sapere , grazie.
    giovedì 11 ottobre 2012 13:40
  • Ciao,

    Aggiungo soltanto che gli allegati delle email ricevuti precedentemente non saranno comunque visibili.

    Alla prossima.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.

    giovedì 11 ottobre 2012 13:40
  • Aggiungo soltanto che gli allegati delle email ricevuti precedentemente non saranno comunque visibili.

    Concordo.

    Aggiornaci appena ci sono novità dal cliente.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    giovedì 11 ottobre 2012 13:44
  • Grazie Andrea buono a sapersi .
    giovedì 11 ottobre 2012 13:44
  • Buonasera Popa Anca , eccomi qua , questa sera sono andato dal cliente ed ho eseguito il comando dalla shell di exchange ma mi esce fuori quest'errore :

    Set-OrganizationConfig - ShowInlineAttachments:$ true Set-OrganizationConfig : Impossibile trovare un parametro posizionale che accet ta l'argomento '-'. In riga:1 car:23 + Set-OrganizationConfig <<<< - ShowInlineAttachments:$ true + CategoryInfo : InvalidArgument: (:) [Set-OrganizationConfig], P arameterBindingException + FullyQualifiedErrorId : PositionalParameterNotFound,Microsoft.Exchange.M anagement.SystemConfigurationTasks.SetOrganization

    Ho sbagliato quancosa ? Se ho capito bene il problema è il trattino (-) ?

    grazie per disponibilità

    mercoledì 17 ottobre 2012 19:23
  • Buonasera Popa Anca

    Buonasera smelzino,

    eccomi qua

    bentornato :-)

    questa sera sono andato dal cliente ed ho eseguito il comando dalla shell di exchange ma mi esce fuori quest'errore :

    Set-OrganizationConfig - ShowInlineAttachments:$ true Set-OrganizationConfig : Impossibile trovare un parametro posizionale che accet ta l'argomento '-'. In riga:1 car:23 + Set-OrganizationConfig <<<< - ShowInlineAttachments:$ true + CategoryInfo : InvalidArgument: (:) [Set-OrganizationConfig], P arameterBindingException + FullyQualifiedErrorId : PositionalParameterNotFound,Microsoft.Exchange.M anagement.SystemConfigurationTasks.SetOrganization

    Ho sbagliato quancosa ? Se ho capito bene il problema è il trattino (-) ?

    grazie per disponibilità

    Non so se Andrea è dello stesso opinione, ma secondo me potresti avere più successo con questo:

    set-OrganizationConfig -ShowInlineAttachments:$true

    (quindi lasciamo uno spazio vuoto prima del trattino, poi dopo il trattino non c’è più lo spazio vuoto)

    Facci sapere se funziona così,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    mercoledì 17 ottobre 2012 19:46
  • Ok provo e ti faccio sapere .

    p.s.: ma quando lancio il comando che messaggio deve escire per sapere se il comando è andato a buon fine ? 

    mercoledì 17 ottobre 2012 19:50
  • Scusami ancora , nel nuovo comando che hai postato c'e' true attaccato al $ ($true) è un'errore di battitura o devo scriverlo così ? nel  comando precedente è staccato .

    mercoledì 17 ottobre 2012 19:56
  • Scusami ancora , nel nuovo comando che hai postato c'e' true attaccato al $ ($true) è un'errore di battitura o devo scriverlo così ? nel  comando precedente è staccato .

    Proverei così:

    set-OrganizationConfig -ShowInlineAttachments:$true

    p.s.: ma quando lancio il comando che messaggio deve escire per sapere se il comando è andato a buon fine ? 

    Anche se in questo momento non ho sotto mano il server Exchange, possiamo vedere la teoria intanto:

    Cmdlet Input and Output Types

    Se la mia interpretazione di questo articolo e' corretta, allora non dovrebbe essere un output particolare. Seguendo uno screenshot simile che ho trovato in giro, potresti ricevere qualcosa tipo:

    Set-OrganizationConfig output


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    mercoledì 17 ottobre 2012 20:38
  • Ciao, utilizza la versione originale del documento http://support.microsoft.com/kb/954684/en-us?fr=1, vedrai che senza traduzione automatica il comando è corretto. Probabilmente Andrea Gallazzi non ha fatto caso all'errore (non suo...)

    Saluti

    Nino

    mercoledì 17 ottobre 2012 20:56
  • ok grazie Anca , domani mi collego in remoto al server , provo e ti faccio sapere grazie sempre per il tempo che mi stai dedicando , buonanotte.
    mercoledì 17 ottobre 2012 20:57
  • Buongiorno Anca , ho eseguito il comando e la risposta è stata come da te descritta 

    Set-OrganizationConfig output

    Adesso ho inviato mail al cliente dicendogli di provare , attendo sua risposta , ti faccio sapere appena ho risposta , buona giornata .

    giovedì 18 ottobre 2012 06:46
  • Buongiorno , grazie del consiglio Nino , buona giornata . 
    giovedì 18 ottobre 2012 06:47
  • Salve ragazzi , ho ricevuto risposta NEGATIVA da parte del cliente , gli allegati continuano a non vedersi , nella mail compare solo la graffetta ma non l'allegato , altre soluzioni ?

    Grazie a tutti x la disponibilità

    giovedì 18 ottobre 2012 08:58
  • Salve ragazzi , ho ricevuto risposta NEGATIVA da parte del cliente , gli allegati continuano a non vedersi , nella mail compare solo la graffetta ma non l'allegato , altre soluzioni ?

    Ciao smelzino,

    Mi permetto un paio di domande, per restringere il campo delle ricerche.

    1. Innanzitutto, hai modo di testare anche su una versione precedente di Outlook?

    2. Questo comportamento si verifica solo per questo caso particolare, dove il destinatario firma il file PDF e poi lo invia indietro al mittente?

    3. Puoi testare anche per altri scenari e riportare qui i risultati?

    Alcuni test suggeriti:

    * se lo invia indietro senza firmare il file?

    * se il destinatario crea una nuova mail e inserisce il file firmato? (invece di rispondere alla mail originale)

    * se il destinatario crea una nuova mail e inserisce un altro allegato (un altro file PDF oppure un file Word)?

    Intanto il suggerimento che posso lasciarti sarebbe di controllare con MFCMAPI se PR_HIDDEN_ATTACHMENT e' impostato su "True".  

    # Controllare le proprietà di un messaggio Outlook con MFCMAPI

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    venerdì 19 ottobre 2012 15:49
  • ok grazie mille Anca , provvederò a fare queste prove e ti faccio sapere , buona serata .
    venerdì 19 ottobre 2012 16:01
  • Ciao Anca , ecco cosa mi ha risposto il cliente

    Mi permetto un paio di domande, per restringere il campo delle ricerche.

    1. Innanzitutto, hai modo di testare anche su una versione precedente di Outlook?

    IN OWA L'ALLEGATO C'E' E SI VEDE REGOLARMENTE QUIBDI CREDO CHE IL PROBLEMA SIA IL CLIENT OUTLOOK 2010

    2. Questo comportamento si verifica solo per questo caso particolare, dove il destinatario firma il file PDF e poi lo invia indietro al mittente?

    PER QUESTO CASO E PER TUTTI QUELLI DOVE IL PDF VIENE MODIFICATO DA UNA APP DI IPAD (IOS6)

    3. Puoi testare anche per altri scenari e riportare qui i risultati?

    test da effettuare su account di posta configurato in outlook 2010 in locale ( file pst ) 

    Alcuni test suggeriti:

    * se lo invia indietro senza firmare il file?

    ARRIVA REGOLARMENTE

    * se il destinatario crea una nuova mail e inserisce il file firmato? (invece di rispondere alla mail originale)

    LA APP FUNZIONA PROPRIO COSI’. NON RISPONDE ALLA MAIL ORIGINALE MA ALLEGA IL FILE MODIFICATO AD UNA NUOVA MAIL.

    * se il destinatario crea una nuova mail e inserisce un altro allegato (un altro file PDF oppure un file Word)?

    ARRIVA REGOLARMENTE

    venerdì 19 ottobre 2012 19:24
  • Ciao Anca , ecco cosa mi ha risposto il cliente

    PER QUESTO CASO E PER TUTTI QUELLI DOVE IL PDF VIENE MODIFICATO DA UNA APP DI IPAD (IOS6)

    3. Puoi testare anche per altri scenari e riportare qui i risultati?

    test da effettuare su account di posta configurato in outlook 2010 in locale ( file pst ) 

    Alcuni test suggeriti:

    * se lo invia indietro senza firmare il file?

    ARRIVA REGOLARMENTE

    * se il destinatario crea una nuova mail e inserisce il file firmato? (invece di rispondere alla mail originale)

    LA APP FUNZIONA PROPRIO COSI’. NON RISPONDE ALLA MAIL ORIGINALE MA ALLEGA IL FILE MODIFICATO AD UNA NUOVA MAIL.

    * se il destinatario crea una nuova mail e inserisce un altro allegato (un altro file PDF oppure un file Word)?

    ARRIVA REGOLARMENTE

    Ciao smelzino,

    Magari per le prossime volte, riesci a ricevere risposte più centrate sul tuo scenario esponendo chiaramente tutti i dettagli.

    Visto che il comportamento si riproduce solo quando e' di mezzo questa app, IMHO non so se puoi aspettare una risoluzione qui sul forum. Comunque se dovessi proseguire con le analisi, controllerei le proprieta' dei messaggi con MFCMAPI e gli header dei messaggi in causa.

    # View the Internet header information for an email message

    Per i Mac era in giro anche questo:

    A PDF attachment from a Mac Mail client is not displayed when you use Outlook 2010 to open the email message in an Exchange Server 2007 SP3 environment

    Faci sapere com'e' andata,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    • Modificato Anca Popa martedì 19 marzo 2013 21:07 formattazione hyperlink
    lunedì 22 ottobre 2012 12:07
  • Ciao Anca , mi scuso per aver causato perdite di tempo per voi ma credevo di aver esposto bene il problema inizialmente anche perchè come si evince dal titolo avevo specificato che l'invio della mail era da Ipad e con pdf firmato . Comunque nessun problema la prossima volta cercherò di essere più preciso , adesso faccio aggiornamento con la pack 4 scaricata dal link che mi hai postato sperando di risolvere , in caso contrario seguo procedura con MFCMAPI .

    Vi faccio sapere , grazie sempre per la disponibilità.

    lunedì 22 ottobre 2012 20:15
  • Grazie a te della comprensione, il mio era solo un avviso generale siccome è sempre una buona pratica sul forum di dare tutti i dettagli necessari sull'intero scenario.

    Mi auguro che tu possa risolvere, fai sapere anche a noi com'è andata!


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    mercoledì 24 ottobre 2012 14:13
  • Scusa smelzino,

    Non abbiamo ricevuto alcun aggiornamento e mi chiedevo se possiamo aiutarti ulteriormente o se il problema è stato risolto.

    Se così fosse ti saremmo grati di condividere il tuo feedback in questo spazio
    ricordandoti che altri membri della community potrebbero riscontrare comportamenti simili.

    Grazie in anticipo della collaborazione!


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    martedì 30 ottobre 2012 10:31
  • Ciao Anca , grazie per l'interesse , il problema non è stato ancora risolto , ho installato l'aggiornamento come suggerito  ma l'allegato contiuna a non vedersi quando si invia un file pdf firmato da ipad su client con outlook 2010  . Devo fare ancora prova con MFCMAPI , credo settimana prossima riesco a fare questa prova .

    Cmq giusto per essere preciso ti confermo che l'allegato non viene visualizzato nella mail solo quando viene firmato su Ipad

    grazie ancora , ciao .

    martedì 30 ottobre 2012 11:08
  • Ciao Anca , scusa il disturbo , ma se collego il client in modalità http al server ?

    in questo modo dovrei risolvere il problema visto che in owa l'allegato si vede giusto ?

    In questa modalità posso sempre utilizzare la copia cash ?

    Grazie

    venerdì 16 novembre 2012 10:29
  • Ciao smelzino,

    Nessun disturbo, anzì nel frattempo volevo chiederti se il tuo Exchange Server 2007 è aggiornato?

    Se mi ricordo bene gli ultimi aggiornamenti, ad oggi con la versione 2007 siamo a SP3 con update rollup 8.

    Facci sapere,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 


    • Modificato Anca Popa venerdì 16 novembre 2012 11:16 add info
    venerdì 16 novembre 2012 11:10
  • Certo , sempre aggiornato , è impostato su aggiornamenti automatici .

    Riguarda la mia domanda ? E' fattibile ?

    venerdì 16 novembre 2012 11:16
  • Certo , sempre aggiornato , è impostato su aggiornamenti automatici .

    Riguarda la mia domanda ? E' fattibile ?

    Ottimo così, avevo il sospetto siccome qualche problematica simile veniva risolta con qualche update rollup.

    Riguardo la tua domanda, da quanto ho capito vorresti utilizzare Outlook Anywhere. Questa modalità è indicata per le connessioni remote (# Overview of Outlook Anywhere), e non sono a conoscenza di problematiche come la tua che siano state risolte dopo l’utilizzo di tale tipo di connessione.

    Hai letto qualche riferimento utile, forse puoi condividerlo anche qui?

    Nel frattempo se sei ancora alla ricerca di una soluzione, possiamo comparare il header di un messaggio “buono” (quando l’allegato pdf arriva regolarmente) con il header di un messaggio “rovinato” (firmato da questa app, quando l’allegato non c'è).

    View the Internet header information for an email message

    Posta qui i due header, togliendo qualsiasi informazione "privata".

    Le verifiche con MFCMAPI non hanno portato lontano?

    Non conosco iPad allora oltre al riferimento sopra (iOS 6) ti chiederei anche il nome di questa app?

    Fai sapere,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    venerdì 16 novembre 2012 13:36