none
HideCustomAction per Disalibiltare il menu Site Actions RRS feed

  • Domanda

  • Ho la necessità di nascondere il menu "site actions". Quindi ho provveduto a creare una cartella al path seguente:
    %ProgramFiles%\Common Files\Microsoft Shared\web server extensions\14\TEMPLATE\FEATURES
    Ho chiamato la cartella "MyHideAction" nella quale ho creato due file:
    Feature.xml

    <?xml version="1.0" encoding="utf-8" ?>
    < Feature xmlns="http://schemas.microsoft.com/sharepoint/"
             Title="Disabilita menu SiteActions"
             Id="D3ECF4D3-09D9-4047-9B9B-1402C6426CAE"
             Scope="Web"
             Creator="Zack"
             Description="Feature per nascondere il menu SiteActions">
        <ElementManifests>   
            <ElementManifest Location="MyHideAction.xml"/>
        </ElementManifests>
    </Feature>

    e poi ho creato il file:

    MyHideAction.xml

    <?xml version="1.0" encoding="utf-8" ?>
    <Elements xmlns="http://schemas.microsoft.com/sharepoint/">
    <HideCustomAction
       Id = "HideCreatePublishingPage" 
       GroupId = "SiteActions"
       HideActionId = "PublishingSiteActionsMenuCustomizer" 
       Location = "Microsoft.SharePoint.StandardMenu">
    </HideCustomAction>
    </Elements>
    Infine, ho provveduto ad attivare la feature seguendo questi passi da PS:
    pushd "C:\program files\common files\microsoft shared\web server extensions\14\bin"
    ./stsadm -o uninstallfeature -filename MyHideAction\feature.xml
    ./stsadm -o installfeature -filename MyHideAction\feature.xml

    Al termine dell'installazione è stato restituito il messaggio:

    Operation completed successfully.
    Quindi dal mio sito ho acceduto alla sezione Site Settings-->Manage Site Features e li ho visto che c'era la mia feature!!!
    L'ho attivata, ma purtroppo il menu Site Action è ancora li !!!

    Che cosa ho mancato/sbagliato???

    Ad ogni modo la mia versione di Sharepoint è quella del 2010.

    • Spostato Anca Popa mercoledì 6 febbraio 2013 18:46 forum piu' appropriato
    venerdì 1 febbraio 2013 13:51

Risposte

Tutte le risposte