none
Installazione Exchange 2013: errore esecuzione "$error.Clear(); RRS feed

  • Discussione generale

  • Buongiorno a tutti,

    sto installando Exchange 2013 SP1 su un server non PDC membro di un dominio funzionante.

    Mentre installa il Ruolo Cassette Postali:

    Si è verificato il seguente errore durante l'esecuzione di "$error.Clear(); 
              $maxWait = New-TimeSpan -Minutes 8
              $timeout = Get-Date;
              $timeout = $timeout.Add($maxWait);
              $currTime = Get-Date;
              $successfullySetConfigDC = $false;

              while($currTime -le $timeout)
              {
                $setSharedCDCErrors = @();
                try
                {
                  Set-SharedConfigDC -DomainController $RoleDomainController -ErrorVariable setSharedCDCErrors -ErrorAction SilentlyContinue;
                  $successfullySetConfigDC = ($setSharedCDCErrors.Count -eq 0);

                  if($successfullySetConfigDC)
                  {
                    break;
                  }
                  Write-ExchangeSetupLog -Info ("An error ocurred while setting shared config DC. Error: " + $setSharedCDCErrors[0]);
                }
                catch
                {
                  Write-ExchangeSetupLog -Info ("An exception ocurred while setting shared config DC. Exception: " + $_.Exception.Message);
                }

                Write-ExchangeSetupLog -Info ("Waiting 30 seconds before attempting again.");
                Start-Sleep -Seconds 30;
                $currTime = Get-Date;
              }

              if( -not $successfullySetConfigDC)
              {
                Write-ExchangeSetupLog -Error "Unable to set shared config DC.";
              }
            ": "Unable to set shared config DC.".

    Ho provato di tutto, tranne reinstallare Exchange dato che rifiuta di disinstallarsi finchè non completa l'intallazione (cosa ovviamente impossibile). Ho già letto un thread simile dove però il problema risultava essere l'installazione di Exch2103 su un PDC, cosa che non avviene nel mio caso. Ho letto ed eseguito alla lettera la verifica e installazione di tutti i prerequisiti, ma nulla.

    Ringrazio chiunque abbia qualcosa da suggerirmi.

    • Tipo modificato Anca Popa martedì 29 aprile 2014 06:08 in attesa di ulteriori aggiornamenti
    • Modificato Anca Popa martedì 29 aprile 2014 12:58 typo error
    martedì 22 aprile 2014 07:29

Tutte le risposte

  • Dovresti verificare il file install.log che crea lui al momento dell'installazione. Troverai sicuramente più info sull'errore.

    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP - MCSA - MCSE http://blogs.sysadmin.it/peppacci/Default.aspx

    martedì 22 aprile 2014 14:11
    Moderatore
  • Grazie per la risposta. Ho dato un'occhiata:

    [04/22/2014 15:33:02.0372] [2] An error occurred during forest discovery (cltsolutions.local).
    [04/22/2014 15:33:02.0372] [2] Ending processing Set-SharedConfigDC
    [04/22/2014 15:33:02.0388] [2] An error ocurred while setting shared config DC. Error: La chiamata al servizio di topologia di Active Directory di Microsoft Exchange sul server 'TopologyClientTcpEndpoint (localhost)' ha restituito un errore. Dettagli errore: An error occurred during forest discovery (cltsolutions.local)..
    [04/22/2014 15:33:02.0404] [2] Waiting 30 seconds before attempting again.

    A quanto pare dice di non poter accedere alla foresta. Solo che:

    - La foresta è accessibile al 100%. Gli altri server, di ruolo e non, accedono senza problemi.
    - Il DNS a cui punta è il PDC, il quale conferma di "conoscere" il mio server di Exch.
    - Il server di Exchange è membro del dominio e accede come administrator con i privilegi più alti. Da questo server posso amministrare il dominio come se fossi sul PDC.
    - Quasiasi altro programma installato su questo server accede ad AD...tutti tranne Exchange.

    martedì 22 aprile 2014 15:41
  • http://social.technet.microsoft.com/Forums/exchange/en-US/34b1c301-ad12-4655-aeea-772e70c654bc/event-id-2142-2077-2069-msexchangeadtopology-exchange-2013?forum=exchangesvradmin

    Verifica quanto dicono in questo post.


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP - MCSA - MCSE http://blogs.sysadmin.it/peppacci/Default.aspx

    mercoledì 23 aprile 2014 13:57
    Moderatore
  • Ciao Gabriele,

    Abbiamo ancora la tua richiesta aperta nel Forum di Exchange Server. 

    Ci sono stati sviluppi nel frattempo?

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    martedì 29 aprile 2014 12:58
  • Ciao, grazie per la risposta.

    Nel frattempo ho reinstallato il SO (nulla di che, essendo una VM) e seguito passo passo la guida ai requisiti.
    Sono sicuro di aver fatto tutto ma ora si persenta questo problema:

    http://social.technet.microsoft.com/Forums/it-IT/3c7cad42-1ea1-433a-a41d-b7d28e89a094/utente-administrator-non-rilevato-come-tale-da-exchange-2103-sp1?forum=exchangeit#28493800-1ffe-4758-8818-71c74875c4f5



    • Modificato GT CLT venerdì 9 maggio 2014 15:54
    venerdì 9 maggio 2014 15:51