none
db non raggiungibile RRS feed

  • Domanda

  • Ciao a tutti,
    ho un problema con una applicazione web.
    Ho un dominio registrato su   a r u b a   e un db su sql azure.

    In locale tutto funziona perché localhost raggiunge il db.
    Ma una volta messo sul server (sopra menzionato) non viene più raggiunto.
    Questo perché il server non consente connessioni fuori dalla loro rete.

    Questo non lo sapevo. Ora sono praticamente inchiodato.
    Con le store procedure e tabelle (e dati) sul db e l'applicazione che non riesce a raggiungerli.

    Chi mi consiglia una soluzione?

    grazie saluti
    martedì 6 settembre 2011 21:56

Risposte

  • ciao,

     

    l'unica soluzione possibile secondo me è creare un web service su azure che dialoga con il db... su Azure non sono tanto preparato quindi non so dirti se è possibile(ma credo proprio di si) ospitare un web service!


    Carmine Punella Blog: http://dotnetlombardia.org/b/remixx/default.aspx
    • Contrassegnato come risposta Dupko giovedì 15 settembre 2011 20:53
    mercoledì 7 settembre 2011 08:04
  • Guarda sarà una soluzione che probabilmente non funziona ma ho appena avuto un problema simile e cercando di risolvere un'altra cosa ho risolto entrambi con questo codice:

    EXEC sp_configure 'show advanced options', 1
    RECONFIGURE
    GO
    EXEC sp_configure 'Ole Automation Procedures', 1
    RECONFIGURE
    GO

    Ripeto sicuramente sbaglierò ma con me ha funzionato. Tentar non nuoce.

    • Contrassegnato come risposta Dupko giovedì 15 settembre 2011 20:53
    mercoledì 7 settembre 2011 11:44

Tutte le risposte

  • ciao,

     

    l'unica soluzione possibile secondo me è creare un web service su azure che dialoga con il db... su Azure non sono tanto preparato quindi non so dirti se è possibile(ma credo proprio di si) ospitare un web service!


    Carmine Punella Blog: http://dotnetlombardia.org/b/remixx/default.aspx
    • Contrassegnato come risposta Dupko giovedì 15 settembre 2011 20:53
    mercoledì 7 settembre 2011 08:04
  • Guarda sarà una soluzione che probabilmente non funziona ma ho appena avuto un problema simile e cercando di risolvere un'altra cosa ho risolto entrambi con questo codice:

    EXEC sp_configure 'show advanced options', 1
    RECONFIGURE
    GO
    EXEC sp_configure 'Ole Automation Procedures', 1
    RECONFIGURE
    GO

    Ripeto sicuramente sbaglierò ma con me ha funzionato. Tentar non nuoce.

    • Contrassegnato come risposta Dupko giovedì 15 settembre 2011 20:53
    mercoledì 7 settembre 2011 11:44