none
Policy su Windows Server 2008 RRS feed

  • Domanda

  • Salve, ho un server con Windows Server 2008 ed ho dato la possibilità ad alcuni utenti di avviare un gestionale in modalità RemoteApp. Fin qui tutto ok e gli utenti lavorano perfettamente.

    Per evitare però che se l'utente accede in Accesso Desktop Remoto trovi tutto il server a sua disposizione ho impostato delle Policy di restrizione sul Desktop e sulla Barra delle applicazioni. In pratica adesso se l'utente accede in Desktop Remoto vede solo lo sfondo e non ha a disposizione nulla del pulsante Start. La configurazione mi è piaciuta fino a quando non abbiamo visto che il gestionale ha iniziato ad dare degli errori di vario genere fin quando non ho riabilitato le Policy.

    Visto che con le Policy in questo caso non possono funzionare come posso fare per bloccare l'accesso in Desktop Remoto permettendo che il gestionale funzioni in RemoteApp ?

    Grazie

     

     

    martedì 3 maggio 2011 16:11

Risposte

  • Due domande:

    di quali policy parli?

    Inoltre, con le remApp l'utente non dovrebbe vedere nessun desktop ma solo la finestra del'applicazione... o mi sfugge qualcosa?

     

    In effetti non avrebbe senso utilizzare la remapp...

    Comunque puoi sempre forzare nella configurazione utente l'avvio automatico del programma.

    Saluti

    Nino


    • Modificato Anca Popa lunedì 9 maggio 2011 08:37 typo error
    • Contrassegnato come risposta Anca Popa lunedì 9 maggio 2011 08:40
    martedì 3 maggio 2011 20:30
    Moderatore
  • Fondamentalmente per abilitare RemoteApp, è necessario dare anche l'accesso RDP.

    Un trucchetto banale è fare in modo che quando l'utente effettua un logon via RDP, venga avviato "logoff.exe" in modo che il desktop non sia accessibile (l'impostazione, ovviamente, non influenza RemoteApp).

    Penso l'indicazione di Nino andasse in quella direzione :-)

    Q: How can I prevent my users from connecting to the full desktop of the server while deploying my applications through RemoteApp?


    A: This isn't really possible. If you give users access to RemoteApps, they also have access to the full desktop of the server.
    The only work-around would be to set the "Start the following program" setting to logoff.exe. This will affect Remote Desktop connections but not RemoteApps.

    http://ts.veranoest.net/ts_faq_configuration.htm#prevent_fulldesktop


    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    • Proposto come risposta Fabrizio Volpe mercoledì 4 maggio 2011 01:00
    • Contrassegnato come risposta Anca Popa lunedì 9 maggio 2011 08:40
    mercoledì 4 maggio 2011 00:56

Tutte le risposte

  • Due domande:

    di quali policy parli?

    Inoltre, con le remApp l'utente non dovrebbe vedere nessun desktop ma solo la finestra del'applicazione... o mi sfugge qualcosa?

     


    Adriano - MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]adcoop.it
    martedì 3 maggio 2011 17:39
  • Due domande:

    di quali policy parli?

    Inoltre, con le remApp l'utente non dovrebbe vedere nessun desktop ma solo la finestra del'applicazione... o mi sfugge qualcosa?

     

    In effetti non avrebbe senso utilizzare la remapp...

    Comunque puoi sempre forzare nella configurazione utente l'avvio automatico del programma.

    Saluti

    Nino


    • Modificato Anca Popa lunedì 9 maggio 2011 08:37 typo error
    • Contrassegnato come risposta Anca Popa lunedì 9 maggio 2011 08:40
    martedì 3 maggio 2011 20:30
    Moderatore
  • Fondamentalmente per abilitare RemoteApp, è necessario dare anche l'accesso RDP.

    Un trucchetto banale è fare in modo che quando l'utente effettua un logon via RDP, venga avviato "logoff.exe" in modo che il desktop non sia accessibile (l'impostazione, ovviamente, non influenza RemoteApp).

    Penso l'indicazione di Nino andasse in quella direzione :-)

    Q: How can I prevent my users from connecting to the full desktop of the server while deploying my applications through RemoteApp?


    A: This isn't really possible. If you give users access to RemoteApps, they also have access to the full desktop of the server.
    The only work-around would be to set the "Start the following program" setting to logoff.exe. This will affect Remote Desktop connections but not RemoteApps.

    http://ts.veranoest.net/ts_faq_configuration.htm#prevent_fulldesktop


    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    • Proposto come risposta Fabrizio Volpe mercoledì 4 maggio 2011 01:00
    • Contrassegnato come risposta Anca Popa lunedì 9 maggio 2011 08:40
    mercoledì 4 maggio 2011 00:56
  • Salve ragazzi, intanto grazie a tutti per le risposte datemi.

    Ricapitolo :

    L'utente lavora tranquillamente in RemoteApp perchè deve utilizzare solo una determinata procedura e niente altro quindi ha sul desktop l'icona della procedura che in maniera del tutto trasparente si connette al server ed entra direttamente in programma. Il problema è che, se l'utente decide di accedere con Desktop Remoto si trova davanti tutto il server nella sua interezza (cartelle e quant'altro). Le policy a cui mi riferisco sono le GPO per inibire Desktop e Barra delle Applicazioni.

     

    Comunque proverò la soluzione datami da Fabrizio Volpe di lanciare il "logoff.exe" all'accesso dell'utente, credo sia la più efficace.

     

    Grazie ancora

    mercoledì 11 maggio 2011 12:03
  • Utenti e Computer di Active Directory, selezioni le proprietà dell'utente e nella scheda "Ambiente" inserisci i parametri dell'applicazione che deve essere esguita in Termina Server.

     

    Saluti

    Nino

    mercoledì 11 maggio 2011 13:50
    Moderatore