none
Remote app in VPN con Windows 2008 R2 RRS feed

  • Discussione generale

  • Buongiorno a tutti,

    ho implementato una VPN IPSEC tra due sedi mediante 2 firewall Netasq. Nella sede principale vi è un server con s.o. windows 2008 R2 configurato come controller di dominio, file server e db server sybase.

    La VPN funziona veramente bene, le risposte ai ping da parte del server sono stabili e con tempi congrui. L'accesso in rdp sul server ha ottime prestazioni ed addirittura si riesce a lavorare con le share di rete presenti sul server (ovviamente sono un pò più lente e non possono essere appesantite con trasferimenti di file di grosse dimensioni, ma per il quotidiano lavoro di un ufficio in una o più cartelle condivise vanno benissimo).

    Il cliente però, ha anche la necessità di utilizzare alcuni gestionali (che vengono utilizzati normalmente in sede centrale), anche nella sede staccata. Ho provato innanzitutto ad utilizzare i software lato client residenti sui PC della sede staccata, ma le prestazioni erano veramente pessime, in quanto tali software non sono ottimizzati per l'utilizzo in ambiente VPN. Poi ho provato ad utilizzare le remote app creando una serie di file .rdp e praticamente ho risolto il problema in quanto le prestazioni sono davvero ottime. Ma ho questo problema:

    Molto spesso l'utente clicca sull'icona del file .rdp e rimane il messaggio "connessione in corso" ma l'applicazione non parte mai. Bisogna provare diverse volte, addirittura ci sono giornate in cui non partono mai. Se invece partono, allora si lavora veramente bene. Quale pensate possa essere la causa?

    Grazie

    venerdì 31 gennaio 2014 13:08

Tutte le risposte

  • E' impossibile dare delle indicazioni su una situazione di questo tipo.

    Se a volte funziona e a volte no, vuol dire che c'è qualche condizione, non permanente, che interviene.

    Io farei del troubleshooting lato firewall, analizzando i log e tracciando il traffico.

    Stessa cosa lato server, verificare event viewer.

    Roberto


    Roberto Ferazzi

    IT Consultant | Microsoft MCTS MCITP MCSA MCSE MCT | http://www.ferazzi.it

    If you found my post helpful, please give it a Helpful vote

    If it answered your question, remember to mark it as an Answer

    venerdì 31 gennaio 2014 13:31
  • Ciao, mi accodo a quello che dice Roberto per segnalarti che i gestionali che hanno db difficilmente funzionano correttamente su vpn SENZA connessioni remote desktop. Capita che il db diventi incoerente abbastanza spesso (soprattutto se sono sql), è poi il motivo per cui ancora sql non è cloudizzabile. Non ho idea di come sia il comportamento con remoteapp, non mi sono mai attentato a farlo in quanto casa madre sconsiglia vivamente (dei miei gestionali almeno). Questo per dirti che secondo me con un server rdp classico senza remote app puoi avere un compromesso valido, sicuro e probabilmente risolvi i problemi di remoteapp. In caso poi tu abbia ancora lo stesso comportamento strano allora DEVI investigare sul tunnel perchè qualcosa non va nel trasferimento protocolli.

    Ciao!

    A. 

    venerdì 31 gennaio 2014 14:08
    Moderatore
  • Buongiorno Leonardo, un paio di domande (tutte da inquadrare durante la fase in cui riscontri il problema):

    • Nessuno dei client riesce ad eseguire l'app oppure è solo un client?
    • Hai provato ad eseguire una connessine RDP pura senza app?
    • Hai verificato se il server risponde al ping?

    Se tu sei (come presumo) nella sede principale dovresti verificare se durante la fase in cui riscontri il problema ci sono delle connessioni appese in attesa di chiusura.

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.


    sabato 1 febbraio 2014 06:36
    Moderatore
  • 1) In sede staccata ci sono 2 pc. Entrambi presentano lo stesso problema. Se però riescono a partire, allora le remot app vanno davvero bene.

    2) La connessione RDP sul server ha ottime prestazioni, infatti finchè non risolvo il problema delle remote app, temporaneamente il cliente sta lavorando proprio in questo modo.

    3) La VPN funziona veramente bene, le risposte ai ping da parte del server sono stabili e con tempi congrui

    Cosa ne pensate?

    Grazie e ciao

    lunedì 3 febbraio 2014 08:08
  • Quando tenti la connessione alla Remote App, alla fine il client restituisce errore? Se si, quale?

    Eseguendo la connessione alla Remote App dalla stessa sede (senza passare dalla VPN) sono presenti gli stessi problemi?

    I client problematici che sistema operativo hanno?

    lunedì 3 febbraio 2014 10:04
    Moderatore
  • Ciao Leonardo,

    Visti i tempi trascorsi, ho evidenziato l'intervento di Roberto, pensando che possa tornare valido per molti scenari simili.

    Le domande sull'argomento rimangono ancora aperte e, se riesci a risolvere nel frattempo, ti saremmo grati di condividere la tua soluzione in questo spazio (tornera' sicuramente utile a qualcun'altro).

    Grazie a tutti della partecipazione nel Forum di Windows Server!


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    • Modificato Anca Popa lunedì 10 febbraio 2014 20:38 typo
    lunedì 10 febbraio 2014 20:38
  • Capita che il db diventi incoerente abbastanza spesso (soprattutto se sono sql), è poi il motivo per cui ancora sql non è cloudizzabile. 

    la mia piccola parte dev dissente da questa affermazione, soprattutto il finale :)

    ciao.


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    martedì 11 febbraio 2014 11:13
    Moderatore
  • allora sono rimasto indietro Edo, SQL in cloud senza cluster? Cioè io metto un server sql in cloud e lo uso come server gestionale? ma con che BMG scusa? Adesso divento curioso :-)
    martedì 11 febbraio 2014 13:09
    Moderatore
  • tu puoi avere il tuo database su SQL Azure, avere la tua web app pubblicata da un web server on premises, puoi aprire il firewall su Azure in modo che il SQL Azure diventi l'endpoint per l'iis locale e configurare la connection string in modo che la web app utilizzi il db su Azure come base di dati.

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    martedì 11 febbraio 2014 13:24
    Moderatore
  • no no, ma speta un attimo, io ho un gestionale verticale di Teamsystem, come faccio a metterlo in cloud che non posso pubblicare la web app perchè vuole il client fisico installato sulla macchina? Mica va via web...

    martedì 11 febbraio 2014 14:49
    Moderatore
  • no no, ma speta un attimo, io ho un gestionale verticale di Teamsystem, come faccio a metterlo in cloud che non posso pubblicare la web app perchè vuole il client fisico installato sulla macchina? Mica va via web...

    ma tu non hai parlato di un gestionale specifico, tu hai scritto:

    "i gestionali che hanno db difficilmente funzionano correttamente su vpn SENZA connessioni remote desktop. Capita che il db diventi incoerente abbastanza spesso (soprattutto se sono sql), è poi il motivo per cui ancora sql non è cloudizzabile."

    e per me spesso i gestionali sono ormai webapp, non client-server classici visto che quest'ultimi sono onerosi da manutenere.


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    martedì 11 febbraio 2014 14:57
    Moderatore
  • Si hai ragione, ma sai che io vivo lontano dalle dorsali :-) da me i gestionali sono al massimo in TS quando va bene ma se vuoi prestazioni elevate li hai ancora in client-server, fermo restando che gestionali web con tutte le caratteristiche del client non ne ho ancora visti perchè il limite dell'interfaccia web è proprio la mancanza di tutte le features. Quindi dove non c'è interfaccia web la vedo dura mettere in cloud un sql, per quelli invece che ce l'hanno hai pienamente ragione.

    A.

    martedì 11 febbraio 2014 15:26
    Moderatore
  • Salve a tutti, mi scuso per essermi fatto sentire dopo così tanto tempo, ma ho avuto qualche problema familiare. Nel frattempo ho affrontato altre problematiche di questo tipo ed ecco cosa è venuto fuori:

    - Non viene restituito nessun errore ma rimane la finestra della remote app in attesa di collegamento e basta.

    - anche provando in sede capita la stessa cosa

    - I client problematici hanno tutti win7 pro.

    - Non è un problema di correttezza di credenziali né di diritti utente (capita anche con utenti che hanno diritti di amministrazione)

    Cliente n.1: vi erano 2 pc collegati in vpn che lamentavano tale problema. Come ho risolto? Pianificando un riavvio automatico del server ogni sera

    Cliente n.2:anche in questo caso vi erano 2 pc collegati in vpn, uno xp e l'altro win7 pro. Ebbene, il client xp andava bene con le remote app, mentre quello win7 no. In questo caso, pur pianificando un riavvio automatico del server ogni sera, non ho risolto. In maniera random, le remote app su tale pc non vanno, poi magari il giorno dopo (come stamattina) funzionano nuovamente. Inutile dire che sono da escludere tutte le variabili relative a UAC, antivirus, firewall di Windows, ecc. In questo caso, l'utente che lavora su tale pc in questo momento utilizza una connessione rdp con un s.o. virtuale sul server stesso che funziona egregiamente. MA IL MISTERO RESTA. SECONDO ME DOVREI FARE UN UPGRADE A WIN2012 R2 PERCHE' LA MIA IMPRESSIONE E' CHE WIN2008R2 NON ABBIA CONSOLIDATO APPIENO LA TECNOLOGIA "REMOTE APP".

    VOSTRE IMPRESSIONI?

    lunedì 3 marzo 2014 14:12
  • Se riavviando funziona secondo me dovresti monitorare l'utilizzo delle risorse del server. Il gestionale si trova installato sullo stesso server?
    lunedì 3 marzo 2014 16:52
    Moderatore
  • Si, ma quello che non capisco, poiché loro più volte aprono e chiudono questi programmi, una remote app rimane in mem sul server anche dopo essere stata chiusa?
    lunedì 3 marzo 2014 17:13
  • Dipende da come è strutturata l'applicazione, in alcuni casi se numerose sessioni rimangono connesse potresti avere problemi di prestazioni. Prova intanto ad eseguire un monitoraggio così vediamo se c'è effettivamente un utilizzo eccessivo di risorse.
    lunedì 3 marzo 2014 17:48
    Moderatore
  • OK lo farò, anche se poi se fosse un problema di risorse, non mi è chiaro nel caso del cliente2, come mai il pc xp continua ad andare
    mercoledì 5 marzo 2014 08:09
  • Potrebbe trattarsi di un caso. Sei sicuro che il client Windows XP funziona sempre? Viene utilizzato con la stessa frequenza rispetto agli altri client?
    mercoledì 5 marzo 2014 10:12
    Moderatore
  • Presso il 2° cliente ha praticamente sempre funzionato
    venerdì 7 marzo 2014 13:24
  • A questo punto, se il client Windows XP funziona sempre correttamente, potrebbe trattarsi di un problema lato client. Le macchine Windows 7 sono tutte uguali? Ultimamente mi è capitato un caso di scarse prestazioni o connessioni intermittenti di rete a causa del driver di una scheda Broadcom. In tal caso prova ad aggiornare driver e/o a disabilitare le caratteristiche avanzate della scheda (a volte causano più problemi che vantaggi) come ad esempio l'interrupt moderation.

    http://technet.microsoft.com/en-us/library/jj574151.aspx

    venerdì 7 marzo 2014 13:53
    Moderatore
  • ok ci provo
    venerdì 7 marzo 2014 23:13
  • Intanto escludo problemi di risorse. Ho monitorato i server durante il verificarsi del problema: non risultava un utilizzo eccessivo di cpu e ram.
    martedì 18 marzo 2014 08:49
  • Per caso utilizzi un proxy o la connessione internet è limitata?

    Prova a leggere questa pagina:

    http://www.360ict.nl/blog/slow-startup-of-remote-applications/

    Qualcuno ha risolto problemi simili anche disabilitando il rilevamento automatico delle impostazioni e l'utilizzo del server gateway desktop remoto.

    martedì 18 marzo 2014 09:11
    Moderatore
  • Grazie, ma il server gateway desktop remoto è già disabilitato e la connessione è apprezzabile. Sapete se con win 2012 srv R2 ci sono gli stessi problemi? Grazie
    giovedì 24 luglio 2014 14:34
  • In realtà, da quanto mi risulta, il problema non dovrebbe esserci nemmeno con 2008 R2, per questo stiamo cercando le cause. Aggiornare sistema operativo (per quanto possa essere comunque consigliato) potrebbe non risolvere la situazione.

    Hai verificato anche la risoluzione DNS? Nei vari server problematici che erogano il servizio viene utilizzata sempre la stessa scheda di rete con gli stessi driver? Ad esempio con alcune configurazioni potrebbe essere necessario aggiornare i driver all'ultima release, disabilitare alcune caratteristiche avanzate o il TCP offloading(abilitato di default) per non avere problemi di prestazioni a livello di rete. La stessa problematica potrebbe inoltre anche riguardare i client oltre che il server.

    Già che ci sei verifica inoltre lato client qualsiasi software di terze parti installato che possa avere funzione di firewall o di analisi del traffico (in genere si trattano di prodotti di Internet Security).

    giovedì 24 luglio 2014 22:17
    Moderatore