none
Windows 2012 - non carica s.o. dopo restore (e neanche prima!) RRS feed

  • Domanda

  • Buongiorno, ho un server Windows 2012 che ho trovato ieri mattina bloccato entrando in ufficio, con una schermata che mi proponeva di fare il ripristino automatico all'avvio.

    (errore 0xc0000139).

    La macchina è installata da un paio di mesi e dall'installazione non era più stata toccata, e non aveva presentato problemi finora.

    Gli ho detto di procedere ma continua a proporre lo stesso errore.

    Ho ripristinato un backup bare metal (fatto col backup di Windows) fatto in precedenza, all'inizio sembrava andare, è partito Windows, ha installato degli aggiornamenti (nella schermata prima di quella di logon) e poi si è ripresentato il problema di prima.

    Se io monto il vhd di backup, vedo tutti i file, correttamente.

    Eppure la macchina continua a ridarmi lo stesso problema.

    Ho provato anche a ripristinare un backup di un giorno precedente, temendo che l'ultimo backup la macchina avesse già i problemi, ma non cambia nulla.

    Ho provato vari comandi bootrec /mbr e fixboot e rebuildbcd, dicono che viene eseguito ma non cambia nulla.

    Se invece installo sul server un win2012 vergine parte regolarmente.

    Adesso sto provando a fare un restore dopo aver ricreato anche l'unità logica dal raid, per evitare che rimanesse qualche traccia dell'installazione precedente ma sono poco fiducioso.

    Qualche consiglio?


    • Modificato rrrroberto martedì 31 marzo 2015 12:48
    martedì 31 marzo 2015 12:47

Risposte

  • Potrebbe essere un modulo di memoria come giá suggerito

    https://msdn.microsoft.com/en-us/library/windows/hardware/ff559244%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396


    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    martedì 31 marzo 2015 17:31

Tutte le risposte

  • Ciao,

    L'installazione vergine funziona anche se fai tutte le updates?

    L'errore come probabilmente avrai visto significa "Entry point not found", non trova una funzione in una dll.

    In c:\windows molto probabilmente hai un file che si chiama memory.dmp.

    Riesci a zipparlo e condividerlo? (swu Onedrive o Dropbox)


    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    martedì 31 marzo 2015 12:58
  • Ciao,

    l'installazione vergine non ho provato ad aggiornarla perché ero focalizzato solo sul tirare su il backup (che è un Exchange e ho tutti gli utenti che scalpitano).

    Sì ho visto che cos'è quell'errore ma non sono riuscito a capire da cosa dipende.
    Ho immaginato che ci entrasse con gli aggiornamenti (che sono l'unica cosa intervenuta su quella macchina).
    Ma la cosa che mi fa specie è che anche andando indietro con un backup più vecchio il problema si presenta uguale.

    Per capirci, l'ultimo backup valido che ho è di venerdì notte. Poi si è piantata la macchina.

    Se anche faccio il restore del backup di giovedì il problema si ripresenta uguale.

    Oppure, visto che quando riparte la macchina dopo il restore parte l'installazione degli aggiornamenti, esiste un modo per evitare che vengano aggiornati all'avvio?

    Adesso sta finendo un ulteriore restore.
    Se non parte ti copio il memory.dmp

    Grazie!

    martedì 31 marzo 2015 13:03
  • Ho dimenticato di chiederti se hai eseguit sfc /scannow, puoi eseguirlo anche dal command prompt di restore,

    qui dice come:

    http://www.winhelponline.com/blog/run-sfc-offline-windows-7-vista/


    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    martedì 31 marzo 2015 13:06
  • Quindi, tra l'altro, se è una dll, l'ultima possibilità che mi tenevo, cioè di fare ripartire il vhd come macchina virtuale, non è praticabile.

    Subito dopo il restore parte

    "Preparazione di Windows. Non spegnere il computer."

    E poi fa gli aggiornamenti: "Operazioni sugli aggiornamenti. Completamento operazione: xx% Non spegnere il computer"

    Non ho maniera di mandarlo in modalità provvisoria prima per non farglieli fare.


    • Modificato rrrroberto martedì 31 marzo 2015 13:13
    martedì 31 marzo 2015 13:12
  • SI ho provato a fare sfc /scannow.

    Non lo fa. Dice di riavviare il computer e lo farà al riavvio. Ovviamente dopo non lo fa.

    Ho provato anche a passargli offwindir e offbootdir ma non cambia nulla.

    martedì 31 marzo 2015 13:16
  • Se riesci a partire dal DVD e ad andare in modalita di ripristino puoi cancellare il file C:\windows\winsxs\pending.xml.

    Questa é un'operazione che MS sconsiglia, in alternativa puoi provare 

    dism.exe /image:C:\ /cleanup-image /revertpendingactions

    http://blogs.technet.com/b/joscon/archive/2009/10/15/getting-out-of-a-no-boot-situation-after-installing-updates-on-windows-7-2008r2.aspx


    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    • Contrassegnato come risposta rrrroberto martedì 31 marzo 2015 15:49
    • Contrassegno come risposta annullato NinoRCTNModerator martedì 31 marzo 2015 19:23
    martedì 31 marzo 2015 13:23
  • Allora...

    Intanto ti allego il link per il memory.dmp (fatto prima di tutti i tentativi che mi hai suggerito dopo)

    https://drive.google.com/file/d/0B44AXLqsVpFJQks5N2tMZ2RkOXc/view?usp=sharing

    (51Mb)

    Cancellato pending.xml -> non è cambiato nulla

    Eseguito dism.exe /image:F:\ /cleanup-image /revertpendingactions (f: perché quando parto da dvd mi chiama c la chiavetta usb coi driver, e f il disco c del server) -> non cambia nulla

    Però da una serie di avvisi:

    martedì 31 marzo 2015 13:50
  • Non cambia nulla nels senso che installa comunque le updates?

    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    martedì 31 marzo 2015 13:53
  • No scusa, io questo lo facevo a macchina già "danneggiata"

    Dici che lo devo fare dopo il restore prima che venga eseguita la prima volta?

    Procedo subito ad un ulteriore restore allora.

    Sei riuscito a scaricare il memory.dmp?

    Attualmente l'errore che mi da è questo:

    martedì 31 marzo 2015 13:56
  • Allora. Se entro con il prompt dei comandi subito dopo il restore, prima che riparta Windows per la prima volta:

    pending.xml non esiste

    dism.exe da lo stesso messaggio che dava la prima volta.

    provo a farlo partire e vediamo che fa...

    martedì 31 marzo 2015 14:54
  • Ho scaricato il dump ma purtroppo non mi dice molto, il thread in esecuzione al momento del crash non sembra avere caricato driver strani, il kernel e altri moduli di sistema caricati non sembrano essere stati aggiornati di recente

    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    martedì 31 marzo 2015 14:55
  • E quindi che cosa può essere che lo blocca?

    Io intanto ho riavviato dopo aver fatto

    1) restore

    2) subito dopo restore, prompt dei comandi e lanciato dism.exe (pending.xml non esisteva).

    e si comporta come al solito.

    Mi viene da piangere. Possibile che con tutti i backup che secondo il servizio di backup erano andati a buon fine non si riesca a ripristinare la macchina?

    martedì 31 marzo 2015 15:01
  • ASPETTA!

    Questa volta, dopo aver fatto la solita schermata di tentativo ripristino poi è partito regolarmente!

    Intanto ho disabilitato gli aggiornamenti automatici.

    Ora rimane da capire quale aggiornamento gli ha dato fastidio.

    martedì 31 marzo 2015 15:48
  • Ha fatto fatica ma ce l'ha fatta alla fine.

    Qual'e' stata l'ultima operazione che hai effettuato?


    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    martedì 31 marzo 2015 15:51
  • Come non detto.

    E' stato su mezz'ora.

    E poi così dal nulla è uscito:

    ipfltdrv.sys...?

    Così, mentre il server era acceso con l'utente loggato ma senza fare nulla e senza avere finestre aperte.

    martedì 31 marzo 2015 15:54
  • IP Filtering Driver (Ipfltdrv.sys)

    Il codice errore dovrebbe essere diverso


    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    martedì 31 marzo 2015 16:04
  • Esce l'errore di cui ho riportato lo screenshot.

    martedì 31 marzo 2015 16:14
  • eh..non vedo le scritte in piccolo, hai un bugcheck code ?(errore BSOD) Del tipo 0xa o simili?

    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    martedì 31 marzo 2015 16:16
  • Ah perdonami.

    non da un codice numerico. dice:

    UNEXPECTED_KERNEL_MODE_TRAP (ipdrvflt.sys)

    martedì 31 marzo 2015 16:19
  • Ho letto da qualche parte che potrebbe essere un rootkit che interferisce con ipdrvflt.sys.

    Ho scaricato il rootkit remover tool di karspersky che consigliano ma non trova nulla, quindi escluso possa essere un problema di quel tipo.

    martedì 31 marzo 2015 16:25
  • Hai comunque eseguito un'analisi completa dell'hardware (storage, RAM)?

    Anche se la macchina ha solo qualche mese è meglio non escludere alcuna ipotesi.

    martedì 31 marzo 2015 17:02
    Moderatore
  • Potrebbe essere un modulo di memoria come giá suggerito

    https://msdn.microsoft.com/en-us/library/windows/hardware/ff559244%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396


    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    martedì 31 marzo 2015 17:31