none
Impossibile connettere Client Outlook 2013 con Exchange 2013 RRS feed

  • Domanda

  • Buon giorno,

    è da due giorni che sono passato a Windows Server 2012 con Echange 2013 e l'unico problema che mi rimane è quello di configurare i client di posta elettronica (Outlook 2010 con Windows 7 e Outlook 2013 con W8).

    Infatti sia OWA che i fari SmartPhone e tablet funzionano correttamente mentre quand tento di configurare uno de due client Outlook mi viene riportato quest'errore:

    Ho già provato a guardare nel web ma senza alcun risultato....

    HELP !


    • Modificato Anca Popa venerdì 15 marzo 2013 10:36 typo
    sabato 29 dicembre 2012 12:21

Risposte

  • Io direi:

    1. Split DNS
    2. Pubblichi autodiscover sull'IP pubblico

    Però se il client è joinato al dominio e connesso ad AD dovrebbe usare il Service Connection Point (SCP) non il record DNS.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    • Contrassegnato come risposta Anca Popa venerdì 15 marzo 2013 10:34
    lunedì 7 gennaio 2013 13:36
  • In aggiunta a quanto detto da Gabriele, vale la pena di aggiungere:

    http://blogs.technet.com/b/exchdxb/archive/2012/05/10/troublshooting-autodiscover-exchange-2007-2010.aspx

    verifica l'esistenza e la correttezza dell'SCP nel tuo dominio.

    PS

    ExRCA non usa l'SCP

    PPS

    Lo split DNS comunque lo farei anche solo per dare un indirizzo unico per OWA agli utenti...

    Ciao,


    Dario Palermo

    • Contrassegnato come risposta Anca Popa venerdì 15 marzo 2013 10:35
    lunedì 7 gennaio 2013 13:47

Tutte le risposte

  • Servono maggiori informazioni... cosa hai provato a fare finora? Hai provato con diverse mailbox? I client da cui fai le prove sono domain joined?

    Ciao,


    Dario Palermo

    sabato 29 dicembre 2012 14:36
  • Ma Exchange 2013 mica è in produzione ancora, è in RTM. Hai messo su una struttura non ancora supportata...sbagli l'aggancio al server comunque, probabilmente non metti nomedominio\nomeutente nel login...bisogna vedere come hai configurato il tutto, ha ragione Dario. spero tu non l'abbia messa da un cliente comunque...perchè la rtm poi non va avanti all'infinito e se ti tocca cambiarla...

    Curiosità, ma visto che hai fatto tutto 2013 perchè non usi office 2013???

    A.

    sabato 29 dicembre 2012 15:50
    Moderatore
  • Buon giorno a tutti,

    I computer dai quali ho provato la configurazione di outlook sono domain joined e montano w8 pro ed office 2k13 e W7 pro con Office 2k10.

    L'nfrastruttura di rete è così composta:

    Server virtuale 2k12 STD (montato su Vsphere 5.0)

    Ruoli installati:

    DOMAIN SERVER;

    DHCP SERVER;

    DNS SERVER;

    VPN SERVER;

    EXCHANGE SERVER;

    FILES SERVER;

    Ci terrei a ribadire che l'infrastruttura funziona perfettamente sia da owa che da i vari dispositivvi mobili (iphone, Tablet, ecc...), durante la normale configurazione di exchange sul client outlook mi viene risolto correttamente il nome del server exchange ed anche quello dell'utente di dominio (quindi presumo non sia un problema di dns).

    Le prove che ho fatto sono state le seguenti:

    Flush DNS (senza risultato)

    Reinstallazione Outlook (senza risultato);

    Disattivazione della modalità cache in outlook (senza risultato)

    Assegnazione dell'indirizzo ip del client da dinamico a statico con l'inserimento dei dns e wins corrispondenti all'ip del server (senza risultato)

    Ho provato anche da accendere un cero a vari santi ;) (senza risultato)

    Altro non saprei...

    Grazie

    domenica 30 dicembre 2012 10:30
  • Giusto per chiarire.

    Exchange 2013 è pienamente supportato escludendo gli scenari di coesistenza aspettando rollup di 2007 e SP3 di 2010.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    domenica 30 dicembre 2012 10:56
  • Se vuoi far funzionare Outlook devi far funzionare l'autodiscover.

    Sono un po' perplesso dalla risoluzione del nome server. Con Exchange 2013 non punti a un server ma al GUID del DB dove si trova la mailbox (i.e. NomeDBconsfilzadi caratteri)

    Non è che c'è un server 2007 o 2010 ? (Qui sì non sarebbe supportato)

    Configurare Outlook a mano non è un'opzione a meno che tu non voglia metterti di buon grado a perdere 2/3 ore per client :-)

    Prova a fare un bel test con test-webservicesconnectivity per capire cosa ti restituisce l'autodiscover http://technet.microsoft.com/en-us/library/aa998328.aspx

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    domenica 30 dicembre 2012 11:05
  • Gabriele,  ma se ancora non posso comprare la licenza come fa ad essere supportato in produzione? E soprattutto come fai ad essere in regola a metterlo su ad un cliente?? Solo per capire...

    A.

    domenica 30 dicembre 2012 15:41
    Moderatore
  • Io non sono granchè in termini di licenze :-(
    La mia fortuna è che di solito se mi chiamano le licenze già ci sono :-)

    Per chi ha un abbonamento MSDN la versione RTM di Exchange 2013 con relative product key era disponibile dal 24/10/2012 ed è pienamente supportata.

    Se vado a vedere il sito del support lifecycle (http://support.microsoft.com/lifecycle/?LN=it&p1=16662&x=16&y=17) dice che l'inizio del ciclo di vita è il 09/01/2013 (e mi sa che è qui che casca l'asino per comprare le licenze) ma il supporto è già attivo.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    domenica 30 dicembre 2012 16:00
  • Io non sono granchè in termini di licenze :-(

    Ah, ok. Immaginavo. Ti illumino solo due secondi. Le sub MSDN e Technet hanno Exchange 2013 scaricabile e sicuramente il supporto per quello esiste, ma NON E' Assolutamente installabile e vendibile a terzi. Per farlo devi ACQUISTARE una licenza e rivenderla a terzi (come rivenditore intendo). Al momento Exchange 2010 è l'unico Exchange server acquistabile da MS (assurdo, c'è solo il 2012 e solo ex 2010..ma questi sono i listini). Questo vuol dire che se l'hai installato presso struttura aziendale sei fuori regola, soggetto a sanzione e se hai un problema chiamando il supporto non te lo coprono (giustamente). Sostanzialmente non hai un numero di licenza valido perchè non puoi comprarlo. Di qui la mia perplessità...best practise è comunque di NON installare mai una piattaforma nei primi 2-3 mesi di vita perchè molte problematiche derivanti dalle strutture precedenti non sono eviscerate e ti ritrovi a piedi spesso, sicuramente non prima che sia a listino..è poco professionale per un IT PRO perchè metti il cliente in situazione di "pericolo" e manco lo sa oltretutto.

    Parlo per esperienza, installai il primo 2008 server 10gg dopo la data d'uscita, piantava con la prima update il team dei nic dell'HP...ed io avevo un server HP naturalmente..nessuno lo sapeva..ma cliente bloccato. Errore mio stupido, cosa da non fare. Questa naturalmente non è una critica è come vanno fatte le cose, poi ognuno è libero e se ne vedono di tutti i colori...quando vedo gente che ha già installato dei srv 2012 uscito da un mese mi viene la pelle d'oca :-). Ciao bella gente.

    A.

    domenica 30 dicembre 2012 17:02
    Moderatore
  • Buon giorno a tutti e grazie per le risposte.

    giusto per chiarire la licenda da me utilizzata è una di quelle presenti nel pacchetto MAPS è installata presso i miei uffici con regolare product key rispettando le regole imposte da Microsoft e nnon è una versione RTM quindi non ha nessuna scadenza.

    Sperando di aver tranquillizzato quelli di voi che mi hanno scritto più preoccupati delle licenze che della questione tecnica confermo che nell'infrastruttura non è presente alcuna altra versione di exchange (2007 o 2010) e che ieri ho provato ad installare un client outlook sul server (lo so non si fa ma vi pregherei di non soffermarvi su questo) e il tutto funziona.

    Giunto a questo punto vi chiedo se qualcuno può darmi una mano tralasciando i "moralismi tecnici" e concentrandosi sull'aspetto tecnico perchè girando nei vari forum ho notato che non è un problema isolato.

    Grazie e buon anno,

    Gabriele.

    lunedì 31 dicembre 2012 08:44
  • Se vuoi far funzionare Outlook devi far funzionare l'autodiscover.

    Sono un po' perplesso dalla risoluzione del nome server. Con Exchange 2013 non punti a un server ma al GUID del DB dove si trova la mailbox (i.e. NomeDBconsfilzadi caratteri)

    Non è che c'è un server 2007 o 2010 ? (Qui sì non sarebbe supportato)

    Configurare Outlook a mano non è un'opzione a meno che tu non voglia metterti di buon grado a perdere 2/3 ore per client :-)

    Prova a fare un bel test con test-webservicesconnectivity per capire cosa ti restituisce l'autodiscover http://technet.microsoft.com/en-us/library/aa998328.aspx

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    Grazie Gabriele,

    tra oggi e martedì provo a fare il test che mi hai indicato e poi ti faccio sapere.

    lunedì 31 dicembre 2012 08:46
  • giusto per chiarire la licenda da me utilizzata è una di quelle presenti nel pacchetto MAPS è installata presso i miei uffici con regolare product key rispettando le regole imposte da Microsoft e nnon è una versione RTM quindi non ha nessuna scadenza.

    Sperando di aver tranquillizzato quelli di voi che mi hanno scritto.....

    Ciao Gabriele, non per fare il guastafeste ma ti riporto un trafiletto preso proprio dal Partner Network

    "Individua le licenze software a tua disposizione in qualità di membro del Microsoft Action Pack Solution Provider. Queste licenze software possono essere utilizzate solo nella sede centrale della tua azienda e solo per scopi aziendali, per condurre dimostrazioni ai clienti, per la formazione dei dipendenti e per lo sviluppo ed il testing di applicazioni. Tali licenze, fornite per le versioni più recenti del software Microsoft, non possono essere utilizzate per attività volte a generare direttamente profitti (come hosting di siti Web o posta elettronica o sviluppo di soluzioni personalizzate dietro compenso economico). Inoltre non possono essere rivendute o utilizzate per fini personali."

    Saluti

    Nino

    martedì 1 gennaio 2013 18:25
  • Ciao Nino,

    Giusto per sicurezza.

    Ti riferisci a me o a BG-TECH ?

    Io parlavo solo di supporto.
    Dei vari tipi di licenze non so nulla :-)

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    martedì 1 gennaio 2013 19:43
  • Ciao Gabriele Tansini, ho riportato la citazione di BG-TECH proprio per evitare ecquivoci :)

    Saluti

    Nino

    martedì 1 gennaio 2013 19:52
  • giusto per chiarire la licenda da me utilizzata è una di quelle presenti nel pacchetto MAPS è installata presso i miei uffici con regolare product key rispettando le regole imposte da Microsoft e nnon è una versione RTM quindi non ha nessuna scadenza.

    Sperando di aver tranquillizzato quelli di voi che mi hanno scritto.....

    Ciao Gabriele, non per fare il guastafeste ma ti riporto un trafiletto preso proprio dal Partner Network

    "Individua le licenze software a tua disposizione in qualità di membro del Microsoft Action Pack Solution Provider. Queste licenze software possono essere utilizzate solo nella sede centrale della tua azienda e solo per scopi aziendali, per condurre dimostrazioni ai clienti, per la formazione dei dipendenti e per lo sviluppo ed il testing di applicazioni. Tali licenze, fornite per le versioni più recenti del software Microsoft, non possono essere utilizzate per attività volte a generare direttamente profitti (come hosting di siti Web o posta elettronica o sviluppo di soluzioni personalizzate dietro compenso economico). Inoltre non possono essere rivendute o utilizzate per fini personali."

    Saluti

    Nino

    Ciao Nino,

    grazie per le delucidazioni ma, ribadendo che nessuno mi paga per il lavoro che stò svolgendo con i MIEI server nella sede centrale della MIA AZIENDA, vorrei chiedervi una mano per la risoluzione tecnica della faccenda.

    Ribadisco a tutti che sono PIENAMENTE IN REGOLA CON LE LICENZE, CHE NON HO VENDUTO O RIVENDUTO I O IL PACCHETTO SOFTWARE IN OGGETTO A NESSUNO, CHE NESSUNO MI STA PAGANDO PER IL LAVORO CHE STO' FACENDO E CHE PER TESTARE I PRODOTTI MICROSOFT CHE APPENA DISPONIBILI ANDRO' A RIVENDERE/CONFIGURARE HO NECESSITA' DI RISOLVERE LA PROBLEMATICA CHE VI HO DESCRITTO.

    Posto questa premessa vi chiedo una mano PURAMENTE TECNICA tralasciando il Licensing che vi assicuro essere più che in regola.

    Grazie, Gabriele (BG-TECH).

    mercoledì 2 gennaio 2013 13:01
  • Se vuoi far funzionare Outlook devi far funzionare l'autodiscover.

    Sono un po' perplesso dalla risoluzione del nome server. Con Exchange 2013 non punti a un server ma al GUID del DB dove si trova la mailbox (i.e. NomeDBconsfilzadi caratteri)

    Non è che c'è un server 2007 o 2010 ? (Qui sì non sarebbe supportato)

    Configurare Outlook a mano non è un'opzione a meno che tu non voglia metterti di buon grado a perdere 2/3 ore per client :-)

    Prova a fare un bel test con test-webservicesconnectivity per capire cosa ti restituisce l'autodiscover http://technet.microsoft.com/en-us/library/aa998328.aspx

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    Grazie Gabriele,

    tra oggi e martedì provo a fare il test che mi hai indicato e poi ti faccio sapere.

    Cia Gabriele,

    purtroppo oggi non sono ancora riuscito a fare i Test che mi hai indicato ma domani dovrei avere un attimo di tempo e ci provo.

    Appena ho novità ti faccio sapere.

    Grazie per la collaborazione dimostrata fin ora,

    Gabriele (BG-TECH)

    mercoledì 2 gennaio 2013 13:03
  • Scusa Gabriele,

    Abbiamo ancora la tua richiesta aperta nel Forum di Exchange Server. 

    Ci sono stati sviluppi nel frattempo?

    Grazie in anticipo di tenerci aggiornati sul tuo percorso!


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    lunedì 7 gennaio 2013 10:41
  • Ciao Anca,

    si purtroppo il problema persiste ma credo di aver fatto un passo in avanti identificando la causa (credo) primaria del "non funzionamento" dei client Outlook: i DNS.

    Infatti quando il client Outlook cerca di prendere la configurazione automatica dell'indirizzo XXX@bg-tech.eu configurato per l'account aziendale Pippo@yyy.local in automatico risolve il dns del dominio .bg-tech.eu andando a puntare all'indirizzo pubblico del provider invece che al server Exchange...

    HELP ! Non c'è qualche anima pia che riesca a darmi una mano perché è vero che da OWA vedo perfettamente tutto e tutto funziona ma avendo Outlook ....

    Di seguito riporto il report d'errori generato dalla diagnosi dello strumento:

    Sincronizzazione, notifica, disponibilità e risposte automatiche (Fuori sede) di Servizi Web Exchange.
     Non tutte le prove di attività dei servizi Web di Exchange sono state completate.
     
    Passi della prova
     
    ExRCA sta tentando di verificare il servizio di individuazione automatica per XXXX@bg-tech.eu.
     Verifica individuazione automatica non riuscita.
     
    Passi della prova
     
    Tentativo di contattare il servizio di individuazione automatica con ciascun metodo in corso.
     Impossibile contattare il servizio di individuazione automatica tramite qualsiasi metodo.
     
    Passi della prova
     
    Tentativo di verifica di un eventuale URL di individuazione automatica https://bg-tech.eu/AutoDiscover/AutoDiscover.xml in corso
     Impossibile verificare questo potenziale URL di individuazione automatica.
     
    Passi della prova
     
    Attempting to resolve the host name bg-tech.eu in DNS.
     The host name resolved successfully.
     
    Dettagli aggiuntivi
     IP addresses returned: 81.31.155.67 (provider esterno di servizi presso il quale faccio un popConnector)


    Testing TCP port 443 on host bg-tech.eu to ensure it's listening and open.
     The port was opened successfully.

    Testing the SSL certificate to make sure it's valid.
     The SSL certificate failed one or more certificate validation checks.
     
    Passi della prova
     
    ExRCA is attempting to obtain the SSL certificate from remote server bg-tech.eu on port 443.
     ExRCA successfully obtained the remote SSL certificate.
     
    Dettagli aggiuntivi
     Remote Certificate Subject: E=webmaster@localhost, CN=localhost, OU=none, O=none, L=Sometown, S=Someprovince, C=US, Issuer: E=webmaster@localhost, CN=localhost, OU=none, O=none, L=Sometown, S=Someprovince, C=US.


    Validating the certificate name.
     Certificate name validation failed.
      Ulteriori informazioni su questo problema e su come risolverlo
     
    Dettagli aggiuntivi
     Host name bg-tech.eu doesn't match any name found on the server certificate E=webmaster@localhost, CN=localhost, OU=none, O=none, L=Sometown, S=Someprovince, C=US.

     
    Tentativo di verifica di un eventuale URL di individuazione automatica https://autodiscover.bg-tech.eu/AutoDiscover/AutoDiscover.xml in corso
     Impossibile verificare questo potenziale URL di individuazione automatica.
     
    Passi della prova
     
    Attempting to resolve the host name autodiscover.bg-tech.eu in DNS.
     The host name resolved successfully.
     
    Dettagli aggiuntivi
     IP addresses returned: 81.31.155.67 (provider esterno di servizi presso il quale faccio un popConnector)


    Testing TCP port 443 on host autodiscover.bg-tech.eu to ensure it's listening and open.
     The port was opened successfully.

    Testing the SSL certificate to make sure it's valid.
     The SSL certificate failed one or more certificate validation checks.
     
    Passi della prova
     
    ExRCA is attempting to obtain the SSL certificate from remote server autodiscover.bg-tech.eu on port 443.
     ExRCA successfully obtained the remote SSL certificate.
     
    Dettagli aggiuntivi
     Remote Certificate Subject: E=webmaster@localhost, CN=localhost, OU=none, O=none, L=Sometown, S=Someprovince, C=US, Issuer: E=webmaster@localhost, CN=localhost, OU=none, O=none, L=Sometown, S=Someprovince, C=US.


    Validating the certificate name.
     Certificate name validation failed.
      Ulteriori informazioni su questo problema e su come risolverlo
     
    Dettagli aggiuntivi
     Host name autodiscover.bg-tech.eu doesn't match any name found on the server certificate E=webmaster@localhost, CN=localhost, OU=none, O=none, L=Sometown, S=Someprovince, C=US.

     
    Tentativo di contattare il servizio di individuazione automatica tramite il metodo di reindirizzamento HTTP in corso.
     Il tentativo di contattare l'individuazione automatica mediante il metodo di reindirizzamento HTTP non è riuscito.
     
    Passi della prova
     
    Attempting to resolve the host name autodiscover.bg-tech.eu in DNS.
     The host name resolved successfully.
     
    Dettagli aggiuntivi
     IP addresses returned: 81.31.155.67 (provider esterno di servizi presso il quale faccio un popConnector)


    Testing TCP port 80 on host autodiscover.bg-tech.eu to ensure it's listening and open.
     The port was opened successfully.

    ExRCA sta verificando l'individuazione automatica host. bg-tech.eu per un reindirizzamento HTTP al servizio di individuazione automatica.
     ExRCA non è stato in grado di ottenere una risposta di reindirizzamento HTTP per l'individuazione automatica.
     
    Dettagli aggiuntivi
     Si è verificata un'eccezione Web in quanto è stata ricevuta una risposta HTTP 404 - NotFound da Unknown.

     


    Tentativo di contattare il servizio di individuazione automatica tramite il metodo di reindirizzamento DNS SRV in corso.
     ExRCA non è stato in grado di contattare il servizio di individuazione automatica utilizzando il metodo di reindirizzamento DNS SRV.
     
    Passi della prova
    Tentativo di individuazione del record SRV _autodiscover._tcp.bg-tech.eu in DNS in corso.
    Impossibile trovare il record SRV di individuazione automatica in DNS.
    Ulteriori informazioni su questo problema e su come risolverlo

     
    lunedì 7 gennaio 2013 13:23
  • Io direi:

    1. Split DNS
    2. Pubblichi autodiscover sull'IP pubblico

    Però se il client è joinato al dominio e connesso ad AD dovrebbe usare il Service Connection Point (SCP) non il record DNS.

    Ciao
    Gabriele


    -- Gabriele Tansini [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights"

    • Contrassegnato come risposta Anca Popa venerdì 15 marzo 2013 10:34
    lunedì 7 gennaio 2013 13:36
  • In aggiunta a quanto detto da Gabriele, vale la pena di aggiungere:

    http://blogs.technet.com/b/exchdxb/archive/2012/05/10/troublshooting-autodiscover-exchange-2007-2010.aspx

    verifica l'esistenza e la correttezza dell'SCP nel tuo dominio.

    PS

    ExRCA non usa l'SCP

    PPS

    Lo split DNS comunque lo farei anche solo per dare un indirizzo unico per OWA agli utenti...

    Ciao,


    Dario Palermo

    • Contrassegnato come risposta Anca Popa venerdì 15 marzo 2013 10:35
    lunedì 7 gennaio 2013 13:47