none
Firewall Windows 2008R2 Standard SP1 non parte dopo modifica GPO RRS feed

  • Domanda

  • Ho tre macchine con installato Windows 2008 R2 SP1 che si sono riavviate dopo una modifica delle GPO ed il servizio Windows Firewall non parte più.

    Le macchine accedono alla rete, ma dall’esterno tutte le connessioni vengono bloccate, quindi condivisioni varie, il Desktop remoto, ma anche un semplice ping.

    Il problema è nato dopo che ho modificato  la Default Domain Policy nella Gestione Criteri di Gruppo.

    In particolare ho:

    -Definito due porte come eccezioni locali

    -Attivato l’esecuzione degli script Windows Powershell

    -Attivato la Gestione remota di Windows con definiti gli indirizzi 192.168.108.35,192.168.114.35 che hanno generato l’errore nello screenshoot

    Il risultato è stato che su tutte le macchine riavviate non funziona più Windows firewall.

    Ho rimesso tutto a posto, ma il firewall continua a non funzionare (errore 87 in evento 7024 con dettaglio “parametro non corretto”).

    Allego gli screenshoot. Mi basterebbe almeno riuscire a riabilitare la rete sulle macchine.

    Ho controllato i permessi sulle chiavi di registro, le dipendenze, i privilegi dell'account "Servizio locale" come descritto in http://blogs.technet.com/b/networking/archive/tags/windows+firewall/

    Un aiuto in questa situazione tragica sarebbe molto apprezzato

    Michele Amoruso


    venerdì 13 luglio 2012 14:24

Risposte

  • Grazie a tutti, ho risolto, non so bene quale policy di dominio aveva abilitato su tutte le connessioni di rete, l'autenticazione 802.1x . Una volta disabilitata, il firewall è ripartito e così la rete.

    Grazie ancora,

    Michele Amoruso

    lunedì 16 luglio 2012 15:31

Tutte le risposte

  • che ruoli hanno queste tre macchine ?

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    venerdì 13 luglio 2012 15:05
    Moderatore
  • Mi corregga Michele se sbaglio, ma essendo a conoscenza del problema, aggiungo che si tratta di un controller di dominio e di due server membri.

    marco

    venerdì 13 luglio 2012 18:06
  • E' stata ripristinata anche la Default Domain Policy attraverso dcgpofix?

    Dopo il ripristino della GPO è stata forzata l'applicazione ma Windows Firewall continua a non avviarsi? Se si, hai provato ad eseguire anche i controlli descritti in questa discussione?

    http://social.technet.microsoft.com/Forums/en/w7itprosecurity/thread/a716ef68-0a11-48b6-9b7f-2a8f95fe60af

    domenica 15 luglio 2012 09:28
    Moderatore
  • Grazie Fabrizio, il ripristino tramite dcgpofix è una delle prove in programma.
    Proviamo ad applicarla e vediamo cosa succede.

    marco

    domenica 15 luglio 2012 11:53
  • la scrittura delle domain policies sui clients obbliga, quando si vuole tornare indietro a scrivere delle policies che impongono ai clients di fare l'esatto contrario della prima policy applicata. il ritornare al default non serve a nulla perchè mette le policies in stato undefined che di fatto non modifica nulla.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    domenica 15 luglio 2012 13:21
    Moderatore
  • comincia col riportare ad un punto di ripristino i due file servers poi vediamo il da farsi sul domain controller.

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    domenica 15 luglio 2012 13:22
    Moderatore
  • purtroppo non c'è un salvataggio eseguito con il backup nativo di windows server 2008 ma con prodotto di terze parti.
    Se scolleghiamo uno dei file server dalla rete e proviamo il ripristino delle policy con DCGPOFIX? Non ne usciamo comunque?
    Almeno per vedere se il firewall riparte. In questo modo, questi server sono praticamente isolati dal resto del mondo.
    Tutto è nato con quella modifica alle policy. Possibile non si possa tornare indietro?!

    marco

    domenica 15 luglio 2012 13:55
  • Confermo quanto dice Edoardo Benussi, probabilmente il problema non si risolverà automaticamente sui client (come avevo sottointeso nella mia risposta precedente), per questo secondo me dovresti per prima cosa eseguire il ripristino delle domain policies per impedire l'applicazione del criterio problematico e poi provare a seguire i suggerimenti contenuti nella discussione che ti ho inserito precedentemente su un client per vedere se si riesce a recuperare il firewall. Poi una volta trovato il problema si può provare ad automatizzare la procedura di ripristino dei client in altro modo.
    domenica 15 luglio 2012 17:19
    Moderatore
  • Aggiungo un link (spero che possa aiutare) da utilizzare dopo aver inibito o corretto la parte della "domain policy" che modifica il FW

    Restore Windows Firewall Default Settings  http://technet.microsoft.com/en-us/library/cc775896(v=ws.10).aspx


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito (non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili . GRAZIE!

    domenica 15 luglio 2012 22:21
    Moderatore
  • Grazie a tutti, ho risolto, non so bene quale policy di dominio aveva abilitato su tutte le connessioni di rete, l'autenticazione 802.1x . Una volta disabilitata, il firewall è ripartito e così la rete.

    Grazie ancora,

    Michele Amoruso

    lunedì 16 luglio 2012 15:31
  • non giocherellare con le domain policies... ci si scotta :)

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    lunedì 16 luglio 2012 16:01
    Moderatore
  • Questa esperienza mi ha insegnato proprio questo :)

    lunedì 16 luglio 2012 19:57