none
Integration Services per VM 2k8 su host 2016 ??

    Domanda

  • Ho importato una VM 2K8R2, che girava su di un host Hyper-V anche lui 2K8, sotto un nuovo host Hyper-V 2016.

    Il software di backup dell'host, mi segnala che il backup di quella VM non è consistent per qualche problema legato al VSS

    Lato host, ho verificato che gli integration services siano abilitati sulla VM e, in teoria, è tutto a posto.

    Leggendo qua e la, mi sembra di aver capito che dovrei aggiornare gli integration services sulla vm guest 2k8 ma non so da dove scaricarli.

    Potete darmi una mano ?

    Grazie

    lunedì 18 marzo 2019 11:20

Risposte

  • Dall'interno della VM avvia un prompt come amministratore ed esegui:
    REG QUERY "HKLM\Software\Microsoft\Virtual Machine\Auto" /v IntegrationServicesVersion

    Se ti dice che non trova la chiave i servizi sono sicuramente da aggiornare, in caso contrario il valore deve avere all'inizio almeno i numeri 6.3.9600.
    Ti consiglio anche la lettura di questa pagina che approfondisce l'aspetto della ricezione degli aggiornamenti tramite Windows Update:
    https://rlevchenko.com/2017/02/18/faq-windows-server-2016-and-hyper-v-integration-services/

    • Contrassegnato come risposta Aldo_ martedì 19 marzo 2019 00:26
    • Contrassegno come risposta annullato Aldo_ martedì 19 marzo 2019 00:26
    • Contrassegnato come risposta Aldo_ martedì 19 marzo 2019 01:02
    lunedì 18 marzo 2019 21:40
    Moderatore

Tutte le risposte

  • L'aggiornamento dei componenti di integrazione solitamente viene fornito direttamente da Windows Update, solo però se viene eseguita la ricerca di aggiornamenti dopo aver abilitato nella VM il servizio di integrazione "Scambio dati".
    In alternativa è possibile eseguire il download da qui:
    https://support.microsoft.com/it-it/help/3071740/hyper-v-integration-components-update-for-windows-virtual-machines-tha

    Nel tuo caso dovresti far riferimento a Windows 7 x64.

    lunedì 18 marzo 2019 11:52
    Moderatore
  • Ciao Fabrizio.

    Ho controllato e il servizio di cui parli è presente e avviato.

    Ho notato anche che il file cab dell'update risale al 2015 quindi, in teoria, la VM dovrebbe essere aggiornata.

    Come faccio a sapere quale versione degli integration services è installata e se è compatibile con l'host 2016 ?

    Grazie

    lunedì 18 marzo 2019 15:21
  • Dall'interno della VM avvia un prompt come amministratore ed esegui:
    REG QUERY "HKLM\Software\Microsoft\Virtual Machine\Auto" /v IntegrationServicesVersion

    Se ti dice che non trova la chiave i servizi sono sicuramente da aggiornare, in caso contrario il valore deve avere all'inizio almeno i numeri 6.3.9600.
    Ti consiglio anche la lettura di questa pagina che approfondisce l'aspetto della ricezione degli aggiornamenti tramite Windows Update:
    https://rlevchenko.com/2017/02/18/faq-windows-server-2016-and-hyper-v-integration-services/

    • Contrassegnato come risposta Aldo_ martedì 19 marzo 2019 00:26
    • Contrassegno come risposta annullato Aldo_ martedì 19 marzo 2019 00:26
    • Contrassegnato come risposta Aldo_ martedì 19 marzo 2019 01:02
    lunedì 18 marzo 2019 21:40
    Moderatore
  • Grazie per la segnalazione e le istruzioni.

    Utilizzando il comando che mi hai indicato, ho rilevato una versione non aggiornata degli IS.

    Ho quindi scaricato la iso degli IS indicata nell'articolo e poi ho lanciato windows update per fargli scaricare l'ultima versione disponibile per 2008R2

    Ho riavviato il server e tutto sembra funzionare perfettamente.

    Grazie per le dritte e spero che questa discussione possa servire anche ad altri.

    martedì 19 marzo 2019 01:02