none
Exchange 2003 non risulta installato in Windows 2003 SBS RRS feed

  • Domanda

  • Nonostante sia stata eseguita la procedura automatizzata per l'installazione di SBS 2003, al termine della quale è risultato un errore finale su Microsoft Fax Server, che all'apparenza sembrava banale. Dopo aver configurato tutti gli utenti di Active Directory e le cassette postali di Exchange Server 2003, si è provveduto ad eseguire gli aggiornamenti del sistema, ma quando si è tentato di installare la service pack 2 di Microsoft Exchange è comparso un errore con una dicitura: "Microsoft Exchange 2003 non è installato!".  Il problema potrebbe apparire relativamente insignificante, se non fosse che il server in questione è il DC di una rete su cui sono state eseguite le migrazioni di tutte le mail aziendali e di alcuni database gestionali. Avete idea di come venir fuori da un simile impiccio?
    lunedì 27 giugno 2011 19:40

Risposte

  • Grazie per la segnalazione, diciamo che è giunta non tempestiva, perchè nel frattempo ero riiuscito a risolvere il prblema in altro modo.
    In effetti, è stato sufficiente rilanciare il Wizard per l'installazione di SBS Server 2003 è giunta sull'installazione di Exchange mi ha segnalato che mancavano solo 7 MB per la sua definizione. Un pò timoroso, ho lasciato proseguire il setup e dopo un errore comparso proprio sul file setup.exe, questa ha terminato correttamente la sua opera.

    Ho rilanciato la Sp2 di Exchange server ed è andata a buon fine, portando a termine qulasiasi aggiornamento. Ho eseguito le verifiche sulle cassette postali e sull'integrità dei servizi e tutto è perfettamente funzionante.

    Ringrazio chi si è speso per questa soluzione.


    Andynap
    • Contrassegnato come risposta Anca Popa giovedì 30 giugno 2011 09:15
    giovedì 30 giugno 2011 07:16

Tutte le risposte

  • Se vai su Microsoft Update e non windows update? Che aggiornamneti vedi?


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    lunedì 27 giugno 2011 21:16
    Moderatore
  • Ho eseguito tutti i download consigliati. Non risulta nulla di anomalo, ho scaricato e configurato persino gli aggiornamenti non indispensabili. Allo stato attuale non risulta nulla da aggiornare!
    Andynap
    martedì 28 giugno 2011 09:29
  • Ma dalla console di exchange, se vai su server, che versione ti da?
    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    martedì 28 giugno 2011 10:05
    Moderatore
  • Sistema di Exchange
    Microsoft Corporation
    Versione 6.5.6944.0

    In pratica la versione base senza neppure Sp1!


    Andynap
    martedì 28 giugno 2011 10:18
  • Questa è la versione da CD senza SP.

    http://www.microsoft.com/downloads/it-it/details.aspx?FamilyID=535bef85-3096-45f8-aa43-60f1f58b3c40

    Hai scaricato la sp da qui?

    Nel caso posto l'errore preciso che ti restituisce l'install.


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    martedì 28 giugno 2011 12:01
    Moderatore
  • Quando provo ad installare la service pack 2 (scaricata dal link che mi hai suggerito!) la schermata che compare ha la seguente dicitura per esteso:

    Installazione guidata di Microsoft Exchange
    Impossibile assegnare più componenti sulle operazioni richieste perchè:
    -Prima di installare questo service pack di Micorsoft Exchange è necessario che nel computer sia installato Exchage server 2003.
    Impossibile assegnare il componente 'servizi di messaggistica e collaborazione di Micorsoft Exchange' sull'operazione 'aggiorna perchè:
    Nel service pack 3 per Micorsoft Exchange 2003 è inclusa una versione aggiornata del filtro messaggi intelligente di Micorsoft Exchange. Nel sistema è stata rilevata una versione precedente del filtro che dovrà essere disinstallata prima di applicare il servoce pack2.

    Chiaramente ho già provveduto a rimuove IMF e le relative chiavi di registro, inoltre ho provveduto a rimuovere e reinstallare il servizio NNTP.

    Tutto sembra legato a qualche chiave di registro non copiata in fase di prima installazione che non fa capire alla sp2 di Micorsoft Exchange che qwuesto è installatro e presente. Ti risulta che la sp2 faccia dei controlli particolari a livello di chiavi di registro?


    Andynap
    martedì 28 giugno 2011 12:50
  • http://support.microsoft.com/kb/935916/en-us

     

    Leggi qui.

     

    Ciao.


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCP - MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    martedì 28 giugno 2011 13:06
    Moderatore
  • Chiramente dopo aver rimosso i filtri IMF la schermata che compare è:

    Installazione guidata di Microsoft Exchange
    Impossibile assegnare più componenti sulle operazioni richieste perchè:
    -Prima di installare questo service pack di Micorsoft Exchange è necessario che nel computer sia installato Exchage server 2003.

    Sto facendo le prove di risoluzione del problema su un image del server, per poi eseguirla sulla macchina reale. Sperando di venirne a capo!


    Andynap
    martedì 28 giugno 2011 13:12
  • Caro Peppacci è stata la prima operazione che ho fatto: ero convinto che la KB 935916 fosse subito risolutiva, ma purtroppo non è così. L'errore come ti ho già postato viene solo ridotto, ma rimane piuttosto grave!
    Andynap
    martedì 28 giugno 2011 13:19
  • Ciao Andynap,

    Mi intrometto nella discussione.

    Quando il setup del service pack viene eseguito, viene effettuata una ricerca nei registri per ritracciare informazioni in merito al software installato sul server.

    Alcune chiavi di registro mancanti potrebbero causare il messaggio di errore visto sopra. Inoltre, il Setup Log di Exchange (sul disco C), potrebbere rilevare un’entrata simile a questa:

    [20:24:08] Leaving CFileManager::ScSetInstallDestDir(sz)
    [20:24:26] - You must have Exchange Server2003 installed onthis machine before installing this Microsoft Exchange Server Service Pack. -- ID:62114 --
    [20:24:26] Prerequisites for Microsoft Exchange failed: The component "Microsoft Exchange
    " cannot be assigned the action "Update" because:
    - You must haveExchange Server 2003 installed on thismachine before installing this Microsoft Exchange Server Service Pack.

    Vai in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Setup e cerca le chiavi seguenti:

    "NewestBuild"=dword: (6944)
    "CurrentBuild"=dword: (473563136)

    Nel caso contrario, prova a crearle (magari esportando prima il registro e salvandolo sul disco D).

    Riprova a installare il SP2, se riesci facci sapere e riavvia il server.

    Avviso di Microsoft
    L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    mercoledì 29 giugno 2011 13:19
  • Grazie per la segnalazione, diciamo che è giunta non tempestiva, perchè nel frattempo ero riiuscito a risolvere il prblema in altro modo.
    In effetti, è stato sufficiente rilanciare il Wizard per l'installazione di SBS Server 2003 è giunta sull'installazione di Exchange mi ha segnalato che mancavano solo 7 MB per la sua definizione. Un pò timoroso, ho lasciato proseguire il setup e dopo un errore comparso proprio sul file setup.exe, questa ha terminato correttamente la sua opera.

    Ho rilanciato la Sp2 di Exchange server ed è andata a buon fine, portando a termine qulasiasi aggiornamento. Ho eseguito le verifiche sulle cassette postali e sull'integrità dei servizi e tutto è perfettamente funzionante.

    Ringrazio chi si è speso per questa soluzione.


    Andynap
    • Contrassegnato come risposta Anca Popa giovedì 30 giugno 2011 09:15
    giovedì 30 giugno 2011 07:16
  • Ciao Andynap,

    Sono lieta di sapere che sei riuscito a risolvere nel frattempo e ti ringrazio di aver aggiornato il thread con le ultime notizie.

    Buona giornata,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    giovedì 30 giugno 2011 09:15