none
Exchange 2007 ed Exchange 2010 non si scambiano email interne. RRS feed

  • Domanda

  • Ciao a tutti.

    Sto cercando di migrare le cassette postali da Exchange 2007 a 2010:

    Server1 - Exchange 2007 SP3 su Windows 2008 SE

    Server2 - Exchange 2010 SP1 rollup1 su Windows 2008 R2

    Ho migrato alcune cassette postale di test, da Exchange 2007 a Exchange 2010. Tutto ok, vedo owa, ed invio email interne tra tes1@ex2010.azienda.local e test2@ex2010.azienda.local

    Le domande sono le seguenti:

    1. E' normale che utente@ex2007 .azienda.local non riesca ad inviare e rivecere email da test@ex2010 .azienda.local? utente@ex2007 riceve una email che gli notifica:

      Il messaggio non è stato ancora recapitato. Microsoft Exchange continuerà a tentare di recapitare il messaggio per conto del mittente.

    2. E' possibile che solo Exchange2007, in chissà che fase della sua configurazione, sia settato in modo da negare l'invio di email da altri server diverso da lui? Se si qual'è la voce da controllare?

    Quale sarebbero i prossimi step a vostro avviso?

    Grazie 1000.

    • Modificato Anca Popa giovedì 21 ottobre 2010 14:52 formattazione
    • Tipo modificato Anca Popa martedì 2 novembre 2010 14:00 attesa di feedback/ ricerca di soluzione
    • Tipo modificato Andreagx mercoledì 10 novembre 2010 09:30 Soluzione trovata
    • Tipo modificato Andreagx mercoledì 10 novembre 2010 09:30 Soluzione trovata
    giovedì 21 ottobre 2010 14:12

Risposte

Tutte le risposte

  • Su entrambi i server è installato il ruolo Hub Transport? Le due versioni di exchange si scambiano i messaggi a livello smtp.

    --
    Peppacci - MVP -
    Microsoft Exchange Server
    http://blogs.sysadmin.it/peppacci/Default.aspx

    Peppacci - MVP - Microsoft Exchange Server http://blogs.sysadmin.it/peppacci/Default.aspx
    giovedì 21 ottobre 2010 14:33
    Moderatore
  • Su entrambi i server è installato il ruolo Hub Transport? Le due versioni di exchange si scambiano i messaggi a livello smtp.

    --
    Peppacci - MVP -
    Microsoft Exchange Server
    http://blogs.sysadmin.it/peppacci/Default.aspx

    Peppacci - MVP - Microsoft Exchange Server http://blogs.sysadmin.it/peppacci/Default.aspx


    Si, entrambi hanno il ruolo hub transport.

    giovedì 21 ottobre 2010 14:49
  • I rispettivi send e receive connector sono abilitati sulla porta 25 di entrambe le macchine? Dalla console del message tracking dovresti cercare i relativi messaggi e vedere qual'è il problema riscontrato. Fai girare anche il BPA su entrambi i server.

    --
    Peppacci - MVP -
    Microsoft Exchange Server
    http://blogs.sysadmin.it/peppacci/Default.aspx

    Peppacci - MVP - Microsoft Exchange Server http://blogs.sysadmin.it/peppacci/Default.aspx
    giovedì 21 ottobre 2010 14:59
    Moderatore
  • I rispettivi send e receive connector sono abilitati sulla porta 25 di entrambe le macchine? Dalla console del message tracking dovresti cercare i relativi messaggi e vedere qual'è il problema riscontrato. Fai girare anche il BPA su entrambi i server.

    Dato che Exchange 2007 funziona bene ho copiato tutti i settaggi e li ho riprodotti in Exchange 2010:

    • Exchange 2007

    Client

    Tab generale: l'fqdn è ex2007.azienda.local
    Tab rete: Porta 587
    Tab Autenticazione: TLS / Autent. di base / Consenti aut. di base solo dopo l'avvio di TLS / Aut. di Exchange
    Tab Gruppi di autorizzazioni: solo Utenti di exchange

    Default

    Tab generale: l'fqdn è mail.azienda.it
    Tab rete: Porta 25
    Tab Autenticazione: TSL / Autenticazione di base
    Tab Gruppi di autorizzazioni: tutti tranne partner
    • Exchange 2010

    Client

    Tab generale: l'fqdn è ex2010.azienda.local
    Tab rete: idem
    Tab Autenticazione: idem
    Tab Gruppi di autorizzazioni: idem

    Default

    Tab generale: l'fqdn è ex2010.azienda.local
    Tab rete: idem
    Tab Autenticazione: idem
    Tab Gruppi di autorizzazioni: idem
    • Le note di BPA (non dovrebbero generare questo problema)  sono
    - SSL abilitato nella directory radice IIS
    - Record 'Host' DNS mancante (è giù il dns 2)
    - 'Active Server Pages' non installato
    - Trovato certificato autofirmato

    Nella verifica del flusso dei messaggio ho effettivamene degli errori (non un warning come gli altri)

    1. Errore durante l'esecuzione di 'test-MapiConnectivity -Server EX2010 -PerConnectionTimeout 120'. Messaggio di errore: Il parametro StorageGroup non è valido..
    2. Errore Errore nell'accettazione della posta Area Hub Transport Server Role Health Il server remoto EX2007 non ha superato il test di accettazione della posta nel tentativo di aprire il socket remoto: Respond = Remote socket is not available.

     

    giovedì 21 ottobre 2010 15:38
  • Hai inserito entrambi gli hub transport nel send connector?

    --
    Peppacci - MVP -
    Microsoft Exchange Server
    http://blogs.sysadmin.it/peppacci/Default.aspx

    Peppacci - MVP - Microsoft Exchange Server http://blogs.sysadmin.it/peppacci/Default.aspx
    venerdì 22 ottobre 2010 07:08
    Moderatore
  • Hai inserito entrambi gli hub transport nel send connector?

    --
    Peppacci - MVP

     

    Rieccomi.

    Scusami, cosa dovrei fare di preciso?

    martedì 26 ottobre 2010 08:38
  • Aggiornamento:

    dalla console di exchange 2010 ho selezionato "Configurazione dell'organizzazione\Trasporto Hub\Connettori di invio ", ho modificato l'unico connettore di invio presente (azienda.it) aggiungendo ex2010 al tab "Server di origine "

    Adesso l'utente configurato su ex2010:

    • può inviare email ad indirizzi esterni
    • non può ricevere email da indirizzi esterni
    • non può ricevere ed inviare email interne da Ex2007
    • può ricevere ed inviare email interne da Ex2010
    Consigli?
    martedì 26 ottobre 2010 12:15
  • Ciao L-M-Info,

    Esegui "Mail Flow Troubleshooter"  sotto "Toolbox"  sia da Exchange 2007 che da Exchange 2010

    Analizziamo i report.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    martedì 26 ottobre 2010 18:35
  • Ciao Andrea,

    allora, i test eseguiti sia su Ex2007 che su Ex2010 generano lo stesso errore:

    • Invio posta non riuscito: Messaggio di errore: Il server SMTP richiede una connessione protetta oppure il client non è stato autenticato. Risposta del server: 5.7.1 Client was not authenticated.

    Se faccio un controllo sul flusso dei messaggi ottengo questo:

    da ut@ex2007.it a ut@ex2010.it

    http://img168.imageshack.us/img168/5180/senzanomer.jpg

    Ho provato anche a disabilitare tutta la protezione interna di Exchagne, ma non cambia niente.

     

    mercoledì 27 ottobre 2010 09:42
  • Ciao L-M-Info,

    Ti suggerisco di eliminare e successivamente ricreare i connettori (in primis gli Internal).

    Se non dovessi risolvere scarica, installa ed esegui Microsoft Product Support Reports. (su entrambi i server di exchange)

    Crea uno zip con password e carica i report on the cloud (ad esempio su skydrive)

    Invia il link al file e la password a: ngc7771 at live dot com


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Modificato Andreagx mercoledì 27 ottobre 2010 12:35 typo er
    mercoledì 27 ottobre 2010 12:21
  • Cominciamo con Exchange 2007 (SRV03),

    1.   Durante la fase di troubleshooting  ti suggerisco di disabilitare gli agenti di trasposto, in particolare
    quelli di terze parti
    Disable-TransportAgent –Identity “Panda Security for Exchange Servers Routing Agent”

     

    2.  Disabilita la regola di trasporto “Disabilitare SMTP verso internet”

     

    3.   Hai ucciso Il connettore di default “Default SRV03” impostando erroneamente i permessi di AnonymousUsers e settando un FQDN mail.xxxxx.it. !!!
    Se non vuoi essere la felicità di SPAMBOT, Hacker e via dicendo ti suggerisco di creare un connettore dedicato alla ricezione delle email internet e di lasciare che il default faccia il suo lavoro con le dovute permission. (non AnonymousUsers)

     

    Al tal proposito leggi :

     

    http://social.technet.microsoft.com/Forums/it/benvenutiannunciit/thread/d42378b2-d49e-49ba-957e-4838431f001c

     

    e magari anche:

     

    http://blogs.dotnethell.it/obiwan/Mettere-in-piedi-un-mailserver__9791.aspx

     

     

    Inizia a sistemare le cose di cui sopra .. asap analizzo il report dell'altro server.

     

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 27 ottobre 2010 19:08
  • Sembra che MPS non riesca ancora a ricavare i dati di Exchange 2010.

    Inviami il risultato di:

    Get-ReceiveConnector |FL

    Get-SendConnector |FL 


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    giovedì 28 ottobre 2010 06:55
  • Cominciamo con Exchange 2007 (SRV03),

    1.   Durante la fase di troubleshooting  ti suggerisco di disabilitare gli agenti di trasposto, in particolare
    quelli di terze parti
    Disable-TransportAgent –Identity “Panda Security for Exchange Servers Routing Agent”

    Fatto

    2.  Disabilita la regola di trasporto “Disabilitare SMTP verso internet”

    Fatto

    3.   Hai ucciso Il connettore di default “Default SRV03” impostando erroneamente i permessi di AnonymousUsers e settando un FQDN mail.xxxxx.it. !!!
    Se non vuoi essere la felicità di SPAMBOT, Hacker e via dicendo ti suggerisco di creare un connettore dedicato alla ricezione delle email internet e di lasciare che il default faccia il suo lavoro con le dovute permission. (non AnonymousUsers)

    Avevo seguito alcune guide sul web, poi avevo fatto i test sulla sicurezza e non avevo problemi di openrelay o simili.

    Nel 5° post di questo thread avevo descritto la configurazione dei connettori. Nello specifico come riporto il connettore di default alle condizioni "normali"? Ps, ti ho inviato i comandi richiesti.

    giovedì 28 ottobre 2010 08:43
  • Ciao L-M-Info,

    Rifai i connettori in questo modo (magari esegui un bel backup prima) :

    Su SRV03

    1. Crea un connettore Client (da wizard) FQDN : srv03.Inforel.local

    2. Crea un connettore Internet (dal wizard) e metti come FQDN: mail.dominioesterno.it

    3. Crea un connettore Internal (dal wizard) come FQDN srv03.Inforel.local

    3. Nel Send Connector devi aggiungere entrambi i servers HT (Proprietà, Source Servers)

    Verdai lo stesso Send Connector su entrambi i servers

    Su EX2010 Test

    1. Crea un connettore Client (da wizard) FQDN : Ex2010test.Inforel.local

    2. Crea un connnetore "Default EX2010" con FQDN: Ex2010test.Inforel.local

    PG: ExchangeUsers, ExchangeServers, ExchangeLegacyServers

    AuthMechanism : Tls, BasicAuth, BasicAuthRequireTLS, ExchangeServer

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Contrassegnato come risposta Andreagx mercoledì 10 novembre 2010 09:33
    giovedì 28 ottobre 2010 16:21
  • Domani, in orari "decenti" faccio le prove :)

    A domani

    martedì 2 novembre 2010 16:55
  • Su SRV03

    1. Crea un connettore Client (da wizard) FQDN : srv03.Inforel.local

    OK

    2. Crea un connettore Internet (dal wizard) e metti come FQDN: mail.dominioesterno.it

    OK

    3. Crea un connettore Internal (dal wizard) come FQDN srv03. Inforel.local
    Quando creo il connettore Internal, se lascio tutto in default mi da errore:

    I nternal
    Non riuscito

    Errore:
    I valori specificati per i parametri Bindings e RemoteIPRanges sono in conflitto con le impostazioni nel connettore di ricezione "SRV03\Internet". Un connettore di ricezione deve avere una combinazione univoca di un indirizzo IP locale, dei binding della porta e degli intervalli di indirizzi IP remoti. Modificare almeno uno di questi valori.
    Comando di Exchange Management Shell tentato:
    new-ReceiveConnector -Name 'Internal' -Usage 'Internal' -RemoteIPRanges '0.0.0.0-255.255.255.255' -Server 'SRV03'

    L'ho ricreato settando l'ip privato del server SRV03, corretto?

     

    3. Nel Send Connector devi aggiungere entrambi i servers HT (Proprietà, Source Servers)

    OK

     

    Su EX2010 Test

    1. Crea un connettore Client (da wizard) FQDN : Ex2010test.Inforel.local

    OK

    2. Crea un connnetore "Default EX2010" con FQDN: Ex2010test.Inforel.local

    Qui non ho capito, che tipo di connettore?

     

    PG: ExchangeUsers, ExchangeServers, ExchangeLegacyServers

    AuthMechanism : Tls, BasicAuth, BasicAuthRequireTLS, ExchangeServer

    Queste conf si intendono su che connettore? solo sul server Ex2010? Sul server SRV03 lascio tutto "standard"?

    Grazie 1000


    mercoledì 3 novembre 2010 18:01
  • > 2. Crea un connnetore "Default EX2010" con FQDN: Ex2010test.Inforel.local

    > Qui non ho capito, che tipo di connettore?

    Custom

    con queste impostazioni: 

    PG: ExchangeUsers, ExchangeServers, ExchangeLegacyServers

    AuthMechanism : Tls, BasicAuth, BasicAuthRequireTLS, ExchangeServer

    Il resto va bene.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Contrassegnato come risposta Andreagx mercoledì 10 novembre 2010 09:33
    mercoledì 3 novembre 2010 19:51
  • Ciao,

    Allora ho fatto tutte le prove del caso, ho eliminato i connettori, li ho ricreati come richiesto seguendo le istruzioni. Ho installato i vari aggiornamenti/rollup su entrambi i server e li ho riavviati, ma la situazione è rimasta sostanzialmente inviariata.

    Di seguito la descrizione dettagliata delle modifiche e delle prove:

    SRV03

    Tipo connettore Generale (FQDN) Rete Autenticazione Gruppi di autent.
    Client srv03.azienda.local Porta 587
    Tutta la rete
    TLS
    Autent. base
    Autent. base TLS
    Autent. windows
    Utenti Exchange
    Internet mail.azienda.it Porta 25
    Tutta la rete
    Solo TLS Utenti anonimi
    Internal srv03.azienda.local Porta 25
    192.168.1.3 (SRV03)
    192.168.1.102 (Ex2010)
    TLS
    Autent. di Exchange
    Server Exchange
    Server Exchange Legacy

    EX2010Test

    Tipo connettore Generale (FQDN) Rete Autenticazione Gruppi di autent.
    Client EX2010TEST.azienda.local Porta 587
    Tutta la rete
    TLS
    Autent. base
    Autent. base TLS
    Autent. windows
    Utenti Exchange
    Custom srv03.azienda.local Porta 25
    Tutta la rete
    TLS
    Autent. base
    Autent. base TLS
    Autent. Exchange Server
    Utenti Exchange
    Server Exchange
    Server Exchange Legacy

    Il connettore di invio è così settato (su entrambi i server)

    Generale (FQDN) Spazio indirizzo Rete Server di origine
    mail.azienda.it SMTP / * / 1 Utilizza MX DNS SRV03
    EX2010TEST

    Facendo varie prova di invio/ricezione ottengo i seguenti risultati:

      A Utente Gmail A Utente1 su Srv03 A Utente2 su Srv03 A Utente1 su Ex2010 A Utente2 su Ex2010
    Da Utente Gmail SI SI SI NO NO
    Da Utente1 su Srv03 SI SI SI NO NO
    Da Utente2 su Srv03 SI SI SI NO NO
    Da Utente1 su Ex2010 SI NO NO SI SI
    Da Utente2 su Ex2010 SI NO NO SI SI

     

    Dopo un po di tempo, i messaggi che non sono stati recapitati tornano al mittente con questa segnalazione:

    Il recapito è ritardato per i seguenti destinatari o liste di distribuzione:
    utente1@ex2010.azienda.local
    Oggetto: Test 22:01
    Il messaggio non è stato ancora recapitato. Microsoft Exchange continuerà a tentare di recapitare il messaggio per conto del mittente.
    Il recapito di questo messaggio verrà tentato fino a 05/11/2010 22.01.49 (GMT + 1.00 h) Amsterdam, Berlino, Berna, Roma, Stoccolma, Vienna. Verrà inviato un messaggio di notifica se il messaggio non può essere recapitato entro l'ora specificata.
    giovedì 4 novembre 2010 10:36
  • Ciao,

    Abilita il Protocol Logging per tutti i connettori SMTP

    http://technet.microsoft.com/en-us/library/bb124531.aspx

    Manda le email come da schemino.

    Carica i log in uno spazio condiviso.

    Vorrei vedere anche la zona primaria del DNS, inoltre ti richiedo di ri-verificare se ci sono EventID utili.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    giovedì 4 novembre 2010 14:41
  • Ciao
    Prima di fare i test che mi hai chiesto ho riverificato gli eventi.
    Quando creo i connettori di ricezione viene scritto un errore negli eventi, il seguente

    Origine: MSExchange Management Application
    ID Evento: 5000
    Categoria attività: AdminAuditLog
    Livello: Errore
    Utente: N/D
    Computer: Ex2010Test.aziendal.local
    Parola chiave: Classico
     
    Impossibile salvare il registro di controllo dell'amministratore per questo cmdlet.
    Organizzazione: 
    Contenuto del registro:
    Subject: Azienda.local/Users/Administrator : New-ReceiveConnector
    Body:
    Cmdlet Name: New-ReceiveConnector
    Object Modified: EX2010TEST\Connettore Client
    Parameter: Name = Connettore Client
    Parameter: Usage = Client
    Parameter: RemoteIPRanges = 0.0.0.0-255.255.255.255
    Parameter: Server = EX2010TEST
    Property Modified: MaxProtocolErrors = 5
    Property Modified: Fqdn = EX2010TEST.azienda.local
    Property Modified: RawName = Connettore Client
    Property Modified: MaxInboundConnection = 5000
    Property Modified: MaxInboundConnectionPerSource = 20
    Property Modified: OrganizationId =
    Property Modified: Id = EX2010TEST\Connettore Client
    Property Modified: RemoteIPRanges = 0.0.0.0-255.255.255.255
    Property Modified: PermissionGroups = ExchangeUsers
    Property Modified: SecurityFlags = 15
    Property Original: MaxProtocolErrors = unlimited
    Property Original: Fqdn =
    Property Original: RawName =
    Property Original: MaxInboundConnection = unlimited
    Property Original: MaxInboundConnectionPerSource = unlimited
    Property Original: OrganizationId =
    Property Original: Id =
    Property Original: RemoteIPRanges = 0.0.0.0-255.255.255.255
    Property Original: PermissionGroups = None
    Property Original: SecurityFlags = 29
    Caller: Azienda.local/Users/Administrator
    Succeeded: True
    Error: Nessuno
    Run Date: 2010-11-05T10:09:48
    OriginatingServer: EX2010TEST (14.01.0218.011)
     
    Errore:
    Eccezione generata durante l'operazione AdminLogProvisioningHandler.Validate: Microsoft.Exchange.Data.Storage.ObjectNotFoundException: Impossibile trovare la cassetta postale di individuazione, cassetta postale nascosta predefinita necessaria per la ricerca di cassette postali. �? possibile che sia stata eliminata accidentalmente. �? necessario ricrearla per poter eseguire nuovamente la ricerca di cassette postali.
       in Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.GetDiscoveryMailbox(ADRecipientSession session)
       in Microsoft.Exchange.Management.SystemConfigurationTasks.AdminAuditLogHelper.CheckArbitrationMailboxStatus(OrganizationId organizationId, ADUser& user, ExchangePrincipal& principal, String& errorMessage)
     
    Ma non mi sembra di aver cancellato alcun account o cassetta postale dal nuovo server.
    Consigli su come procedere?
    venerdì 5 novembre 2010 10:23
  • Controlla se esiste un Mailbox di sistema che si chiama Discovery.

    Se non esiste creala

    http://technet.microsoft.com/en-us/library/dd638177.aspx

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Contrassegnato come risposta Andreagx mercoledì 10 novembre 2010 09:33
    venerdì 5 novembre 2010 10:57
  • La maibox non esisteva:
    [PS] C:\>Get-Mailbox -Resultsize unlimited -Filter {RecipientTypeDetails -eq "DiscoveryMailbox"}
    [PS] C:\>
     
    Quindi l�??ho creata:
    [PS] C:\>New-Mailbox SearchResults -Discovery -UserPrincipalName discovery@azienda.it
     
    Name                      Alias                ServerName       ProhibitSendQuota
    ----                      -----                ----------       -----------------
    SearchResults             discovery            ex2010test       50 GB (53,687,091,200 bytes)
     
    Il problema persiste, quando creo il connettore viene scritto quell�??errore nell�??event viewer.
    venerdì 5 novembre 2010 11:26
  • Ciao.
    Allora ho riavviato i server, la situazione si è sbloccata per un certo verso:
     
      A Utente Gmail A Utente1 su Srv03 A Utente2 su Srv03 A Utente1 su Ex2010 A Utente2 su Ex2010
    Da Utente Gmail SI SI SI NO NO
    Da Utente1 su Srv03 SI SI SI NO NO
    Da Utente2 su Srv03 SI SI SI NO NO
    Da Utente1 su Ex2010 SI SI SI SI SI
    Da Utente2 su Ex2010 SI SI SI SI SI
     
    Adesso, come vedi dalla tabella, l'utente su Exchange 2010 invia correttamente all'utente su Exchange 2007.
    Il problema rimane la ricezione di Exchange 2010, non viene scritto niente nei log 'SMTPReceive'.
    Ho fatto l'upload dei log, ti ho inviato una email con link e password.
     
    Grazie 1000
    Luca
     
    "- Andrea Gallazzi -" ha scritto nel messaggio news:62379a40-0454-440f-8d06-71a75d3c5aa1@communitybridge.codeplex.com...
    lunedì 8 novembre 2010 14:16
  • Intanto verifica che il tuo Sonicwall non sia configurato come SMTP proxy. Se lo è disattivalo.

    Ri-esegui Mail Flow Troubleshooter da Toolbox


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    lunedì 8 novembre 2010 22:30
  • Ho installato i nuovi aggiornamenti e riavviato entrambi i server.
    Adesso sembra tutto funzionante, riesco ad inviare e ricevere le email.
    Non c'era niente di "sbagliato" nelle ultime configurazioni, ma non riesco ad identificare l'origine dei problemi che ho avuto. Il sonicwall non è configurato come smtp proxy, non avevo filtri strani, fattostà che adesso funziona tutto.
    Adesso incido nel marmo la configurazione dei connettori.

    Grazie 1000 Andrea, sei stato utilissimo.
    mercoledì 10 novembre 2010 08:40