none
Incompatibilità / problema di installazione di CMClient da SCCM 1906 su Windows 7 Sp1 RRS feed

  • Domanda

  • Ciao a tutti, 

    come da oggetto, mi sono accorto che una volta aggiornato l'SCCM alla 1906 l'installazione del Client ( configuration Manager Client ) su Windows 7 SP1, inteso come installazione del sistema operativo da Task Sequence, non funziona piu, ovvero non si installa dando una serie di errori dei quali non ho ancora trovato il filo della matassa.
    Stessa cosa accade anche se lo installo manualmente.

    Ora, so perfettamente che Windows 7 sarà abbandonato nel breve, difatti stiamo già migrando a 10, ma volevo chiedere se questo problema è un problema risaputo, oppure se è una cosa voluta per via della fine del sistema operativo, oppure ce l'ho solo io e andrebbe sistemata in quanto al momento ancora in essere.

    A disposizione per chiarimenti





    • Modificato UnclePear venerdì 6 settembre 2019 13:09
    venerdì 6 settembre 2019 10:35

Risposte

Tutte le risposte

  • Per il supporto a Windows 7 è necessario installare prima sul client l'aggiornamento SHA-2:
    https://support.microsoft.com/en-us/help/4472027/2019-sha-2-code-signing-support-requirement-for-windows-and-wsus
    sabato 7 settembre 2019 13:28
    Moderatore
  • Ciao e grazie per la risposta,

    Si, l'aggiornamento è stato installato, ma il problema c'è sempre, sotto riportate più o meno le ultima 20 righe con gli errori :

    Couldn't verify 'C:\WINDOWS\ccmsetup\ccmsetup.cab' authenticode signature. Return code 0x80096005 ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)
    Sending state '316'... ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)
    Updating MDM_ConfigSetting.ClientDeploymentErrorCode with value 2147500037 ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)
    OS is not Win10RS3+, ENDOK. ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)
    Failed to get client version for sending state messages. Error 0x8004100e ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)
    [] Params to send '5.0.8853.1000 Deployment Error 0x80004005. Pre-req file name: C:\WINDOWS\ccmsetup\ccmsetup.cab' ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)
    A Fallback Status Point has not been specified and no client was installed.  Message with STATEID='316' will not be sent. ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)
    Failed to send status 316. Error (87D00215) ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)
    Failed to extract manifest cab file with error 0x80004005. Try next location. ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)
    Enumerated all 1 DP locations but none of them is good. Fallback to MP. ccmsetup 09/09/2019 07:58:08 2652 (0x0A5C)


    Trying without proxy. ccmsetup 09/09/2019 07:54:48 3136 (0x0C40)
    Couldn't verify 'C:\WINDOWS\ccmsetup\ccmsetup.cab' authenticode signature. Return code 0x80096005 ccmsetup 09/09/2019 07:55:02 3136 (0x0C40)
    Sending state '316'... ccmsetup 09/09/2019 07:55:02 3136 (0x0C40)
    Updating MDM_ConfigSetting.ClientDeploymentErrorCode with value 2147500037 ccmsetup 09/09/2019 07:55:02 3136 (0x0C40)
    OS is not Win10RS3+, ENDOK. ccmsetup 09/09/2019 07:55:02 3136 (0x0C40)
    Failed to load mdmregistration.dll with error 0x80070057 ccmsetup 09/09/2019 07:55:02 3136 (0x0C40)
    Deleting Comanagement reg keys... ccmsetup 09/09/2019 07:55:02 3136 (0x0C40)
    Failed to connect to policy namespace. Error 0x8004100e ccmsetup 09/09/2019 07:55:02 4076 (0x0FEC)
    Failed to revoke client upgrade local policy. Error 0x8004100e ccmsetup 09/09/2019 07:55:02 4076 (0x0FEC)
    Sending state '301'... ccmsetup 09/09/2019 07:55:02 4076 (0x0FEC)
    Updating MDM_ConfigSetting.ClientDeploymentErrorCode with value 2147500037 ccmsetup 09/09/2019 07:55:02 4076 (0x0FEC)
    OS is not Win10RS3+, ENDOK. ccmsetup 09/09/2019 07:55:02 4076 (0x0FEC)
    CcmSetup failed with error code 0x80004005 ccmsetup 09/09/2019 07:55:02 4076 (0x0FEC)

    Ho verificto tutti gli errori ma non sono risucito a cavarne nulla, probabilmente non devo averlo fatto bene, per questo vi chiedo gentilmente un secondo punto di vista.

    Grazie come sempre per il supporto



    lunedì 9 settembre 2019 06:10
  • prova a vedere qui

    https://forums.prajwaldesai.com/threads/unable-to-install-client-and-application.2382/


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    e[dot]benussi[at]outlook[dot]it

    lunedì 9 settembre 2019 09:20
    Moderatore
  • Potrebbe trattarsi di un problema di lista certificati root non aggiornata sul client Windows 7
    Prova a copiare ccmsetup.cab sul client Windows 7, poi vai nelle proprietà del file e vai su firma digitale.
    Su dettagli verifica che il certificato Microsoft non risulti scaduto o revocato.
    lunedì 9 settembre 2019 21:59
    Moderatore
  • Ciao, allora, confermo quanto avevi già scritto.

    Avevo scaricato l'aggiornamento da te indicato, ma non l'ultimissima versione, difatti scaricando quella rilasciata ad Agosto/settembre ( 2019-09 Security Update for Windows 7 for x64-based Systems (KB4474419) ), tutto ha ripreso a funzionare.
    Con SCCM ho fatto l'update dell'immagine di Windows 7 SP1, ed ora anche in fase di deploy si installa tutto correttamente.

    Grazie come sempre per il supporto

    venerdì 13 settembre 2019 07:46